
<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />



<link rel="shortcut icon" href="https://steelersdepot.com/wp-content/uploads/2020/10/favicon-16x16-1.png" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://steelersdepot.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://steelersdepot.com/feed/atom/" />
<link rel="pingback" href="https://steelersdepot.com/xmlrpc.php" />

<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2021/02/StockPeteWerner1-1000x600.jpg" />
<meta name="twitter:image" content="https://steelersdepot.com/wp-content/uploads/2021/02/StockPeteWerner1-1000x600.jpg" />

<meta property="og:type" content="article" />
<meta property="og:description" content="From now until the 2021 NFL Draft takes place, we hope to showcase as many prospects as possible and examine both their strengths and weaknesses. Most of these profiles will feature individuals that the Pittsburgh Steelers are likely to have an interest in, while a few others will be top-ranked players. If there is a [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/">
<meta name="twitter:title" content="2021 NFL Draft Player Profiles: Ohio State LB Pete Werner">
<meta name="twitter:description" content="From now until the 2021 NFL Draft takes place, we hope to showcase as many prospects as possible and examine both their strengths and weaknesses. Most of these profiles will feature individuals that the Pittsburgh Steelers are likely to have an interest in, while a few others will be top-ranked players. If there is a [&hellip;]">



<script>
(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-1.0.43';
	w.adthrive.host = 'ads.adthrive.com';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/5e387029c4178d20fcc52aa6/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href);
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);
</script>

	<!-- This site is optimized with the Yoast SEO Premium plugin v15.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>2021 NFL Draft Player Profiles: Ohio State LB Pete Werner - Steelers Depot</title>
	<meta name="description" content="From now until the 2021 NFL Draft takes place, we hope to showcase as many prospects as possible and examine both their strengths and weaknesses. Most of" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="2021 NFL Draft Player Profiles: Ohio State LB Pete Werner - Steelers Depot" />
	<meta property="og:description" content="From now until the 2021 NFL Draft takes place, we hope to showcase as many prospects as possible and examine both their strengths and weaknesses. Most of" />
	<meta property="og:url" content="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/" />
	<meta property="og:site_name" content="Steelers Depot" />
	<meta property="article:publisher" content="https://www.facebook.com/steelersdepot" />
	<meta property="article:published_time" content="2021-02-19T16:30:54+00:00" />
	<meta property="article:modified_time" content="2021-02-19T05:24:00+00:00" />
	<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2021/02/StockPeteWerner1.jpg" />
	<meta property="og:image:width" content="1024" />
	<meta property="og:image:height" content="683" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@Steelersdepot" />
	<meta name="twitter:site" content="@Steelersdepot" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://steelersdepot.com/#organization","name":"Steelers Depot","url":"https://steelersdepot.com/","sameAs":["https://www.facebook.com/steelersdepot","https://twitter.com/Steelersdepot"],"logo":{"@type":"ImageObject","@id":"https://steelersdepot.com/#logo","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2015/07/depot-logo.png","width":384,"height":100,"caption":"Steelers Depot"},"image":{"@id":"https://steelersdepot.com/#logo"}},{"@type":"WebSite","@id":"https://steelersdepot.com/#website","url":"https://steelersdepot.com/","name":"Steelers Depot","description":"Pittsburgh Steelers blog featuring news, discussion &amp; merchandise!","publisher":{"@id":"https://steelersdepot.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://steelersdepot.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/#primaryimage","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2021/02/StockPeteWerner1.jpg","width":1024,"height":683,"caption":"COLUMBUS, OH - SEPTEMBER 1: Pete Werner #20 of the Ohio State Buckeyes defends against the Oregon State Beavers at Ohio Stadium on September 1, 2018 in Columbus, Ohio. Ohio State defeated Oregon State 77-31. (Photo by Jamie Sabau/Getty Images)"},{"@type":"WebPage","@id":"https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/#webpage","url":"https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/","name":"2021 NFL Draft Player Profiles: Ohio State LB Pete Werner - Steelers Depot","isPartOf":{"@id":"https://steelersdepot.com/#website"},"primaryImageOfPage":{"@id":"https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/#primaryimage"},"datePublished":"2021-02-19T16:30:54+00:00","dateModified":"2021-02-19T05:24:00+00:00","description":"From now until the 2021 NFL Draft takes place, we hope to showcase as many prospects as possible and examine both their strengths and weaknesses. Most of","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/"]}]},{"@type":"Article","@id":"https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/#article","isPartOf":{"@id":"https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/#webpage"},"author":{"@id":"https://steelersdepot.com/#/schema/person/5650e78b5b6e1bb74e78d918b04f08d1"},"headline":"2021 NFL Draft Player Profiles: Ohio State LB Pete Werner","datePublished":"2021-02-19T16:30:54+00:00","dateModified":"2021-02-19T05:24:00+00:00","mainEntityOfPage":{"@id":"https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/#webpage"},"commentCount":0,"publisher":{"@id":"https://steelersdepot.com/#organization"},"image":{"@id":"https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/#primaryimage"},"keywords":"2021 NFL Draft,Ohio State,Pete Werner,Player Profiles","articleSection":"NFL Draft","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/#respond"]}]},{"@type":"Person","@id":"https://steelersdepot.com/#/schema/person/5650e78b5b6e1bb74e78d918b04f08d1","name":"Devin Jackson","image":{"@type":"ImageObject","@id":"https://steelersdepot.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/4c315a338353cb6f62da9b737328207c?s=96&d=mm&r=g","caption":"Devin Jackson"}}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="https://steelersdepot.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; 2021 NFL Draft Player Profiles: Ohio State LB Pete Werner Comments Feed" href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://steelersdepot.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mvp-reset-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/reset.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-style-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/style.css?ver=5.6.1' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/css/iecss.css?ver=5.6.1' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mvp-style-entertainment-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/style-entertainment.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/media-queries.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://steelersdepot.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='child-main-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/main.min.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/css/bootstrap.min.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='sc-youtube-embed-css'  href='https://steelersdepot.com/wp-content/plugins/sc-youtube-embed/sc-youtube-embed.css?ver=1612538317' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://steelersdepot.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.4' type='text/css' media='all' />
<script type='text/javascript' data-cfasync="false" src='https://steelersdepot.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' data-cfasync="false" src='https://steelersdepot.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://steelersdepot.com/wp-json/" /><link rel="alternate" type="application/json" href="https://steelersdepot.com/wp-json/wp/v2/posts/536174" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://steelersdepot.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://steelersdepot.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/pMvfx-2ftY' />
<link rel="alternate" type="application/json+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2021%2F02%2F2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2021%2F02%2F2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner%2F&#038;format=xml" />
<script type="text/javascript" data-cfasync="false">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</script><script type="text/javascript">//<![CDATA[
  function external_links_in_new_windows_loop() {
    if (!document.links) {
      document.links = document.getElementsByTagName('a');
    }
    var change_link = false;
    var force = '';
    var ignore = '';

    for (var t=0; t<document.links.length; t++) {
      var all_links = document.links[t];
      change_link = false;
      
      if(document.links[t].hasAttribute('onClick') == false) {
        // forced if the address starts with http (or also https), but does not link to the current domain
        if(all_links.href.search(/^http/) != -1 && all_links.href.search('steelersdepot.com') == -1 && all_links.href.search(/^#/) == -1) {
          // console.log('Changed ' + all_links.href);
          change_link = true;
        }
          
        if(force != '' && all_links.href.search(force) != -1) {
          // forced
          // console.log('force ' + all_links.href);
          change_link = true;
        }
        
        if(ignore != '' && all_links.href.search(ignore) != -1) {
          // console.log('ignore ' + all_links.href);
          // ignored
          change_link = false;
        }

        if(change_link == true) {
          // console.log('Changed ' + all_links.href);
          document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
          document.links[t].removeAttribute('target');
        }
      }
    }
  }
  
  // Load
  function external_links_in_new_windows_load(func)
  {  
    var oldonload = window.onload;
    if (typeof window.onload != 'function'){
      window.onload = func;
    } else {
      window.onload = function(){
        oldonload();
        func();
      }
    }
  }

  external_links_in_new_windows_load(external_links_in_new_windows_loop);
  //]]></script>

<style type='text/css'>img#wpstats{display:none}</style>
<style type='text/css'>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</style>
	
<style type="text/css">


.post-cont-out,
.post-cont-in {
	margin-right: 0;
	}




.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -315px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 315px;
	}
.home-left-col {
	float: left;
	}
.home-mid-col {
	float: right;
	margin-left: 15px;
	margin-right: 0;
	}

@media screen and (max-width: 1399px) and (min-width: 1250px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1249px) and (min-width: 1100px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1099px) {
.home-wrap-out2,
.home-wrap-in2 {
	float: left;
	margin-left: 0;
	margin-right: 0;
	}
.home-mid-col {
	float: left;
	}
}
@media screen and (max-width: 479px) {
.home-mid-col {
	margin-left: 0;
	}
}





</style>

<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #eeeeee; }
</style>
	
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<script>
	     (adsbygoogle = window.adsbygoogle || []).push({
	          google_ad_client: "ca-pub-7138622909378284",
	          enable_page_level_ads: true
	     });
	</script>
	
		<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({article:'auto'});
		!function (e, f, u, i) {
			if (!document.getElementById(i)){
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}
		}(document.createElement('script'),
		document.getElementsByTagName('script')[0],
		'//cdn.taboola.com/libtrc/steelersdepot/loader.js',
		'tb_loader_script');
		if(window.performance && typeof window.performance.mark == 'function')
		{window.performance.mark('tbl_ic');}
	</script>
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-11437002-3"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-11437002-3');
</script>
</head>


<body class="post-template-default single single-post postid-536174 single-format-standard custom-background logged-out at-ads-allowed">
	<div id="site" class="left relative">
		<div id="site-wrap" class="left relative">
						<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
									<li class="fb-soc">
						<a href="https://www.facebook.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-facebook-square fa-2"></i>
						</a>
					</li>
													<li class="twit-soc">
						<a href="https://twitter.com/Steelersdepot" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																	<li class="inst-soc">
						<a href="https://www.instagram.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-instagram fa-2"></i>
						</a>
					</li>
																	<li class="yt-soc">
						<a href="https://www.youtube.com/channel/UCFqbkq2BzNY3iQ_FPveqVhw" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-youtube-play fa-2"></i>
						</a>
					</li>
																	<li class="tum-soc">
						<a href="https://steelersdepot.tumblr.com/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-tumblr fa-2"></i>
						</a>
					</li>
													<li class="rss-soc">
						<a href="https://steelersdepot.com/feed/rss/" target="_blank" data-wpel-link="internal">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/" data-wpel-link="internal">Home</a></li>
<li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/" data-wpel-link="internal">Steelers News</a></li>
<li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/" data-wpel-link="internal">Steelers Wire</a></li>
<li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/" data-wpel-link="internal">Podcast</a></li>
<li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li id="menu-item-535831" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-535831"><a href="https://steelersdepot.com/?s=2021+NFL+Draft+Player+Profiles" data-wpel-link="internal">2021 NFL Draft Player Profiles</a></li>
	<li id="menu-item-520576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/" data-wpel-link="internal">2020 NFL Scouting Combine Results Tracker</a></li>
	<li id="menu-item-520575" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/" data-wpel-link="internal">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li id="menu-item-520730" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/" data-wpel-link="internal">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li id="menu-item-515035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li id="menu-item-515038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/" data-wpel-link="internal">Contact Us</a></li>
<li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4" data-wpel-link="external" rel="external noopener noreferrer">Donate</a></li>
<li id="menu-item-496474" class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/" data-wpel-link="internal">Go Ad-Free</a></li>
<li id="menu-item-493254" class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php" data-wpel-link="internal">Login</a></li>
<li id="menu-item-493255" class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout" data-wpel-link="internal">Logout</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->			<div id="head-main-wrap" class="left relative">
				<div id="head-main-top" class="left relative">
																														</div><!--head-main-top-->
				<div id="main-nav-wrap">
					<div class="nav-out">
						<div class="nav-in">
							<div id="main-nav-cont" class="left" itemscope itemtype="http://schema.org/Organization">
								<div class="nav-logo-out">
									<div class="nav-left-wrap left relative">
										<div class="fly-but-wrap left relative">
											<span></span>
											<span></span>
											<span></span>
											<span></span>
										</div><!--fly-but-wrap-->
																					<div class="nav-logo left">
																									<a itemprop="url" href="https://steelersdepot.com/" data-wpel-link="internal"><img itemprop="logo" src="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png" alt="Steelers Depot" data-rjs="2" /></a>
																																					<h2 class="mvp-logo-title">Steelers Depot</h2>
																							</div><!--nav-logo-->
																			</div><!--nav-left-wrap-->
									<div class="nav-logo-in">
										<div class="nav-menu-out">
											<div class="nav-menu-in">
												<nav class="main-menu-wrap left">
													<div class="menu-header-container"><ul id="menu-header-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/" data-wpel-link="internal">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/" data-wpel-link="internal">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/" data-wpel-link="internal">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/" data-wpel-link="internal">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-535831"><a href="https://steelersdepot.com/?s=2021+NFL+Draft+Player+Profiles" data-wpel-link="internal">2021 NFL Draft Player Profiles</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/" data-wpel-link="internal">2020 NFL Scouting Combine Results Tracker</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/" data-wpel-link="internal">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/" data-wpel-link="internal">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/" data-wpel-link="internal">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4" data-wpel-link="external" rel="external noopener noreferrer">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/" data-wpel-link="internal">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php" data-wpel-link="internal">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout" data-wpel-link="internal">Logout</a></li>
</ul></div>												</nav>
											</div><!--nav-menu-in-->
											<div class="nav-right-wrap relative">
												<div class="nav-search-wrap left relative">
													<span class="nav-search-but left"><i class="fa fa-search fa-2"></i></span>
													<div class="search-fly-wrap">
														<form method="get" id="searchform" action="https://steelersdepot.com/">
	<input type="text" name="s" id="s" value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>													</div><!--search-fly-wrap-->
												</div><!--nav-search-wrap-->
																									<a href="https://www.facebook.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
													<span class="nav-soc-but"><i class="fa fa-facebook fa-2"></i></span>
													</a>
																																					<a href="https://twitter.com/Steelersdepot" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
													<span class="nav-soc-but"><i class="fa fa-twitter fa-2"></i></span>
													</a>
																							</div><!--nav-right-wrap-->
										</div><!--nav-menu-out-->
									</div><!--nav-logo-in-->
								</div><!--nav-logo-out-->
							</div><!--main-nav-cont-->
						</div><!--nav-in-->
					</div><!--nav-out-->
				</div><!--main-nav-wrap-->
			</div><!--head-main-wrap-->
										<div id="body-main-wrap" class="left relative" itemscope itemtype="http://schema.org/NewsArticle">
					<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/"/>
																																			<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="body-main-cont" class="left relative">
																		<!-- <div style="margin-bottom:40px">
	<h5>Send Alex to Training Camp</h5>
	<iframe class='gfm-media-widget' image='0' coinfo='0' width='100%' height='100%' frameborder='0' id='steelers-depot-2018-training-camp'></iframe>
	<script src='//funds.gofundme.com/js/5.0/media-widget.js'></script>
	<style>
	.gfm-widget {
		width: 100%;
		max-width: initial;
	}
	</style>
	<script>
	jQuery(function($){
	});
	</script>
</div> --><div id="post-main-wrap" class="left relative">
	<div class="post-wrap-out1">
		<div class="post-wrap-in1">
			<div id="post-left-col" class="relative">
	<article id="post-area" class="post-536174 post type-post status-publish format-standard has-post-thumbnail hentry category-nfl-draft tag-2021-nfl-draft tag-ohio-state tag-pete-werner tag-player-profiles">
			<header id="post-header">
							<a class="post-cat-link" href="https://steelersdepot.com/category/nfl-draft/" data-wpel-link="internal"><span class="post-head-cat">NFL Draft</span></a>
						<h1 class="post-title entry-title left" itemprop="headline">2021 NFL Draft Player Profiles: Ohio State LB Pete Werner</h1>
							<div id="post-info-wrap" class="left relative">
					<div class="post-info-out">
						<div class="post-info-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/4c315a338353cb6f62da9b737328207c?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/4c315a338353cb6f62da9b737328207c?s=100&#038;d=mm&#038;r=g 2x' class='avatar arm_grid_avatar arm-avatar avatar-50 photo' height='50' width='50' loading='lazy'/>						</div><!--post-info-img-->
						<div class="post-info-in">
							<div class="post-info-right left relative">
								<div class="post-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
									<span class="post-info-text">By</span> <span class="author-name vcard fn author" itemprop="name"><a href="https://steelersdepot.com/author/devin-jackson/" title="Posts by Devin Jackson" rel="author" data-wpel-link="internal">Devin Jackson</a></span> 																	</div><!--post-info-name-->
								<div class="post-info-date left relative">
									<span class="post-info-text">Posted on</span> <span class="post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2021-02-19">February 19, 2021 at 11:30 am</time></span>
									<meta itemprop="dateModified" content="2021-02-19"/>
								</div><!--post-info-date-->
							</div><!--post-info-right-->
						</div><!--post-info-in-->
					</div><!--post-info-out-->
				</div><!--post-info-wrap-->
					</header><!--post-header-->
	

			<section class="social-sharing-top">
			<a href="#" onclick="window.open(&#039;http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/&amp;t=2021 NFL Draft Player Profiles: Ohio State LB Pete Werner&#039;, &#039;facebookShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open(&#039;http://twitter.com/share?text=2021 NFL Draft Player Profiles: Ohio State LB Pete Werner -&amp;url=https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/&#039;, &#039;twitterShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
			<a href="whatsapp://send?text=2021 NFL Draft Player Profiles: Ohio State LB Pete Werner https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/" data-wpel-link="internal"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open(&#039;http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/&amp;media=https://steelersdepot.com/wp-content/uploads/2021/02/StockPeteWerner1-1000x600.jpg&amp;description=2021 NFL Draft Player Profiles: Ohio State LB Pete Werner&#039;, &#039;pinterestShare&#039;, &#039;width=750,height=350&#039;); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="/cdn-cgi/l/email-protection#c4fbb7b1a6aea1a7b0f9f6f4f6f5e48a8288e480b6a5a2b0e494a8a5bda1b6e494b6aba2ada8a1b7fee48bacadabe497b0a5b0a1e48886e494a1b0a1e493a1b6aaa1b6e2a5a9b4ff868b809df98de4a2abb1aaa0e4b0acadb7e4a5b6b0ada7a8a1e4adaab0a1b6a1b7b0adaaa3e4a5aaa0e4b0acabb1a3acb0e4aba2e4b7aca5b6adaaa3e4adb0e4b3adb0ace4bdabb1eae487aca1a7afe4adb0e4abb1b0fee4acb0b0b4b7feebebb7b0a1a1a8a1b6b7a0a1b4abb0eaa7aba9ebf6f4f6f5ebf4f6ebf6f4f6f5e9aaa2a8e9a0b6a5a2b0e9b4a8a5bda1b6e9b4b6aba2ada8a1b7e9abacadabe9b7b0a5b0a1e9a8a6e9b4a1b0a1e9b3a1b6aaa1b6eb"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
																	<a href="#disqus_thread"><div class="social-comments comment-click-536174"><i class="fa fa-commenting fa-2"></i></div></a>
									</section><!--social-sharing-top-->
	


																					<div class="left" id="post-feat-img-wrapper">
							<div id="post-feat-img" class="relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
								<img width="1024" height="683" src="https://steelersdepot.com/wp-content/uploads/2021/02/StockPeteWerner1.jpg" class="attachment- size- wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2021/02/StockPeteWerner1.jpg 1024w, https://steelersdepot.com/wp-content/uploads/2021/02/StockPeteWerner1-300x200.jpg 300w, https://steelersdepot.com/wp-content/uploads/2021/02/StockPeteWerner1-768x512.jpg 768w" sizes="(max-width: 1024px) 100vw, 1024px" />																<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2021/02/StockPeteWerner1.jpg">
								<meta itemprop="width" content="1024">
								<meta itemprop="height" content="683">
								<div class="post-feat-text">
																										</div><!--post-feat-text-->
							</div><!--post-feat-img-->
						</div>
																<div id="content-area" itemprop="articleBody" class="post-536174 post type-post status-publish format-standard has-post-thumbnail hentry category-nfl-draft tag-2021-nfl-draft tag-ohio-state tag-pete-werner tag-player-profiles">
		<div class="post-cont-out">
			<div class="post-cont-in">
				<div id="content-main" class="left relative">

						
	
		<div class="post-specific-content">
<p>From now until the 2021 NFL Draft takes place, we hope to showcase as many prospects as possible and examine both their strengths and weaknesses. Most of these profiles will feature individuals that the Pittsburgh Steelers are likely to have an interest in, while a few others will be top-ranked players. If there is a player you would like us to analyze, let us know in the comments below.</p>
<p><strong>#20 Pete Werner Ohio State LB – 6’2” 239 pounds</strong></p>
<p><strong>The Good</strong></p>
<p>– Instinctual athlete with versatile skill set<br />
– Above average athleticism to play sideline to sideline<br />
– Saw snaps at inside LB, S, Slot DB during his time at Ohio State<br />
– Excellent at mirroring routes in zone coverage and phasing out vertical routes<br />
– Physical player who violently re-routes receivers and gets them off their track<br />
– Ability to carry inside receivers and tight ends vertical to prevent completions and cut-off passing lanes<br />
– Effective in delayed blitz scenarios, causes havoc in backfield with physicality at point of attack<br />
– Good starting experience against quality competition<br />
– More consistent in attacking downhill on outside run plays<br />
– Textbook tackler who shows serious pop behind his pads</p>
<p><strong>The Bad</strong></p>
<p>– Showcases slow reaction time in attacking inside zone and power run concepts<br />
– Struggles shedding blocks from guards and tackles who make it to the second level<br />
– Struggles maintaining eye discipline in play action and jet sweep motion fakes concepts, gets out of position<br />
– Showcases stiff hips in one on one situations in boundaries versus tight ends and running backs<br />
– Susceptible to double moves on outside when lined up against speedier, shiftier athletes<br />
– Indecisiveness attacking downhill on run plays allows for cutbacks holes on backside of defense</p>
<p><strong>Bio</strong></p>
<p>– Played in 47 career games, with 35 starts at Ohio State<br />
– Amassed 185 tackles, 16 tackles for loss, 4 forced fumbles and 2 fumble recoveries<br />
– 2017: OSU Scholar-Athlete<br />
– 2018: OSU Scholar-Athlete and Academic All-Big Ten<br />
– 2019: Academic All-Big Ten<br />
– 4-star recruit who played high school ball at Indianapolis Cathedral, chose Ohio State over Notre Dame, Boston College, Illinois, Northwestern and more.<br />
– Father, Greg Werner, played two years in the NFL with the New York Jets and Philadelphia Eagles</p>
<p><strong>Tape Breakdown</strong></p>
<p>Pete Werner is one of the more versatile athletes in the 2021 NFL Draft class, from either side of the ball. His ability to mirror routes in zone coverage, sideline to sideline ability to play single high safety and football instincts to play all over the field makes him an intriguing evaluation. As mentioned above, Werner mainly played the SAM LB role at Ohio State, but has snaps as a single high safety, at slot corner, snaps as the MIKE backer, and more. He was someone who was heavily involved in the Buckeyes special teams units as well.</p>
<p>First thing to note while watching Werner is how he makes 1-2 plays in a game that helped shift momentum for the Buckeyes defense. Earlier this season against Indiana, Werner forced a fumble as Indiana inched closer to scoring a touchdown. Werner delivers a nice pop, just outside of the goal line, giving the Buckeyes offense the ball. Impressive physicality below from Werner.</p>
<div style='position:relative;padding-bottom: calc(56.25% + 44px)'><iframe title="Pete Werner FF" src='https://gfycat.com/ifr/lastingyoungfairyfly' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0;' allowfullscreen></iframe></div>
<p>&nbsp;</p>
<p>There are plenty of reps where Werner is isolated against a tight end in the boundary, and below is one of those reps. Werner is matched up with the Michigan TE Nick Eubanks, who runs a vertical route up the sideline. Werner does a nice job flipping his hips and getting in phase, being patient and waiting for Eubanks to adjust his body to the ball. During the route, Werner does a nice job phasing Eubanks to the sideline and forcing a difficult throw, and making a play on the ball to deflect it away.</p>
<div style='position:relative;padding-bottom: calc(56.25% + 44px)'><iframe title="Pete Werner man coverage" src='https://gfycat.com/ifr/reflectingillustriousdoe' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0;' allowfullscreen></iframe></div>
<p>&nbsp;</p>
<p>One thing Werner needs to improve is shedding blocks more consistently, but he does a nice job against Alabama and Michigan disengaging on outside runs and making the play in the backfield. He attacks downhill on both plays, sets the edge and makes the play. Exactly what you want out of a sideline to sideline linebacker.</p>
<div style='position:relative;padding-bottom: calc(56.25% + 44px)'><iframe title="Pete Werner outside run shed" src='https://gfycat.com/ifr/frequentgiantabalone' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0;' allowfullscreen></iframe></div>
<p>&nbsp;</p>
<p>Werner typically struggles redirecting on play action and RPO concepts but does a nice job reading his keys, transitioning into coverage and making a play on Heisman winner Devonta Smith to break up the pass. He showcases his fluid hips in coverage and instincts to deliver the hit as Smith is attempting to catch the ball.</p>
<div style='position:relative;padding-bottom: calc(56.25% + 44px)'><iframe title="Pete Werner reaction zone coverage" src='https://gfycat.com/ifr/infamousjealousdogfish' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0;' allowfullscreen></iframe></div>
<p>&nbsp;</p>
<p>Werner makes a seamless transition from undercutting the initial out route run by Indiana slot receiver Whop Philyor, staying in his hip pocket and phasing Philyor towards the sideline. It is rare for a linebacker his size to be able to run with some of the fastest athletes on the field.</p>
<div style='position:relative;padding-bottom: calc(56.25% + 44px)'><iframe title="Pete Werner carrying vertical" src='https://gfycat.com/ifr/conventionalemotionaldungenesscrab' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0;' allowfullscreen></iframe></div>
<p>&nbsp;</p>
<p>Being able to pick up on an offenses’ tendencies in something Werner does well at the linebacker position. Werner diagnoses the screen here, and gets downhill quick, stopping the Penn State running back for a minimal gain.</p>
<div style='position:relative;padding-bottom: calc(56.25% + 44px)'><iframe title="Pete Werner reacting screen" src='https://gfycat.com/ifr/gentlecalculatingblackrhino' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0;' allowfullscreen></iframe></div>
<p>&nbsp;</p>
<p>The play below against Indiana is what concerns me with Werner. He adjusts to the motion across the formation, but is fooled by the outside run fake, and instead of remaining square, he gets all the way turned around. Werner has to be better with keeping his body square to his keys, and not vacating his zone because he is fooled by pre-snap motion and play action.</p>
<div style='position:relative;padding-bottom: calc(56.25% + 44px)'><iframe title="Pete Werner out of position" src='https://gfycat.com/ifr/lamevaluablecrocodile' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0;' allowfullscreen></iframe></div>
<p>&nbsp;</p>
<p>There are situations where Werner has stiff hips and allows receivers or running backs to get behind him. Against Indiana, the split out running back makes a subtle move at the top of his route to leave Werner in the dust because he was sitting on a short hitch route. Because he is beat, Werner is in trail position and can’t keep up with the foot speed.</p>
<div style='position:relative;padding-bottom: calc(56.25% + 44px)'><iframe title="Pete Werner stiff hips" src='https://gfycat.com/ifr/blissfulspryhoopoe' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0;' allowfullscreen></iframe></div>
<p>&nbsp;</p>
<p>Werner’s reaction time and block shedding has to be better at the next level. In the first part of the clip against Alabama, Werner bounces around and hesitates, allowing the frontside tackle to wash him out of the play on this power run scheme. Werner has a chance to make the play if he attacks the tackle, and muddies up the run lane for running back Najee Harris.</p>
<p>In the second part of the clip, against Penn State, the backside tackle on this zone scheme doubles up to Werner, and washes him out of the play. Werner has to be better with his physicality when taking on blocks at the point of attack.</p>
<div style='position:relative;padding-bottom: calc(56.25% + 44px)'><iframe title="Pete Werner missing run fits" src='https://gfycat.com/ifr/scaredyellowamericancrow' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0;' allowfullscreen></iframe></div>
<p>&nbsp;</p>
<p>Despite those needed improvements, Werner’s range in Ohio State’s defense was tremendous. The Indiana game was one of his best games on tape in terms of showing off his versatility carrying slot receivers vertically and across the field. In a cover 3 look, Werner transitions into his pass drop and runs step for step with the Indiana slot receiver. Impressive athleticism once again for Werner.</p>
<div style='position:relative;padding-bottom: calc(56.25% + 44px)'><iframe title="Pete Werner carrying inside receiver" src='https://gfycat.com/ifr/grossjoyfulguppy' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0;' allowfullscreen></iframe></div>
<p>&nbsp;</p>
<p>The last thing to highlight with Werner’s versatility is his effectiveness on delayed blitzes. Several times in the Clemson game, Werner forced Trevor Lawrence to make either an errant throw or rushed throw. He showcases imposing physicality when attacking running backs in pass protection and forces quarterbacks to leave the pocket or step up into pressure.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Along with his coverage prowess, an underrated part of <a href="https://twitter.com/hashtag/OSU?src=hash&amp;ref_src=twsrc%5Etfw" data-wpel-link="external" rel="external noopener noreferrer">#OSU</a> LB Pete Werner&#39;s game is how he attacks on delayed blitzes. He disguises it well, then explodes through contact and knocks RB&#39;s off balance. Causes havoc, collapsing the pocket.</p>
<p>Really instinctual, cerebral player. <a href="https://t.co/hxbXhP9Mq5" data-wpel-link="external" rel="external noopener noreferrer">pic.twitter.com/hxbXhP9Mq5</a></p>
<p>&mdash; Devin Jackson (@RealD_Jackson) <a href="https://twitter.com/RealD_Jackson/status/1361691817352306691?ref_src=twsrc%5Etfw" data-wpel-link="external" rel="external noopener noreferrer">February 16, 2021</a></p></blockquote>
<p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>There is no denying that Pete Werner is one of the best coverage linebackers in this 2021 class. He showcases his football intelligence, instincts and athletic ability to be a SAM linebacker at the next level in a 3-4 scheme and play in sub-packages in third down passing situations. Werner also brings value in the special teams game as well, and is the type of player defensive coordinators would love to have on their defense. He’s not an elite athlete and will probably test moderately well, but his upside, specifically in coverage, is one that could benefit the Steelers defense. While he has some work to do in terms of shedding blocks in the run game, and stiffness in man coverage, Werner translates well to the NFL and can be an effective three down linebacker in the modern game.</p>
<p><strong>Projection:</strong> 3rd-4th Round</p>
<p><strong>Games Watched:</strong> vs. Indiana, at Alabama, vs Clemson, at Penn State, at Michigan (2019)</p>
<p>&nbsp;</p>
<table class="tableizer-table">
<tbody>
<tr class="tableizer-firstrow">
<th colspan="5">Previous 2021 NFL Draft Player Profiles</th>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-kentucky-oc-drake-jackson/" data-wpel-link="internal">OC Drake Jackson</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-alabama-oc-landon-dickerson/" data-wpel-link="internal">OC Landon Dickerson</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-penn-state-te-pat-freiermuth/" data-wpel-link="internal">TE Pat Freiermuth</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-north-carolina-rb-javonte-williams/" data-wpel-link="internal">RB Javonte Williams</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-alabama-cb-patrick-surtain-ii/" data-wpel-link="internal">CB Patrick Surtain II</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-alabama-og-deonte-brown/" data-wpel-link="internal">OG Deonte Brown</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-southern-methodist-te-kylen-granson/" data-wpel-link="internal">TE Kylen Granson</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-miami-fl-te-brevin-jordan/" data-wpel-link="internal">TE Brevin Jordan</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-tennessee-ol-trey-smith/" data-wpel-link="internal">OL Trey Smith</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-oklahoma-ot-adrian-ealy/" data-wpel-link="internal">OT Adrian Ealy</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-south-carolina-cb-jaycee-horn/" data-wpel-link="internal">CB Jaycee Horn</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-lsu-cb-kary-vincent-jr/" data-wpel-link="internal">CB Kary Vincent Jr.</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-louisiana-rb-elijah-mitchell/" data-wpel-link="internal">RB Elijah Mitchell</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-alabama-ot-alex-leatherwood/" data-wpel-link="internal">OT Alex Leatherwood</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-boston-college-te-hunter-long/" data-wpel-link="internal">TE Hunter Long</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-alabama-rb-najee-harris/" data-wpel-link="internal">RB Najee Harris</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-georgia-cb-tyson-campbell/" data-wpel-link="internal">CB Tyson Campbell</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-tulsa-lb-zaven-collins/" data-wpel-link="internal">LB Zaven Collins</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-northwestern-db-greg-newsome/" data-wpel-link="internal">DB Greg Newsome</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-virginia-te-tony-poljan/" data-wpel-link="internal">TE Tony Poljan</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-alabama-dl-christian-barmore/" data-wpel-link="internal">DL Christian Barmore</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-memphis-rb-kenneth-gainwell/" data-wpel-link="internal">RB Kenneth Gainwell</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-northwestern-ot-rashawn-slater/" data-wpel-link="internal">OT Rashawn Slater</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-florida-wr-kadarius-toney/" data-wpel-link="internal">WR Kadarius Toney</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-north-carolina-rb-michael-carter/" data-wpel-link="internal">RB Michael Carter</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-washington-edge-joe-tryon/" data-wpel-link="internal">EDGE Joe Tryon</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-oregon-cb-thomas-graham-jr/" data-wpel-link="internal">CB Thomas Graham Jr.</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-clemson-wr-amari-rodgers/" data-wpel-link="internal">WR Amari Rodgers</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-ucla-rb-demetric-felton/" data-wpel-link="internal">RB Demetric Felton</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-oklahoma-c-creed-humphrey/" data-wpel-link="internal">C Creed Humphrey</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-georgia-c-trey-hill/" data-wpel-link="internal">C Trey Hill</a></td>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-lsu-lb-jabril-cox/" data-wpel-link="internal">LB Jabril Cox</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/01/2021-nfl-draft-player-profiles-florida-state-cb-asante-samuel-jr/" data-wpel-link="internal">CB Asante Samuel Jr.</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-missouri-s-joshuah-bledsoe/" data-wpel-link="internal">S Joshuah Bledsoe</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-texas-ot-samuel-cosmi/" data-wpel-link="internal">OT Samuel Cosmi</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-tcu-s-trevon-moehrig/" data-wpel-link="internal">S Trevon Moehrig</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-rb-oklahoma-state-chuba-hubbard/" data-wpel-link="internal">RB Chuba Hubbard</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-cincinnati-s-james-wiggins/" data-wpel-link="internal">S James Wiggins</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-tcu-lb-garret-wallow/" data-wpel-link="internal">LB Garret Wallow</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-mississippi-state-rb-kylin-hill/" data-wpel-link="internal">RB Kylin Hill</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-north-carolina-wr-dazz-newsome/" data-wpel-link="internal">WR Dazz Newsome</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-virginia-tech-rb-khalil-herbert/" data-wpel-link="internal">RB Khalil Herbert</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-cb-shaun-wade/" data-wpel-link="internal">CB Shaun Wade</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-oklahoma-state-wr-tylan-wallace/" data-wpel-link="internal">WR Tylan Wallace</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-oklahoma-rb-rhamondre-stevenson/" data-wpel-link="internal">RB Rhamondre Stevenson</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-cal-cb-camryn-bynum/" data-wpel-link="internal">CB Camryn Bynum</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-usc-wr-amon-ra-st-brown/" data-wpel-link="internal">WR Amon-Ra St. Brown</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-south-carolina-wr-shi-smith/" data-wpel-link="internal">WR Shi Smith</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-notre-dame-lt-liam-eichenberg/" data-wpel-link="internal">OT Liam Eichenberg</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-pittsburgh-edge-patrick-jones/" data-wpel-link="internal">EDGE Patrick Jones</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-nc-state-dt-alim-mcneill/" data-wpel-link="internal">DT Alim McNeill</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-virginia-tech-ot-christian-darrisaw/" data-wpel-link="internal">OT Christian Darrisaw</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-florida-qb-kyle-trask/" data-wpel-link="internal">QB Kyle Trask</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-oregon-state-rb-jermar-jefferson/" data-wpel-link="internal">RB Jermar Jefferson</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-north-dakota-state-qb-trey-lance/" data-wpel-link="internal">QB Trey Lance</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-michigan-ot-jaylen-mayfield/" data-wpel-link="internal">OT Jaylen Mayfield</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-oklahoma-state-ot-tevin-jenkins/" data-wpel-link="internal">OT Teven Jenkins</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ole-miss-te-kenny-yeboah/" data-wpel-link="internal">TE Kenny Yeboah</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-north-carolina-lb-chazz-surratt/" data-wpel-link="internal">LB Chazz Surratt</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-oklahoma-cb-tre-brown/" data-wpel-link="internal">CB Tre Brown</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-texas-am-qb-kellen-mond/" data-wpel-link="internal">QB Kellen Mond</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-missouri-ilb-nick-bolton/" data-wpel-link="internal">LB Nick Bolton</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-byu-ol-brady-christensen/" data-wpel-link="internal">OL Brady Christensen</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-iowa-dl-daviyon-nixon/" data-wpel-link="internal">DL Dayvion Nixon</a></td>
</tr>
<tr>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-washington-cb-elijah-molden/" data-wpel-link="internal">CB Elijah Molden</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-alabama-qb-mac-jones/" data-wpel-link="internal">QB Mac Jones</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-pittsburgh-edge-rashad-weaver/" data-wpel-link="internal">EDGE Rashad Weaver</a></td>
<td><a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-michigan-lb-cameron-mcgrone/" data-wpel-link="internal">LB Cameron McGrone</a></td>
</tr>
</tbody>
</table>
</div>

	<div id="taboola-below-article">
	</div>

															<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
						<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
															<img src="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png"/>
								<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png">
													</div><!--mvp-org-logo-->
						<meta itemprop="name" content="Steelers Depot">
					</div><!--mvp-org-wrap-->
					<div class="posts-nav-link">
											</div><!--posts-nav-link-->
											<div class="post-tags">
							<span class="post-tags-header">Related Items:</span><span itemprop="keywords"><a href="https://steelersdepot.com/tag/2021-nfl-draft/" rel="tag" data-wpel-link="internal">2021 NFL Draft</a>, <a href="https://steelersdepot.com/tag/ohio-state/" rel="tag" data-wpel-link="internal">Ohio State</a>, <a href="https://steelersdepot.com/tag/pete-werner/" rel="tag" data-wpel-link="internal">Pete Werner</a>, <a href="https://steelersdepot.com/tag/player-profiles/" rel="tag" data-wpel-link="internal">Player Profiles</a></span>
						</div><!--post-tags-->
																<div class="social-sharing-bot">
							<a href="#" onclick="window.open(&#039;http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/&amp;t=2021 NFL Draft Player Profiles: Ohio State LB Pete Werner&#039;, &#039;facebookShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span> <span style="color: #fff; font-family: 'Montserrat', sans-serif; font-size: 10px; font-weight: 400; line-height: 100%; padding: 8px 0; text-transform: uppercase;"></span></div></a>
							<a href="#" onclick="window.open(&#039;http://twitter.com/share?text=2021 NFL Draft Player Profiles: Ohio State LB Pete Werner -&amp;url=https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/&#039;, &#039;twitterShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
							<a href="whatsapp://send?text=2021 NFL Draft Player Profiles: Ohio State LB Pete Werner https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/" data-wpel-link="internal"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="#" onclick="window.open(&#039;http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/&amp;media=https://steelersdepot.com/wp-content/uploads/2021/02/StockPeteWerner1-1000x600.jpg&amp;description=2021 NFL Draft Player Profiles: Ohio State LB Pete Werner&#039;, &#039;pinterestShare&#039;, &#039;width=750,height=350&#039;); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="/cdn-cgi/l/email-protection#734c000611191610074e41434142533d353f53370112150753231f120a16015323011c151a1f160049533c1b1a1c532007120716533f315323160716532416011d160155121e0348313c372a4e3a53151c061d1753071b1a00531201071a101f16531a1d0716011600071a1d1453121d1753071b1c06141b07531c1553001b12011a1d14531a0753041a071b530a1c065d53301b161018531a07531c060749531b07070300495c5c000716161f1601001716031c075d101c1e5c414341425c43415c414341425e1d151f5e17011215075e031f120a16015e03011c151a1f16005e1c1b1a1c5e00071207165e1f115e031607165e0416011d16015c"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
						</div><!--social-sharing-bot-->
																            <div class="mvp-related-posts left relative">
		<h4 class="post-header"><span class="post-header">Recommended for you</span></h4>
			<ul>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-rb-trey-sermon/" rel="bookmark" title="2021 NFL Draft Player Profiles: Ohio State RB Trey Sermon" data-wpel-link="internal">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2021/01/StockTreySermon-300x180.jpg" class="reg-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2021/01/StockTreySermon-300x180.jpg 300w, https://steelersdepot.com/wp-content/uploads/2021/01/StockTreySermon-1000x600.jpg 1000w, https://steelersdepot.com/wp-content/uploads/2021/01/StockTreySermon-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2021/01/StockTreySermon-80x80.jpg" class="mob-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2021/01/StockTreySermon-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2021/01/StockTreySermon-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-rb-trey-sermon/" data-wpel-link="internal">2021 NFL Draft Player Profiles: Ohio State RB Trey Sermon</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-penn-state-edge-jayson-oweh/" rel="bookmark" title="2021 NFL Draft Player Profiles: Penn State EDGE Jayson Oweh" data-wpel-link="internal">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2021/02/StockJaysonOweh1-300x180.jpg" class="reg-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2021/02/StockJaysonOweh1-300x180.jpg 300w, https://steelersdepot.com/wp-content/uploads/2021/02/StockJaysonOweh1-1000x600.jpg 1000w, https://steelersdepot.com/wp-content/uploads/2021/02/StockJaysonOweh1-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2021/02/StockJaysonOweh1-80x80.jpg" class="mob-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2021/02/StockJaysonOweh1-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2021/02/StockJaysonOweh1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-penn-state-edge-jayson-oweh/" data-wpel-link="internal">2021 NFL Draft Player Profiles: Penn State EDGE Jayson Oweh</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-michigan-lb-cameron-mcgrone/" rel="bookmark" title="2021 NFL Draft Player Profiles: Michigan LB Cameron McGrone" data-wpel-link="internal">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2021/02/StockCameronMcGrone1-300x180.jpg" class="reg-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2021/02/StockCameronMcGrone1-300x180.jpg 300w, https://steelersdepot.com/wp-content/uploads/2021/02/StockCameronMcGrone1-1000x600.jpg 1000w, https://steelersdepot.com/wp-content/uploads/2021/02/StockCameronMcGrone1-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2021/02/StockCameronMcGrone1-80x80.jpg" class="mob-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2021/02/StockCameronMcGrone1-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2021/02/StockCameronMcGrone1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-michigan-lb-cameron-mcgrone/" data-wpel-link="internal">2021 NFL Draft Player Profiles: Michigan LB Cameron McGrone</a>
				</div><!--related-text-->
            			</li>
            		</ul></div>																					<div id="disqus_thread"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
    /**
     *  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT 
     *  THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR 
     *  PLATFORM OR CMS.
     *  
     *  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: 
     *  https://disqus.com/admin/universalcode/#configuration-variables
     */
    /*
    var disqus_config = function () {
        // Replace PAGE_URL with your page's canonical URL variable
        this.page.url = PAGE_URL;  
        
        // Replace PAGE_IDENTIFIER with your page's unique identifier variable
        this.page.identifier = PAGE_IDENTIFIER; 
    };
    */


	// DISQUS.reset({
	// 	reload: true,
	// 	config: function () {  
	// 		this.page.identifier = 'steelersdepot';
	// 		this.page.url = 'https://steelersdepot.com/2021/02/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner/';
	// 	}
	// });
 //    var changeThread = function(){
 //    };


    var disqus_loaded = false;
    
	if (typeof(disqus_loaded)=="undefined" || !disqus_loaded) {
		disqus_loaded=1;
		jQuery.ajax({
			type: 'GET',
			url: 'https://steelersdepot.disqus.com/embed.js',
			dataType: 'script',
			cache: true
		});
	} 

    // (function() {
    //     var d = document, s = d.createElement('script');
        
    //     s.src = 'https://steelersdepot.disqus.com/embed.js';
    //     // s.src = '/wp-content/themes/flex-mag-child/assets/js/disqus-post.js';
        
    //     s.setAttribute('data-timestamp', +new Date());
    //     (d.head || d.body).appendChild(s);
    // })();
</script>
<noscript>
    Please enable JavaScript to view the 
    <a href="https://disqus.com/?ref_noscript" rel="nofollow external noopener noreferrer" data-wpel-link="external">
        comments powered by Disqus.
    </a>
</noscript>									</div><!--content-main-->
			</div><!--post-cont-in-->
					</div><!--post-cont-out-->
	</div><!--content-area-->
</article>
				</div><!--post-left-col-->
			</div><!--post-wrap-in1-->
			
							<div id="post-right-col" class="relative">
																		<div id="sidebar-wrap" class="left relative theiaStickySidebar">
	<div id="custom_html-29" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a target="_blank" href="https://fanatics.ncw6.net/c/2325230/618771/9663" rel="noopener external noreferrer" data-wpel-link="external"><img src="https://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></div><!--sidebar-wrap-->															</div><!--post-right-col-->
					</div><!--post-wrap-out1-->
</div><!--post-main-wrap-->
											</div><!--body-main-cont-->
				</div><!--body-main-in-->
			</div><!--body-main-out-->
		</div><!--body-main-wrap-->
		<footer id="foot-wrap" class="left relative">
			<div id="foot-top-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-widget-wrap" class="left relative">
															<div class="foot-widget left relative">
																			<div class="foot-logo left realtive">
											<img src="https://steelersdepot.com/wp-content/themes/flex-mag/images/logos/logo-foot.png" alt="Steelers Depot" data-rjs="2" />
										</div><!--foot-logo-->
																		<div class="foot-info-text left relative">
										<p>Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem?</p><p>Temporibus autem quibusdam et aut officiis debitis aut rerum necessitatibus saepe eveniet.</p>									</div><!--footer-info-text-->
									<div class="foot-soc left relative">
										<ul class="foot-soc-list relative">
																							<li class="foot-soc-fb">
													<a href="https://www.facebook.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-facebook-square fa-2"></i></a>
												</li>
																																		<li class="foot-soc-twit">
													<a href="https://twitter.com/Steelersdepot" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-twitter-square fa-2"></i></a>
												</li>
																																													<li class="foot-soc-inst">
													<a href="https://www.instagram.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-instagram fa-2"></i></a>
												</li>
																																													<li class="foot-soc-yt">
													<a href="https://www.youtube.com/channel/UCFqbkq2BzNY3iQ_FPveqVhw" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-youtube-play fa-2"></i></a>
												</li>
																																													<li class="foot-soc-tumb">
													<a href="https://steelersdepot.tumblr.com/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-tumblr-square fa-2"></i></a>
												</li>
																																		<li class="foot-soc-rss">
													<a href="https://steelersdepot.com/feed/rss/" target="_blank" data-wpel-link="internal"><i class="fa fa-rss-square fa-2"></i></a>
												</li>
																					</ul>
									</div><!--foot-soc-->
								</div><!--foot-widget-->
																				</div><!--foot-widget-wrap-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-top-->
			<div id="foot-bot-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-bot" class="left relative">
							<div class="foot-menu relative">
								<div class="menu-header-container"><ul id="menu-header-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/" data-wpel-link="internal">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/" data-wpel-link="internal">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/" data-wpel-link="internal">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/" data-wpel-link="internal">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-535831"><a href="https://steelersdepot.com/?s=2021+NFL+Draft+Player+Profiles" data-wpel-link="internal">2021 NFL Draft Player Profiles</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/" data-wpel-link="internal">2020 NFL Scouting Combine Results Tracker</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/" data-wpel-link="internal">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/" data-wpel-link="internal">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/" data-wpel-link="internal">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4" data-wpel-link="external" rel="external noopener noreferrer">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/" data-wpel-link="internal">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php" data-wpel-link="internal">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout" data-wpel-link="internal">Logout</a></li>
</ul></div>							</div><!--foot-menu-->
							<div class="foot-copy relative">
								<p>&copy; 2021 Steelers Depot</p>
							</div><!--foot-copy-->
						</div><!--foot-bot-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-bot-->
		</footer>
	</div><!--site-wrap-->
</div><!--site-->
<div class="fly-to-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
	<span class="to-top-text">To Top</span>
</div><!--fly-to-top-->
<div class="fly-fade">
</div><!--fly-fade-->
			<script data-cfasync="false" type="text/javascript">
			function arm_open_modal_box_in_nav_menu(menu_id, form_id) {
                           
				jQuery(".arm_nav_menu_link_" + form_id).find("." + form_id).trigger("click");
				return false;
			}
			</script>
					<div data-theiaStickySidebar-sidebarSelector='"#tab-col2"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":0,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#tab-col3"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#post-right-col"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		
<script type="text/javascript">
jQuery(document).ready(function($) {

	// Back to Top Button
    	var duration = 500;
    	$('.back-to-top').click(function(event) {
          event.preventDefault();
          $('html, body').animate({scrollTop: 0}, duration);
          return false;
	});

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

	  	$(".comment-click-536174").on("click", function(){
  	  $(".com-click-id-536174").show();
	  $(".disqus-thread-536174").show();
  	  $(".com-but-536174").hide();
  	});
	

$(window).load(function() {
  // The slider being synced must be initialized first
  $('.post-gallery-bot').flexslider({
    animation: "slide",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    itemWidth: 80,
    itemMargin: 10,
    asNavFor: '.post-gallery-top'
  });

  $('.post-gallery-top').flexslider({
    animation: "fade",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    	  prevText: "&lt;",
          nextText: "&gt;",
    sync: ".post-gallery-bot"
  });
});

});

</script>

<script type='text/javascript' data-cfasync="false" src='https://steelersdepot.com/wp-includes/js/comment-reply.min.js?ver=5.6.1' id='comment-reply-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"steelersdepot"};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.21' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"536174 https:\/\/steelersdepot.com\/?p=536174","disqusShortname":"steelersdepot","disqusTitle":"2021 NFL Draft Player Profiles: Ohio State LB Pete Werner","disqusUrl":"https:\/\/steelersdepot.com\/2021\/02\/2021-nfl-draft-player-profiles-ohio-state-lb-pete-werner\/","postId":"536174"};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.21' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.6.3' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.6.3' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag/js/scripts.js?ver=5.6.1' id='mvp-flexmag-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag/js/autoloadpost.js?ver=5.6.1' id='mvp-autoloadpost-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag/js/retina.js?ver=5.6.1' id='retina-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag-child/assets/js/main.min.js?ver=5.6.1' id='main-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/sc-youtube-embed/sc-youtube-embed.js?ver=1612538317' id='sc-youtube-embed-js'></script>
<script type='text/javascript' data-cfasync="false" src='https://steelersdepot.com/wp-includes/js/wp-embed.min.js?ver=5.6.1' id='wp-embed-js'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script src='https://stats.wp.com/e-202107.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4',blog:'11559871',post:'536174',tz:'-5',srv:'steelersdepot.com'} ]);
	_stq.push([ 'clickTrackerInit', '11559871', '536174' ]);
</script>

	<style>
.modal {
	margin-top:200px;
}
.modal-backdrop {
	background: rgba(0,0,0,0.6);
}
.modal-body a {
	text-decoration: underline;
}
</style>
<div class="modal" id="ad-free-modal" tabindex="-1" role="dialog">
	<div class="modal-dialog" role="document">
		<div class="modal-content">
			<div class="modal-header">
				<h5 class="modal-title">Adblocker is on</h5>
				<button type="button" class="close" data-dismiss="modal" aria-label="Close">
					<span aria-hidden="true">&times;</span>
				</button>
			</div>
			<div class="modal-body">
				<p>We noticed your adblocker is on.  We use ads to fund this site and continue to bring you premium Steelers content.</p>
				<p>If you like what you see on this site, we now have an <a href="/go-ad-free" data-wpel-link="internal">ad-free option</a> available for a donation of $25 per year, and you can enjoy the site entirely ad-free!</p>
				<p>Additionally, if you'd like to donate above and beyond the ad-free option, you can <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&amp;hosted_button_id=XZ97MFHPQZYX4" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">donate via PayPal</a> as well.</p>
				<p>Finally, if you wish to not see this dialog box, please turn off your adblocker, and enjoy content normally</p>
				<p>Thank you for visiting Steelers Depot!</p>
			</div>
			<div class="modal-footer">
				<a href="/go-ad-free" class="btn btn-warning" style="color:white" data-wpel-link="internal">Go Ad-Free</a>
				<button type="button" class="btn btn-dark" data-dismiss="modal">Close</button>
			</div>
		</div>
	</div>
</div></body>
</html>