<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />



<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://steelersdepot.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://steelersdepot.com/feed/atom/" />
<link rel="pingback" href="https://steelersdepot.com/xmlrpc.php" />

<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2019/03/StockJusticeHill1.jpg" />
<meta name="twitter:image" content="https://steelersdepot.com/wp-content/uploads/2019/03/StockJusticeHill1.jpg" />

<meta property="og:type" content="article" />
<meta property="og:description" content="Day One of the 2019 NFL Combine is in the books. Before we jump into tomorrow&#8217;s big day, with the quarterbacks, receivers, and tight ends working out in one Saturday marathon event, let&#8217;s recap everything that happened at Indianapolis on Friday. If you missed it, we&#8217;re keeping track of who we know the Steelers have [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/">
<meta name="twitter:title" content="2019 NFL Combine: Day One Analysis">
<meta name="twitter:description" content="Day One of the 2019 NFL Combine is in the books. Before we jump into tomorrow&#8217;s big day, with the quarterbacks, receivers, and tight ends working out in one Saturday marathon event, let&#8217;s recap everything that happened at Indianapolis on Friday. If you missed it, we&#8217;re keeping track of who we know the Steelers have [&hellip;]">


<title>2019 NFL Combine: Day One Analysis - Steelers Depot</title>

<!-- This site is optimized with the Yoast SEO plugin v9.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Day One of the 2019 NFL Combine is in the books. Before we jump into tomorrow&#039;s big day, with the quarterbacks, receivers, and tight ends working out in"/>
<link rel="canonical" href="https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/" />
<link rel="publisher" href="https://plus.google.com/+DaveBryan"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="2019 NFL Combine: Day One Analysis - Steelers Depot" />
<meta property="og:description" content="Day One of the 2019 NFL Combine is in the books. Before we jump into tomorrow&#039;s big day, with the quarterbacks, receivers, and tight ends working out in" />
<meta property="og:url" content="https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/" />
<meta property="og:site_name" content="Steelers Depot" />
<meta property="article:tag" content="2019 NFL Combine" />
<meta property="article:tag" content="2019 NFL Draft" />
<meta property="article:tag" content="Dalton Risner" />
<meta property="article:tag" content="Miles Sanders" />
<meta property="article:section" content="NFL Draft" />
<meta property="article:published_time" content="2019-03-01T22:13:37+00:00" />
<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2019/03/StockJusticeHill1.jpg" />
<meta property="og:image:secure_url" content="https://steelersdepot.com/wp-content/uploads/2019/03/StockJusticeHill1.jpg" />
<meta property="og:image:width" content="851" />
<meta property="og:image:height" content="477" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Day One of the 2019 NFL Combine is in the books. Before we jump into tomorrow&#039;s big day, with the quarterbacks, receivers, and tight ends working out in" />
<meta name="twitter:title" content="2019 NFL Combine: Day One Analysis - Steelers Depot" />
<meta name="twitter:site" content="@Steelersdepot" />
<meta name="twitter:image" content="https://steelersdepot.com/wp-content/uploads/2019/03/StockJusticeHill1.jpg" />
<meta name="twitter:creator" content="@Alex_Kozora" />
<script type='application/ld+json'>{"@context":"https://schema.org","@type":"Organization","url":"https://steelersdepot.com/","sameAs":["https://plus.google.com/+DaveBryan","https://twitter.com/Steelersdepot"],"@id":"https://steelersdepot.com/#organization","name":"Steelers Depot","logo":""}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="https://steelersdepot.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; 2019 NFL Combine: Day One Analysis Comments Feed" href="https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.9"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='feedzy-rss-feeds-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/feedzy-rss-feeds/css/feedzy-rss-feeds.css?ver=3.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-reset-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/css/reset.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-style-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/style.css?ver=4.9.9' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/css/iecss.css?ver=4.9.9' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mvp-style-entertainment-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/css/style-entertainment.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/css/media-queries.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='child-main-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/assets/css/_main.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/css/bootstrap.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.9' type='text/css' media='all' />
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://steelersdepot.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://steelersdepot.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://steelersdepot.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/pPyaZ-27lh' />
<link rel="alternate" type="application/json+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2019%2F03%2F2019-nfl-combine-day-one-analysis%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2019%2F03%2F2019-nfl-combine-day-one-analysis%2F&#038;format=xml" />
<script type="text/javascript" data-cfasync="false">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</script><style type='text/css'>img#wpstats{display:none}</style>
<style type='text/css'>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</style>
	
<style type="text/css">


.post-cont-out,
.post-cont-in {
	margin-right: 0;
	}




.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -315px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 315px;
	}
.home-left-col {
	float: left;
	}
.home-mid-col {
	float: right;
	margin-left: 15px;
	margin-right: 0;
	}

@media screen and (max-width: 1399px) and (min-width: 1250px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1249px) and (min-width: 1100px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1099px) {
.home-wrap-out2,
.home-wrap-in2 {
	float: left;
	margin-left: 0;
	margin-right: 0;
	}
.home-mid-col {
	float: left;
	}
}
@media screen and (max-width: 479px) {
.home-mid-col {
	margin-left: 0;
	}
}





</style>

<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #eeeeee; }
</style>

	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<script>
	     (adsbygoogle = window.adsbygoogle || []).push({
	          google_ad_client: "ca-pub-7138622909378284",
	          enable_page_level_ads: true
	     });
	</script>
	
		<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({article:'auto'});
		!function (e, f, u, i) {
			if (!document.getElementById(i)){
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}
		}(document.createElement('script'),
		document.getElementsByTagName('script')[0],
		'//cdn.taboola.com/libtrc/steelersdepot/loader.js',
		'tb_loader_script');
		if(window.performance && typeof window.performance.mark == 'function')
		{window.performance.mark('tbl_ic');}
	</script>
	</head>


<body class="post-template-default single single-post postid-504883 single-format-standard custom-background logged-out">
	<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','/wp-content/themes/flex-mag-child/assets/js/google-analytics.js','ga');

	ga('create', 'UA-11437002-3', 'auto');
	ga('send', 'pageview');
	</script>
	<div id="site" class="left relative">
		<div id="site-wrap" class="left relative">
						<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
													<li class="twit-soc">
						<a href="https://twitter.com/Steelersdepot" target="_blank">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																																					<li class="rss-soc">
						<a href="https://steelersdepot.com/feed/rss/" target="_blank">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li id="menu-item-456507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li>
	<li id="menu-item-240753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li>
	<li id="menu-item-225936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li>
</ul>
</li>
<li id="menu-item-38058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li>
<li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li id="menu-item-496474" class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li id="menu-item-493254" class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li id="menu-item-493255" class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->			<div id="head-main-wrap" class="left relative">
				<div id="head-main-top" class="left relative">
																														</div><!--head-main-top-->
				<div id="main-nav-wrap">
					<div class="nav-out">
						<div class="nav-in">
							<div id="main-nav-cont" class="left" itemscope itemtype="http://schema.org/Organization">
								<div class="nav-logo-out">
									<div class="nav-left-wrap left relative">
										<div class="fly-but-wrap left relative">
											<span></span>
											<span></span>
											<span></span>
											<span></span>
										</div><!--fly-but-wrap-->
																					<div class="nav-logo left">
																									<a itemprop="url" href="https://steelersdepot.com/"><img itemprop="logo" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png" alt="Steelers Depot" data-rjs="2" /></a>
																																					<h2 class="mvp-logo-title">Steelers Depot</h2>
																							</div><!--nav-logo-->
																			</div><!--nav-left-wrap-->
									<div class="nav-logo-in">
										<div class="nav-menu-out">
											<div class="nav-menu-in">
												<nav class="main-menu-wrap left">
													<div class="menu-header-container"><ul id="menu-header-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>												</nav>
											</div><!--nav-menu-in-->
											<div class="nav-right-wrap relative">
												<div class="nav-search-wrap left relative">
													<span class="nav-search-but left"><i class="fa fa-search fa-2"></i></span>
													<div class="search-fly-wrap">
														<form method="get" id="searchform" action="https://steelersdepot.com/">
	<input type="text" name="s" id="s" value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>													</div><!--search-fly-wrap-->
												</div><!--nav-search-wrap-->
																																					<a href="https://twitter.com/Steelersdepot" target="_blank">
													<span class="nav-soc-but"><i class="fa fa-twitter fa-2"></i></span>
													</a>
																							</div><!--nav-right-wrap-->
										</div><!--nav-menu-out-->
									</div><!--nav-logo-in-->
								</div><!--nav-logo-out-->
							</div><!--main-nav-cont-->
						</div><!--nav-in-->
					</div><!--nav-out-->
				</div><!--main-nav-wrap-->
			</div><!--head-main-wrap-->
										<div id="body-main-wrap" class="left relative" itemscope itemtype="http://schema.org/NewsArticle">
					<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/"/>
																																			<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="body-main-cont" class="left relative">
																			<div id="leader-wrap" class="left relative">
								<!-- large column top -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7138622909378284"
     data-ad-slot="9571372570"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>							</div><!--leader-wrap-->
												<!-- <div style="margin-bottom:40px">
	<h5>Send Alex to Training Camp</h5>
	<iframe class='gfm-media-widget' image='0' coinfo='0' width='100%' height='100%' frameborder='0' id='steelers-depot-2018-training-camp'></iframe>
	<script src='//funds.gofundme.com/js/5.0/media-widget.js'></script>
	<style>
	.gfm-widget {
		width: 100%;
		max-width: initial;
	}
	</style>
	<script>
	jQuery(function($){
	});
	</script>
</div> --><div id="post-main-wrap" class="left relative">
	<div class="post-wrap-out1">
		<div class="post-wrap-in1">
			<div id="post-left-col" class="relative">
	<article id="post-area" class="post-504883 post type-post status-publish format-standard has-post-thumbnail hentry category-nfl-draft tag-2019-nfl-combine tag-2019-nfl-draft tag-dalton-risner tag-miles-sanders">
			<header id="post-header">
							<a class="post-cat-link" href="https://steelersdepot.com/category/nfl-draft/"><span class="post-head-cat">NFL Draft</span></a>
						<h1 class="post-title entry-title left" itemprop="headline">2019 NFL Combine: Day One Analysis</h1>
							<div id="post-info-wrap" class="left relative">
					<div class="post-info-out">
						<div class="post-info-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/dd199f8d970e1b3dbb6a44b8a92b4ef4?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/dd199f8d970e1b3dbb6a44b8a92b4ef4?s=100&#038;d=mm&#038;r=g 2x' class='avatar arm_grid_avatar arm-avatar avatar-50 photo' height='50' width='50' />						</div><!--post-info-img-->
						<div class="post-info-in">
							<div class="post-info-right left relative">
								<div class="post-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
									<span class="post-info-text">By</span> <span class="author-name vcard fn author" itemprop="name"><a href="https://steelersdepot.com/author/alex-kozora/" title="Posts by Alex Kozora" rel="author">Alex Kozora</a></span> <span class="author-twitter"><a href="https://twitter.com/Alex_Kozora" class="twitter-but" target="_blank"><i class="fa fa-twitter fa-2"></i></a></span>																	</div><!--post-info-name-->
								<div class="post-info-date left relative">
									<span class="post-info-text">Posted on</span> <span class="post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2019-03-01">March 1, 2019 at 5:13 pm</time></span>
									<meta itemprop="dateModified" content="2019-03-01"/>
								</div><!--post-info-date-->
							</div><!--post-info-right-->
						</div><!--post-info-in-->
					</div><!--post-info-out-->
				</div><!--post-info-wrap-->
					</header><!--post-header-->
	

			<section class="social-sharing-top">
			<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/&amp;t=2019 NFL Combine: Day One Analysis', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open('http://twitter.com/share?text=2019 NFL Combine: Day One Analysis -&amp;url=https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
			<a href="whatsapp://send?text=2019 NFL Combine: Day One Analysis https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/&amp;media=https://steelersdepot.com/wp-content/uploads/2019/03/StockJusticeHill1.jpg&amp;description=2019 NFL Combine: Day One Analysis', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="/cdn-cgi/l/email-protection#f5ca8680979f909681c8c7c5c4ccd5bbb3b9d5b69a98979c9b90cfd5b1948cd5ba9b90d5b49b94998c869c86d3949885ceb7bab1acc8bcd5939a809b91d5819d9c86d59487819c969990d59c9b8190879086819c9b92d5949b91d5819d9a80929d81d59a93d5869d94879c9b92d59c81d5829c819dd58c9a80dbd5b69d90969ed59c81d59a8081cfd59d81818586cfdada86819090999087869190859a81db969a98dac7c5c4ccdac5c6dac7c5c4ccd89b9399d8969a98979c9b90d891948cd89a9b90d8949b94998c869c86da"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
																	<a href="#disqus_thread"><div class="social-comments comment-click-504883"><i class="fa fa-commenting fa-2"></i></div></a>
									</section><!--social-sharing-top-->
	


																					<div class="left" id="post-feat-img-wrapper">
							<div id="post-feat-img" class="relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
								<img width="851" height="477" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/StockJusticeHill1.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/StockJusticeHill1.jpg 851w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/StockJusticeHill1-300x168.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/StockJusticeHill1-768x430.jpg 768w" sizes="(max-width: 851px) 100vw, 851px" />																<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2019/03/StockJusticeHill1.jpg">
								<meta itemprop="width" content="851">
								<meta itemprop="height" content="477">
								<div class="post-feat-text">
																										</div><!--post-feat-text-->
							</div><!--post-feat-img-->
						</div>
																<div id="content-area" itemprop="articleBody" class="post-504883 post type-post status-publish format-standard has-post-thumbnail hentry category-nfl-draft tag-2019-nfl-combine tag-2019-nfl-draft tag-dalton-risner tag-miles-sanders">
		<div class="post-cont-out">
			<div class="post-cont-in">
				<div id="content-main" class="left relative">

						
	
		<div class="post-specific-content">
<p>Day One of the 2019 NFL Combine is in the books. Before we jump into tomorrow&#8217;s big day, with the quarterbacks, receivers, and tight ends working out in one Saturday marathon event, let&#8217;s recap everything that happened at Indianapolis on Friday.</p>
<p>If you missed it, we&#8217;re keeping track of who we know the Steelers <a href="https://steelersdepot.com/2019/03/2019-steelers-combine-interview-masterlist-updating/">have interviewed over here</a>. And as always, bookmark our combine results tracker by <a href="https://steelersdepot.com/2019-nfl-scouting-combine-results-tracker/">clicking this link</a>. We&#8217;ll update it live throughout each day of workouts.</p>
<p>Let&#8217;s dive into the linemen and running backs.</p>
<p><strong>Offensive Line</strong></p>
<p>&#8211; Biggest winner of the day? NC State center <strong>Garrett Bradury</strong>. Mentioned him yesterday as a back-end first round pick. I think he&#8217;s squarely in that camp now and may go as high as the teens. Someone made a good comparison to <strong>Frank Ragnow&#8217;s</strong> &#8220;rise,&#8221; who ultimately went 20th to Detroit in the 2018 draft. Ran the third fastest 40 time (4.92) with a very good 1.74 ten split while looking fluid pulling in drills. <strong>Shaun O&#8217;Hara</strong> and <strong>Joe Thomas</strong> very complimentary of him during the NFL Network&#8217;s coverage.</p>
<p>&#8211; <strong>Andre Dillard</strong> tested about as well as you could hope for. 1.7 tens split is excellent and he killed it with a 9&#8217;10&#8221; broad and 4.4 short shuttle. Those numbers put him in some elite company with historically good results.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">LADIES AND GENTLEMEN LET&#39;S WELCOME&#8230;.</p>
<p>WASHINGTON STATE T ANDRE DILLARD (4.40) TO THE CLUB!!!! <a href="https://t.co/CFN7NQSpsV">https://t.co/CFN7NQSpsV</a></p>
<p>&mdash; Josh Norris (@JoshNorris) <a href="https://twitter.com/JoshNorris/status/1101567954439884803?ref_src=twsrc%5Etfw">March 1, 2019</a></p></blockquote>
<p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>He has the size and length that he covers a ton of ground on his kickslide. A good workout overall and very likely first rounder.</p>
<p>&#8211; I didn&#8217;t love Charlotte&#8217;s <strong>Nate Davis</strong> in the little I saw at the Senior Bowl but it today was a good one for him. Great bend, gets really low in his stance, and showed coordination and balance in his drills. That &#8220;flip hips&#8221; drill where the coach takes the linemen in a straight line? A lot of guys bob and weave all over the place. Not Davis. He stayed straight down the hashes while being able to change directions.</p>
<p>&#8211; Everything looked easy for Boston College&#8217;s <strong>Chris Lindstrom</strong>. Ran really well despite tipping the scales at nearly 310 pounds (4.9 40, 1.7 split) with a 30.5 vert, 9&#8217;9&#8243; broad, and 4.54 shuttle. Explosive player who showed power and ability to uncoil his hips on contact in those &#8220;fold block&#8221; drills. Big, strong lower half whose base doesn&#8217;t narrow.</p>
<p>&#8211; They mentioned it on the broadcast but tip of the hat to Florida tackle <strong>Jawaan Taylor</strong>. Hamstring pull kept him from running the 40 and everything but the bench, where he put up 24 reps with 35 1/8 inch arms, but he gutted it out through the drills and still looked good. As Joe Thomas said (he was an excellent addition, by the way), linemen have to play through the pain. Gotta be the toughest guys on the team. And Taylor showed he wasn&#8217;t going to shy away from the opportunity, even if he wasn&#8217;t quite at his best. Respect.</p>
<p>&#8211; Weber State&#8217;s <strong>Sua Opeta</strong> wasn&#8217;t a guy I knew anything about coming into this thing but liked the way he moved in drills. Fluid guy who was comfortable pulling. 1.66 ten split is ridiculous, best of the day by the big guys up front. 33 inch vert to boot.</p>
<p>&#8211; Morgan State&#8217;s <strong>Joshua Miles</strong> was a weird one too. Insane 36 inch vert. According to <em>NFL Combine Results</em>, of interior linemen, only <strong>Ben Miller&#8217;s</strong> 37.5 mark &#8211; and he was a 263 pound center &#8211; and <strong>Eric Steinbach&#8217;s</strong> 36 jump matched or beat Miles&#8217;. His other testing wasn&#8217;t nearly as strong and he screwed up the &#8220;flip hip&#8221; drill, trying to kickslide at the begin before the coach brought him back and explained it to him again. He was about the 15th guy in his group to go through the drill too so there&#8217;s no excuse. Stuff coaches don&#8217;t like to see.</p>
<p>&#8211; <strong>Tyler Jones</strong> from NC State did the same thing. The &#8220;rusher&#8221; in the kickslide drill, you&#8217;re supposed to run full sprint to stress the tackle in the drill and make him quickly cover ground. Jones jogged his way through so slowly they made <em>him </em>redo it. He didn&#8217;t run the 40 and his other testing was largely average, at best.</p>
<p>&#8211; You can definitely tell some of the big uglies were gassed by the end of the day, a long, mentally draining process. Dillard was one of them. So was Purdue&#8217;s <strong>Phil Haynes,</strong> a big man at 322 pounds.</p>
<p>&#8211; Except for <strong>Dalton Risner</strong>. Dude&#8217;s energy knows no limits. Saw the clips of him at the Senior Bowl. High energy, high intensity. Check him out as the &#8220;rabbit&#8221; in the mirror drill. Highlight of the day.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Dalton Risner as the rabbit has been my favorite part of the Combine. <a href="https://twitter.com/hashtag/NFLCombine?src=hash&amp;ref_src=twsrc%5Etfw">#NFLCombine</a> <a href="https://t.co/na52AowG55">pic.twitter.com/na52AowG55</a></p>
<p>&mdash; Alex Kozora (@Alex_Kozora) <a href="https://twitter.com/Alex_Kozora/status/1101542937702424579?ref_src=twsrc%5Etfw">March 1, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>&#8211; <strong>Greg Little</strong> had a rough day of it and there&#8217;s a clear separation between national media, who believes he&#8217;s a potential first rounder, and draftniks, who think he&#8217;s far from it. Today seems to lean towards the latter group: 1.84 split and a 25 inch vertical. Looked stiff and slow in drills.</p>
<p>In his defense, <strong>Orlando Brown Jr</strong>. had one of the worst Combine&#8217;s ever last year and turned out to be a very good player for the Ravens, though his draft stock took a hit, falling to the third round.</p>
<p><strong>Running Back</strong></p>
<p>&#8211; Definitely not the fastest group of runners Indy has ever seen. Tons of guys who ran slower than expected.</p>
<p>None moreso than Georgia&#8217;s <strong>Elijah Holyfield</strong>, who ran 4.79, 4.81 and officially, a 4.78. A favorite on the Internet, he was expected to run somewhere in the 4.5&#8217;s. That drastic of a difference and poor of a time is something that can seriously hurt your draft stock, especially for a guy like him who doesn&#8217;t have a lot of tape (215 career carries). 29.5 inch vert and 9&#8217;10&#8221; broad didn&#8217;t do him any favors either.</p>
<p>FAU&#8217;s <strong>Devin Singletary</strong> (4.66), Kentucky&#8217;s <strong>Benny Snell</strong> (4.66), and Iowa State&#8217;s<strong> David Montgomery</strong> (4.63) were also worse than anticipated.</p>
<p>&#8211;<strong> Myles Gaskins</strong> and <strong>Miles Sanders</strong> two solid days. Gaskins shows burst out of his cuts while Sanders is fluid and solid in pretty much everything that he does. Sanders killed his workout with a sub 4.5 40 time, 36 inch vert, 10&#8217;4&#8243; broad, and 6.89 three cones.</p>
<p>&#8211; If you watched<strong> Justice Hill</strong> at Oklahoma State, his numbers don&#8217;t come as a major shock though make no mistake, they&#8217;re very impressive. 4.4 40, 40 inch vert, a rare club to be apart of. Even pulled off 21 reps on the bench. Strong day for him.</p>
<p>&#8211; What worried me about <strong>Tony Pollard</strong> on tape popped up in his drills. Stiff, straight-line player who struggles to lower his pad level and change directions. 4.52 40 is slower than I expected too. Did catch the ball a little cleaner than I saw on tape.</p>
<p>&#8211; If the Steelers want to stick with their trend of drafting big running backs, Temple&#8217;s<strong> Ryquell Armstead</strong> might be a name to circle. Ran a 4.45 40 at 5&#8217;11, 220 pounds, though his vert and broad were underwhelming. But a name I want to go back and watch nonetheless. 34 career touchdowns.</p>
</div>

	<div id="taboola-below-article">
	<div id="custom_html-26" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script></div></div></div>

															<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
						<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
															<img src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png"/>
								<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png">
													</div><!--mvp-org-logo-->
						<meta itemprop="name" content="Steelers Depot">
					</div><!--mvp-org-wrap-->
					<div class="posts-nav-link">
											</div><!--posts-nav-link-->
											<div class="post-tags">
							<span class="post-tags-header">Related Items:</span><span itemprop="keywords"><a href="https://steelersdepot.com/tag/2019-nfl-combine/" rel="tag">2019 NFL Combine</a>, <a href="https://steelersdepot.com/tag/2019-nfl-draft/" rel="tag">2019 NFL Draft</a>, <a href="https://steelersdepot.com/tag/dalton-risner/" rel="tag">Dalton Risner</a>, <a href="https://steelersdepot.com/tag/miles-sanders/" rel="tag">Miles Sanders</a></span>
						</div><!--post-tags-->
																<div class="social-sharing-bot">
							<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/&amp;t=2019 NFL Combine: Day One Analysis', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span> <span style="color: #fff; font-family: 'Montserrat', sans-serif; font-size: 10px; font-weight: 400; line-height: 100%; padding: 8px 0; text-transform: uppercase;"></span></div></a>
							<a href="#" onclick="window.open('http://twitter.com/share?text=2019 NFL Combine: Day One Analysis -&amp;url=https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
							<a href="whatsapp://send?text=2019 NFL Combine: Day One Analysis https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/&amp;media=https://steelersdepot.com/wp-content/uploads/2019/03/StockJusticeHill1.jpg&amp;description=2019 NFL Combine: Day One Analysis', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="/cdn-cgi/l/email-protection#c7f8b4b2a5ada2a4b3faf5f7f6fee789818be784a8aaa5aea9a2fde783a6bee788a9a2e786a9a6abbeb4aeb4e1a6aab7fc8588839efa8ee7a1a8b2a9a3e7b3afaeb4e7a6b5b3aea4aba2e7aea9b3a2b5a2b4b3aea9a0e7a6a9a3e7b3afa8b2a0afb3e7a8a1e7b4afa6b5aea9a0e7aeb3e7b0aeb3afe7bea8b2e9e784afa2a4ace7aeb3e7a8b2b3fde7afb3b3b7b4fde8e8b4b3a2a2aba2b5b4a3a2b7a8b3e9a4a8aae8f5f7f6fee8f7f4e8f5f7f6feeaa9a1abeaa4a8aaa5aea9a2eaa3a6beeaa8a9a2eaa6a9a6abbeb4aeb4e8"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
						</div><!--social-sharing-bot-->
																            <div class="mvp-related-posts left relative">
		<h4 class="post-header"><span class="post-header">Recommended for you</span></h4>
			<ul>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2019/03/2019-steelers-combine-interview-masterlist-updating/" rel="bookmark" title="2019 Steelers Combine Interview Masterlist: (Updating)">
						<img width="269" height="180" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/10/StockSteelers2.jpg" class="reg-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/10/StockSteelers2.jpg 3872w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/10/StockSteelers2-300x201.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/10/StockSteelers2-1024x685.jpg 1024w" sizes="(max-width: 269px) 100vw, 269px" />						<img width="80" height="54" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/10/StockSteelers2.jpg" class="mob-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/10/StockSteelers2.jpg 3872w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/10/StockSteelers2-300x201.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/10/StockSteelers2-1024x685.jpg 1024w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2019/03/2019-steelers-combine-interview-masterlist-updating/">2019 Steelers Combine Interview Masterlist: (Updating)</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2019/03/steelers-met-with-osu-rb-justice-hill-at-nfl-scouting-combine/" rel="bookmark" title="Steelers Met With OSU RB Justice Hill At NFL Scouting Combine">
						<img width="300" height="180" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/justice-hill-oksu-2018-300x180.jpg" class="reg-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/justice-hill-oksu-2018-300x180.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/justice-hill-oksu-2018-1000x600.jpg 1000w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/justice-hill-oksu-2018-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/justice-hill-oksu-2018-80x80.jpg" class="mob-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/justice-hill-oksu-2018-80x80.jpg 80w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/justice-hill-oksu-2018-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2019/03/steelers-met-with-osu-rb-justice-hill-at-nfl-scouting-combine/">Steelers Met With OSU RB Justice Hill At NFL Scouting Combine</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2019/03/2019-nfl-draft-player-profiles-stanford-rb-bryce-love/" rel="bookmark" title="2019 NFL Draft Player Profiles: Stanford RB Bryce Love">
						<img width="300" height="180" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/StockBryceLove1-300x180.jpg" class="reg-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/StockBryceLove1-300x180.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/StockBryceLove1-1000x600.jpg 1000w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/StockBryceLove1-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/StockBryceLove1-80x80.jpg" class="mob-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/StockBryceLove1-80x80.jpg 80w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/03/StockBryceLove1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2019/03/2019-nfl-draft-player-profiles-stanford-rb-bryce-love/">2019 NFL Draft Player Profiles: Stanford RB Bryce Love</a>
				</div><!--related-text-->
            			</li>
            		</ul></div>																					<div id="disqus_thread"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
    /**
     *  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT 
     *  THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR 
     *  PLATFORM OR CMS.
     *  
     *  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: 
     *  https://disqus.com/admin/universalcode/#configuration-variables
     */
    /*
    var disqus_config = function () {
        // Replace PAGE_URL with your page's canonical URL variable
        this.page.url = PAGE_URL;  
        
        // Replace PAGE_IDENTIFIER with your page's unique identifier variable
        this.page.identifier = PAGE_IDENTIFIER; 
    };
    */


	// DISQUS.reset({
	// 	reload: true,
	// 	config: function () {  
	// 		this.page.identifier = 'steelersdepot';
	// 		this.page.url = 'https://steelersdepot.com/2019/03/2019-nfl-combine-day-one-analysis/';
	// 	}
	// });
 //    var changeThread = function(){
 //    };


    var disqus_loaded = false;
    
	if (typeof(disqus_loaded)=="undefined" || !disqus_loaded) {
		disqus_loaded=1;
		jQuery.ajax({
			type: 'GET',
			url: 'https://steelersdepot.disqus.com/embed.js',
			dataType: 'script',
			cache: true
		});
	} 

    // (function() {
    //     var d = document, s = d.createElement('script');
        
    //     s.src = 'https://steelersdepot.disqus.com/embed.js';
    //     // s.src = 'https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/assets/js/disqus-post.js';
        
    //     s.setAttribute('data-timestamp', +new Date());
    //     (d.head || d.body).appendChild(s);
    // })();
</script>
<noscript>
    Please enable JavaScript to view the 
    <a href="https://disqus.com/?ref_noscript" rel="nofollow">
        comments powered by Disqus.
    </a>
</noscript>									</div><!--content-main-->
			</div><!--post-cont-in-->
					</div><!--post-cont-out-->
	</div><!--content-area-->
</article>
				</div><!--post-left-col-->
			</div><!--post-wrap-in1-->
			
							<div id="post-right-col" class="relative">
																		<div id="sidebar-wrap" class="left relative theiaStickySidebar">
	<div id="custom_html-28" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- top right -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7138622909378284"
     data-ad-slot="2275390383"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="custom_html-27" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="taboola-right-rail-bulk"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'right-rail-bulk1',
    container: 'taboola-right-rail-bulk',
    placement: 'Right Rail-Bulk',
    target_type: 'mix'
  });
</script></div></div><div id="custom_html-29" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a target="_blank" href="https://shareasale.com/r.cfm?b=537844&amp;u=275818&amp;m=7124&amp;urllink=&amp;afftrack="><img src="https://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></div><!--sidebar-wrap-->															</div><!--post-right-col-->
					</div><!--post-wrap-out1-->
</div><!--post-main-wrap-->
											</div><!--body-main-cont-->
				</div><!--body-main-in-->
			</div><!--body-main-out-->
		</div><!--body-main-wrap-->

		<footer id="foot-wrap" class="left relative">
			<div id="foot-top-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-widget-wrap" class="left relative">
															<div class="foot-widget left relative">
																			<div class="foot-logo left realtive">
											<img src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/images/logos/logo-foot.png" alt="Steelers Depot" data-rjs="2" />
										</div><!--foot-logo-->
																		<div class="foot-info-text left relative">
										<p>Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem?</p><p>Temporibus autem quibusdam et aut officiis debitis aut rerum necessitatibus saepe eveniet.</p>									</div><!--footer-info-text-->
									<div class="foot-soc left relative">
										<ul class="foot-soc-list relative">
																																		<li class="foot-soc-twit">
													<a href="https://twitter.com/Steelersdepot" target="_blank"><i class="fa fa-twitter-square fa-2"></i></a>
												</li>
																																																																																																				<li class="foot-soc-rss">
													<a href="https://steelersdepot.com/feed/rss/" target="_blank"><i class="fa fa-rss-square fa-2"></i></a>
												</li>
																					</ul>
									</div><!--foot-soc-->
								</div><!--foot-widget-->
																				</div><!--foot-widget-wrap-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-top-->
			<div id="foot-bot-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-bot" class="left relative">
							<div class="foot-menu relative">
								<div class="menu-header-container"><ul id="menu-header-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>							</div><!--foot-menu-->
							<div class="foot-copy relative">
								<p>&copy; 2019 Steelers Depot</p>
							</div><!--foot-copy-->
						</div><!--foot-bot-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-bot-->
		</footer>
	</div><!--site-wrap-->
</div><!--site-->
<div class="fly-to-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
	<span class="to-top-text">To Top</span>
</div><!--fly-to-top-->
<div class="fly-fade">
</div><!--fly-fade-->
			<script data-cfasync="false" type="text/javascript">
			function arm_open_modal_box_in_nav_menu(menu_id, form_id) {
                           
				jQuery(".arm_nav_menu_link_" + form_id).find("." + form_id).trigger("click");
				return false;
			}
			</script>
					<div data-theiaStickySidebar-sidebarSelector='"#tab-col2"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":0,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#tab-col3"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#post-right-col"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		
<script type="text/javascript">
jQuery(document).ready(function($) {

	// Back to Top Button
    	var duration = 500;
    	$('.back-to-top').click(function(event) {
          event.preventDefault();
          $('html, body').animate({scrollTop: 0}, duration);
          return false;
	});

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

	  	$(".comment-click-504883").on("click", function(){
  	  $(".com-click-id-504883").show();
	  $(".disqus-thread-504883").show();
  	  $(".com-but-504883").hide();
  	});
	

$(window).load(function() {
  // The slider being synced must be initialized first
  $('.post-gallery-bot').flexslider({
    animation: "slide",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    itemWidth: 80,
    itemMargin: 10,
    asNavFor: '.post-gallery-top'
  });

  $('.post-gallery-top').flexslider({
    animation: "fade",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    	  prevText: "&lt;",
          nextText: "&gt;",
    sync: ".post-gallery-bot"
  });
});

});

</script>

<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=4.9.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"steelersdepot"};
/* ]]> */
</script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"504883 https:\/\/steelersdepot.com\/?p=504883","disqusShortname":"steelersdepot","disqusTitle":"2019 NFL Combine: Day One Analysis","disqusUrl":"https:\/\/steelersdepot.com\/2019\/03\/2019-nfl-combine-day-one-analysis\/","postId":"504883"};
/* ]]> */
</script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201909'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.6.3'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.6.3'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/js/scripts.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/js/autoloadpost.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/js/retina.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/assets/js/_main.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=4.9.9'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script type='text/javascript' src='https://stats.wp.com/e-201909.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.9',blog:'12286105',post:'504883',tz:'-5',srv:'steelersdepot.com'} ]);
	_stq.push([ 'clickTrackerInit', '12286105', '504883' ]);
</script>

	<style>
.modal {
	margin-top:200px;
}
.modal-backdrop {
	background: rgba(0,0,0,0.6);
}
.modal-body a {
	text-decoration: underline;
}
</style>
<div class="modal" id="ad-free-modal" tabindex="-1" role="dialog">
	<div class="modal-dialog" role="document">
		<div class="modal-content">
			<div class="modal-header">
				<h5 class="modal-title">Adblocker is on</h5>
				<button type="button" class="close" data-dismiss="modal" aria-label="Close">
					<span aria-hidden="true">&times;</span>
				</button>
			</div>
			<div class="modal-body">
				<p>We noticed your adblocker is on.  We use ads to fund this site and continue to bring you premium Steelers content.</p>
				<p>If you like what you see on this site, we now have an <a href="/go-ad-free">ad-free option</a> available for a donation of $25 per year, and you can enjoy the site entirely ad-free!</p>
				<p>Additionally, if you'd like to donate above and beyond the ad-free option, you can <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=XZ97MFHPQZYX4" target="_blank">donate via PayPal</a> as well.</p>
				<p>Finally, if you wish to not see this dialog box, please turn off your adblocker, and enjoy content normally</p>
				<p>Thank you for visiting Steelers Depot!</p>
			</div>
			<div class="modal-footer">
				<a href="/go-ad-free" class="btn btn-warning" style="color:white">Go Ad-Free</a>
				<button type="button" class="btn btn-dark" data-dismiss="modal">Close</button>
			</div>
		</div>
	</div>
</div>	<script type="text/javascript">
	jQuery(function($) {
		window._taboola = window._taboola || [];
		_taboola.push({flush: true});

		var adBlockEnabled = false;
		var testAd = document.createElement('div');
		testAd.innerHTML = '&nbsp;';
		testAd.className = 'adsbox';
		document.body.appendChild(testAd);
		window.setTimeout(function() {
			if(testAd.offsetHeight === 0) {
				adBlockEnabled = true;
				$('#ad-free-modal').modal('show');
			}
			testAd.remove();
			console.log('AdBlock Enabled? ', adBlockEnabled)
		}, 5000);
	});
	</script>
</body>
</html>