
<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />



<link rel="shortcut icon" href="https://steelersdepot.com/wp-content/uploads/2020/10/favicon-16x16-1.png" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://steelersdepot.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://steelersdepot.com/feed/atom/" />
<link rel="pingback" href="https://steelersdepot.com/xmlrpc.php" />

<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2022/10/not-just-football.jpg" />
<meta name="twitter:image" content="https://steelersdepot.com/wp-content/uploads/2022/10/not-just-football.jpg" />

<meta property="og:type" content="article" />
<meta property="og:description" content="The Pittsburgh Steelers fell 16-10 on Sunday Night on the road against the Miami Dolphins to fall to 2-5 on the season with an impending matchup against the undefeated Philadelphia Eagles. The Steelers lost the turnover battle 3-0 against Miami, with their defense dropping four would-be interceptions throughout the game. On his Not Just Football [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/">
<meta name="twitter:title" content="Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217;">
<meta name="twitter:description" content="The Pittsburgh Steelers fell 16-10 on Sunday Night on the road against the Miami Dolphins to fall to 2-5 on the season with an impending matchup against the undefeated Philadelphia Eagles. The Steelers lost the turnover battle 3-0 against Miami, with their defense dropping four would-be interceptions throughout the game. On his Not Just Football [&hellip;]">


<script>!function(){"use strict";for(var t=window.location.search.substring(1).split("&"),e=0;e<t.length;e++){var i="adt_ei",a=t[e];if(0===a.indexOf(i)){var r=a.split(i+"=")[1];localStorage.setItem(i,r),t.splice(e,1),history.replaceState(null,"","?"+t.join("&"));break}}}();
</script>    <style>
        .pro-wccp:before {
            content: "\f160";
            top: 3px;
        }
        .pro-wccp:before{
            color:#02CA03 !important
        }
        .pro-wccp {
            transform: rotate(45deg);
        }
    </style>
    <meta name='robots' content='max-image-preview:large' />
<link rel="preload" fetchpriority="high" href="https://steelersdepot.com/wp-content/themes/flex-mag-child/fonts/oswald-v49-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" fetchpriority="high" href="https://steelersdepot.com/wp-content/themes/flex-mag-child/fonts/montserrat-v25-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" fetchpriority="high" href="https://steelersdepot.com/wp-content/themes/flex-mag-child/fonts/lato-v23-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" fetchpriority="high" href="https://steelersdepot.com/wp-content/themes/flex-mag-child/fonts/lato-v23-latin-700.woff2" as="font" type="font/woff2" crossorigin>
<style data-no-optimize="1" data-cfasync="false">
	.adthrive-ad {
		margin-top: 10px;
		margin-bottom: 10px;
		text-align: center;
		overflow-x: visible;
		clear: both;
		line-height: 0;
	}
	/* Fix for Featured image not showing on post: https://steelersdepot.com/2022/05/steelers-pickett-didnt-believe-hed-walk-in-and-be-qb1-is-looking-forward-to-competing-for-job/ https://adthrive.zendesk.com/agent/tickets/211903 */

body.postid-571106.adthrive-device-phone #post-feat-img{
width: 100% !important;
} 

.adthrive-sidebar.side-widget {
padding: 10px 0px;
}

#AdThrive_Sidebar_9_desktop {
margin-bottom: 100px;
}

body.adthrive-device-desktop #adthrive-collapse-container {
width: 60%;
max-width: 500px;
}


.adthrive-sidebar.adthrive-stuck {
margin-top:80px;
}

.adthrive-content, .adthrive-header {
margin-left:auto;
margin-right:auto;
}

.adthrive-privacy-preferences {
 display: block !important;
}
.adthrive-ccpa-link { 
display: block !important; }

.adthrive-footer-message {
    margin-bottom: 100px !important;
    margin-top: 5px !important;
    height: auto !important;
}</style>
<script data-no-optimize="1" data-cfasync="false">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</script>

<script data-no-optimize="1" data-cfasync="false">
(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-2.3.1';
	w.adthrive.host = 'ads.adthrive.com';
	w.adthrive.integration = 'plugin';

	var commitParam = (w.adthriveCLS && w.adthriveCLS.bucket !== 'prod' && w.adthriveCLS.branch) ? '&commit=' + w.adthriveCLS.branch : '';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/5e387029c4178d20fcc52aa6/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href) + commitParam + '&cb=' + (Math.floor(Math.random() * 100) + 1) + '';
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);
</script>

	<!-- This site is optimized with the Yoast SEO Premium plugin v15.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Cameron Heyward Doesn&#039;t &#039;Have Any Lack Of Faith&#039; In DBs, But Says &#039;We Gotta Catch Those Interceptions&#039; - Steelers Depot</title>
	<meta name="description" content="The Pittsburgh Steelers fell 16-10 on Sunday Night on the road against the Miami Dolphins to fall to 2-5 on the season with an impending matchup against" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Cameron Heyward Doesn&#039;t &#039;Have Any Lack Of Faith&#039; In DBs, But Says &#039;We Gotta Catch Those Interceptions&#039; - Steelers Depot" />
	<meta property="og:description" content="The Pittsburgh Steelers fell 16-10 on Sunday Night on the road against the Miami Dolphins to fall to 2-5 on the season with an impending matchup against" />
	<meta property="og:url" content="https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/" />
	<meta property="og:site_name" content="Steelers Depot" />
	<meta property="article:publisher" content="https://www.facebook.com/steelersdepot" />
	<meta property="article:published_time" content="2022-10-25T22:10:00+00:00" />
	<meta property="article:modified_time" content="2022-10-25T22:05:24+00:00" />
	<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2022/10/not-just-football.jpg" />
	<meta property="og:image:width" content="771" />
	<meta property="og:image:height" content="434" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@Steelersdepot" />
	<meta name="twitter:site" content="@Steelersdepot" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://steelersdepot.com/#organization","name":"Steelers Depot","url":"https://steelersdepot.com/","sameAs":["https://www.facebook.com/steelersdepot","https://twitter.com/Steelersdepot"],"logo":{"@type":"ImageObject","@id":"https://steelersdepot.com/#logo","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2015/07/depot-logo.png","width":384,"height":100,"caption":"Steelers Depot"},"image":{"@id":"https://steelersdepot.com/#logo"}},{"@type":"WebSite","@id":"https://steelersdepot.com/#website","url":"https://steelersdepot.com/","name":"Steelers Depot","description":"Pittsburgh Steelers blog featuring news, discussion &amp; merchandise!","publisher":{"@id":"https://steelersdepot.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://steelersdepot.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/#primaryimage","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2022/10/not-just-football.jpg","width":771,"height":434},{"@type":"WebPage","@id":"https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/#webpage","url":"https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/","name":"Cameron Heyward Doesn't 'Have Any Lack Of Faith' In DBs, But Says 'We Gotta Catch Those Interceptions' - Steelers Depot","isPartOf":{"@id":"https://steelersdepot.com/#website"},"primaryImageOfPage":{"@id":"https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/#primaryimage"},"datePublished":"2022-10-25T22:10:00+00:00","dateModified":"2022-10-25T22:05:24+00:00","description":"The Pittsburgh Steelers fell 16-10 on Sunday Night on the road against the Miami Dolphins to fall to 2-5 on the season with an impending matchup against","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/"]}]},{"@type":"Article","@id":"https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/#article","isPartOf":{"@id":"https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/#webpage"},"author":{"@id":"https://steelersdepot.com/#/schema/person/1398440edc4b6f82bc69f7e528025820"},"headline":"Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217;","datePublished":"2022-10-25T22:10:00+00:00","dateModified":"2022-10-25T22:05:24+00:00","mainEntityOfPage":{"@id":"https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/#webpage"},"commentCount":0,"publisher":{"@id":"https://steelersdepot.com/#organization"},"image":{"@id":"https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/#primaryimage"},"keywords":"Cameron Heyward,Not Just Football","articleSection":"Article","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/#respond"]}]},{"@type":"Person","@id":"https://steelersdepot.com/#/schema/person/1398440edc4b6f82bc69f7e528025820","name":"Joe Clark","image":{"@type":"ImageObject","@id":"https://steelersdepot.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e80755b50e7990cb085da88036354645?s=96&d=mm&r=g","caption":"Joe Clark"}}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="https://steelersdepot.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217; Comments Feed" href="https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/6.0.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/6.0.3/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/6.0.3/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='convertkit-broadcasts-css'  href='https://steelersdepot.com/wp-content/plugins/convertkit/resources/frontend/css/broadcasts.css?ver=1.9.8.5' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='mvp-reset-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/reset.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-style-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/style.css?ver=6.0.3' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/css/iecss.css?ver=6.0.3' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mvp-style-entertainment-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/style-entertainment.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/media-queries.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://steelersdepot.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='css-protect.css-css'  href='https://steelersdepot.com/wp-content/plugins/wccp-pro/css-protect.css?wccp_ver_num=1&#038;ver=10.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='print-protection.css-css'  href='https://steelersdepot.com/wp-content/plugins/wccp-pro/css/print-protection.css?wccp_ver_num=1&#038;ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='child-main-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/main.min.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/css/bootstrap.min.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/11.4/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' data-cfasync="false" src='https://c0.wp.com/c/6.0.3/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' data-cfasync="false" src='https://c0.wp.com/c/6.0.3/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://steelersdepot.com/wp-json/" /><link rel="alternate" type="application/json" href="https://steelersdepot.com/wp-json/wp/v2/posts/585730" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://steelersdepot.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://steelersdepot.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/pdvQnt-2sng' />
<link rel="alternate" type="application/json+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2022%2F10%2Fcameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2022%2F10%2Fcameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions%2F&#038;format=xml" />
<script type="text/javascript" data-cfasync="false">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</script><style type="text/css">
.feedzy-rss-link-icon:after {
	content: url("https://steelersdepot.com/wp-content/plugins/feedzy-rss-feeds/img/external-link.png");
	margin-left: 3px;
}
</style>
		<script type="text/javascript">//<![CDATA[
  function external_links_in_new_windows_loop() {
    if (!document.links) {
      document.links = document.getElementsByTagName('a');
    }
    var change_link = false;
    var force = '';
    var ignore = '';

    for (var t=0; t<document.links.length; t++) {
      var all_links = document.links[t];
      change_link = false;
      
      if(document.links[t].hasAttribute('onClick') == false) {
        // forced if the address starts with http (or also https), but does not link to the current domain
        if(all_links.href.search(/^http/) != -1 && all_links.href.search('steelersdepot.com') == -1 && all_links.href.search(/^#/) == -1) {
          // console.log('Changed ' + all_links.href);
          change_link = true;
        }
          
        if(force != '' && all_links.href.search(force) != -1) {
          // forced
          // console.log('force ' + all_links.href);
          change_link = true;
        }
        
        if(ignore != '' && all_links.href.search(ignore) != -1) {
          // console.log('ignore ' + all_links.href);
          // ignored
          change_link = false;
        }

        if(change_link == true) {
          // console.log('Changed ' + all_links.href);
          document.links[t].setAttribute('onClick', 'javascript:window.open(\'' + all_links.href.replace(/'/g, '') + '\', \'_blank\', \'noopener\'); return false;');
          document.links[t].removeAttribute('target');
        }
      }
    }
  }
  
  // Load
  function external_links_in_new_windows_load(func)
  {  
    var oldonload = window.onload;
    if (typeof window.onload != 'function'){
      window.onload = func;
    } else {
      window.onload = function(){
        oldonload();
        func();
      }
    }
  }

  external_links_in_new_windows_load(external_links_in_new_windows_loop);
  //]]></script>

<link rel="dns-prefetch" href="https://ads.adthrive.com/"><link rel="preconnect" href="https://ads.adthrive.com/"><link rel="preconnect" href="https://ads.adthrive.com/" crossorigin><style>img#wpstats{display:none}</style>
	
<style type="text/css">


.post-cont-out,
.post-cont-in {
	margin-right: 0;
	}




.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -315px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 315px;
	}
.home-left-col {
	float: left;
	}
.home-mid-col {
	float: right;
	margin-left: 15px;
	margin-right: 0;
	}

@media screen and (max-width: 1399px) and (min-width: 1250px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1249px) and (min-width: 1100px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1099px) {
.home-wrap-out2,
.home-wrap-in2 {
	float: left;
	margin-left: 0;
	margin-right: 0;
	}
.home-mid-col {
	float: left;
	}
}
@media screen and (max-width: 479px) {
.home-mid-col {
	margin-left: 0;
	}
}





</style>

<script id="wccp_pro_disable_selection" type="text/javascript">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</script>
<script id="wccp_pro_disable_hot_keys" type="text/javascript">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</script>
<style>
.wccp_pro_copy_code_button
{
	line-height: 6px;
	width: auto;
	font-size: 8pt;
	font-family: tahoma;
	margin-top: 1px;
	margin-right: 2px;
	position:absolute;
	top:0;
	right:0;
	border-radius: 4px;
	opacity: 100%;
	margin-top: -30px;
}
.wccp_pro_copy_code_button:hover
{
	opacity: 100%;
}

.wccp_pro_copy_code_button[disabled]
{
	opacity: 40%;
	border-color: red;
}
code,pre
{
	overflow: visible;
	white-space: pre-line;
}
</style>
<script id="wccp_pro_disable_Right_Click" type="text/javascript">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</script>
	
	<script id="wccp_pro_disable_drag_images">
	document.ondragstart = disable_drag_images;
		jQuery(document).ready(function(){
			jQuery('img').each(function() {
				jQuery(this).attr('draggable', false);
			});
		});
	</script>
	<style id="wccp_pro_style1">
		img{
			-moz-user-select: none;
			-webkit-user-select: none;
			-ms-user-select: none;
			-khtml-user-select: none;
			user-select: none;
			-webkit-user-drag: none;
			user-drag: none;
		}
	</style>
	<script id="wccp_pro_css_disable_selection" type="text/javascript">
	function wccp_pro_msieversion() 
		{
			var ua = window.navigator.userAgent;
			var msie = ua.indexOf("MSIE");
			var msie2 = ua.indexOf("Edge");
			var msie3 = ua.indexOf("Trident");

		if (msie > -1 || msie2 > -1 || msie3 > -1) // If Internet Explorer, return version number
		{
			return "IE";
		}
		else  // If another browser, return 0
		{
			return "otherbrowser";
		}
	}
    
	var e = document.getElementsByTagName('H1')[0];
	if(e && wccp_pro_msieversion() == "IE")
	{
		e.setAttribute('unselectable',"on");
	}
	</script>
<script id="wccp_pro_class_exclusion" type="text/javascript">
function copyToClipboard(elem) {
	  // create hidden text element, if it doesn't already exist
    var targetId = "_wccp_pro_hiddenCopyText_";
    {
        // must use a temporary form element for the selection and copy
        target = document.getElementById(targetId);
        if (!target) {
            var target = document.createElement("textarea");
            target.style.position = "absolute";
            target.style.left = "-9999px";
            target.style.top = "0";
            target.id = targetId;
            document.body.appendChild(target);
        }
        target.textContent = elem.textContent;
    }
    // select the content
    var currentFocus = document.activeElement;
    target.focus();
    target.setSelectionRange(0, target.value.length);
    
    // copy the selection
    var succeed;
    try {
    	  succeed = document.execCommand("copy");
    } catch(e) {
        succeed = false;
    }

    // restore original focus
    if (currentFocus && typeof currentFocus.focus === "function") {
        currentFocus.focus();
    }
    
    
	// clear temporary content
	target.textContent = "";
	document.getElementsByTagName('span')[0].innerHTML = " ";
    return succeed;
}
/**************************************************/
function wccp_pro_log_to_console_if_allowed(title = "title", data = "")
{
	var myName = "";
	
	if(wccp_pro_log_to_console_if_allowed.caller != null) myName = wccp_pro_log_to_console_if_allowed.caller.toString();
	
	myName = myName.substr('function '.length);
	
	myName = myName.substr(0, myName.indexOf('('));

	//console.log("function_name: " + myName);
	
	}
/**************************************************/
function fallbackCopyTextToClipboard(text) {
  var textArea = document.createElement("textarea");
  textArea.value = text;
  document.body.appendChild(textArea);
  textArea.focus();
  textArea.select();

  try {
    var successful = document.execCommand("copy");
    var msg = successful ? "successful" : "unsuccessful";
    console.log("Fallback: Copying text command was " + msg);
  } catch (err) {
    console.error("Fallback: Oops, unable to copy", err);
  }

  document.body.removeChild(textArea);
}
/*****************************************/
function copyTextToClipboard(text) {
  if (!navigator.clipboard) {
    fallbackCopyTextToClipboard(text);
    return;
  }
  navigator.clipboard.writeText(text).then(
    function() {
      console.log("Async: Copying to clipboard was successful!");
    },
    function(err) {
      console.error("Async: Could not copy text: ", err);
    }
  );
}
/*****************************************/
/*getSelectionTextAndContainerElement*/
function getSelectionTextAndContainerElement()
{
    var text = "", containerElement = null;
    if (typeof window.getSelection != "undefined") {
        var sel = window.getSelection();
        if (sel.rangeCount) {
            var node = sel.getRangeAt(0).commonAncestorContainer;
            containerElement = node.nodeType == 1 ? node : node.parentNode;
			if (typeof(containerElement.parentElement) != 'undefined') current_clicked_object = containerElement.parentElement;
            text = sel.toString();
        }
    } else if (typeof document.selection != "undefined" && document.selection.type != "Control")
	{
        var textRange = document.selection.createRange();
        containerElement = textRange.parentElement();
        text = textRange.text;
    }
    
	return {
        text: text,
        containerElement: containerElement
    };
}

function getSelectionParentElement() {
    var parentEl = null, sel;
	
    if (window.getSelection) {
        sel = window.getSelection();
        if (sel.rangeCount) {
            parentEl = sel.getRangeAt(0).commonAncestorContainer;
			//sel.getRangeAt(0).startContainer.parentNode;
            if (parentEl.nodeType != 1) {
                parentEl = parentEl.parentNode;
            }
        }
    } else if ( (sel = document.selection) && sel.type != "Control") {
        parentEl = sel.createRange().parentElement();
    }
	
	let arr = new Array();
	
	arr["nodeName"] = "cant_find_parent_element";
	
	if(parentEl != null)
		return parentEl;
	else
		return arr;
}
/*****************************************/
function sleep(ms) {
    return new Promise(resolve => setTimeout(resolve, ms));
}
/*****************************************/
</script>

<script id="wccp_pro_class_exclusion" type="text/javascript">
function apply_class_exclusion(e)
{
	wccp_pro_log_to_console_if_allowed("function", "apply_class_exclusion" + e);
	
	var my_return = 'No';
	
	var e = e || window.event; // also there is no e.target property in IE. instead IE uses window.event.srcElement
  	
	var target = e.target || e.srcElement || 'nothing';
	
	//if(target.parentElement != null) console.log (target.parentElement.className);
	
	var excluded_classes = '' + '';
	
	var class_to_exclude = "";
	
	if(target.parentElement != null)
	{
		class_to_exclude = target.className + ' ' + target.parentElement.className || '';
	}else{
		class_to_exclude = target.className;
	}
	
	var class_to_exclude_array = Array();
	
	//console.log(class_to_exclude);
	
	if (typeof(class_to_exclude) != 'undefined') class_to_exclude_array = class_to_exclude.split(" ");
	
	//console.log (class_to_exclude_array);
	
	class_to_exclude_array.forEach(function(item)
	{
		if(item != '' && excluded_classes.indexOf(item)>=0)
		{
			target.style.cursor = "text";
			
			console.log ('Yes');
			
			my_return = 'Yes';
		}
	});

	try {
		class_to_exclude = target.parentElement.getAttribute('class') || target.parentElement.className || '';
		}
	catch(err) 
		{
		class_to_exclude = '';
		}
	
	if(class_to_exclude != '' && excluded_classes.indexOf(class_to_exclude)>=0)
	{
		target.style.cursor = "text";
		my_return = 'Yes';
	}

	return my_return;
}
</script>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #eeeeee; }
</style>
	<script data-no-optimize='1' data-cfasync='false' id='cls-disable-ads-25a1f64'>var cls_disable_ads=function(t){"use strict";var e=function(t){var e=window.location.href;return t.some((function(t){return new RegExp(t,"i").test(e)}))},i=function(){function t(t){this.adthrive=t,this.all=!1,this.content=!1,this.recipe=!1,this.video=!1,this.locations=new Set,this.reasons=new Set,(this.urlHasEmail(window.location.href)||this.urlHasEmail(window.document.referrer))&&(this.all=!0,this.reasons.add("all_email"));try{this.checkCommandQueue(),null!==document.querySelector(".tag-novideo")&&(this.video=!0,this.locations.add("Video"),this.reasons.add("video_tag"))}catch(t){}}return t.prototype.checkCommandQueue=function(){var t=this;this.adthrive&&this.adthrive.cmd&&this.adthrive.cmd.forEach((function(e){var i=e.toString(),a=t.extractAPICall(i,"disableAds");a&&t.disableAllAds(t.extractPatterns(a));var n=t.extractAPICall(i,"disableContentAds");n&&t.disableContentAds(t.extractPatterns(n));var s=t.extractAPICall(i,"disablePlaylistPlayers");s&&t.disablePlaylistPlayers(t.extractPatterns(s))}))},t.prototype.extractPatterns=function(t){var e=t.match(/\'(.*?)\'/g);if(null!==e)return e.map((function(t){return t.replace(/'/g,"")}))},t.prototype.extractAPICall=function(t,e){var i=new RegExp(e+"\\((.*?)\\)","g"),a=t.match(i);return null!==a&&a[0]},t.prototype.disableAllAds=function(t){t&&!e(t)||(this.all=!0,this.reasons.add("all_page"))},t.prototype.disableContentAds=function(t){t&&!e(t)||(this.content=!0,this.recipe=!0,this.locations.add("Content"),this.locations.add("Recipe"),this.reasons.add("content_plugin"))},t.prototype.disablePlaylistPlayers=function(t){t&&!e(t)||(this.video=!0,this.locations.add("Video"),this.reasons.add("video_page"))},t.prototype.urlHasEmail=function(t){if(!t)return!1;return null!==/([A-Z0-9._%+-]+(@|%(25)*40)[A-Z0-9.-]+\.[A-Z]{2,})/i.exec(t)},t}(),a=window.adthriveCLS;return a&&(a.disableAds=new i(window.adthrive)),t.ClsDisableAds=i,Object.defineProperty(t,"__esModule",{value:!0}),t}({});
</script>		<style type="text/css" id="wp-custom-css">
			/* Slide Menu Color Link Fix */
nav.fly-nav-menu ul li a {
	color: #FFF !important;
}

/* Slide Menu Sub-Menu Icon Fix */
nav.fly-nav-menu ul li.menu-item-has-children:after {
	top: 0;
	font-size: 28px;
}

nav.fly-nav-menu ul li.menu-item-has-children.tog-minus:after {
	top: -14px;
	}

/* Fly to Top Fix */
.fly-to-top {
	bottom: 100px;
}
.feat-top2-right-text h2, .blog-widget-text h2, .archive-list-text h2, h2.stand-title{
	cursor: pointer;
}		</style>
		<script data-no-optimize='1' data-cfasync='false' id='cls-header-insertion-25a1f64'>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</script>
<style type='text/css'>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</style>
	
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<script>
	     (adsbygoogle = window.adsbygoogle || []).push({
	          google_ad_client: "ca-pub-7138622909378284",
	          enable_page_level_ads: true
	     });
	</script>
	
		<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({article:'auto'});
		!function (e, f, u, i) {
			if (!document.getElementById(i)){
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}
		}(document.createElement('script'),
		document.getElementsByTagName('script')[0],
		'//cdn.taboola.com/libtrc/steelersdepot/loader.js',
		'tb_loader_script');
		if(window.performance && typeof window.performance.mark == 'function')
		{window.performance.mark('tbl_ic');}
	</script>
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-11437002-3"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-11437002-3');


</script>
<script type="text/javascript">
	  window.disqus_config = function () {
	    this.disable_ads = true;
	}
</script>
</head>


<body class="post-template-default single single-post postid-585730 single-format-standard custom-background logged-out unselectable at-ads-allowed">
	<div id="site" class="left relative">
		<div id="site-wrap" class="left relative">
						<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
									<li class="fb-soc">
						<a href="https://www.facebook.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-facebook-square fa-2"></i>
						</a>
					</li>
													<li class="twit-soc">
						<a href="https://twitter.com/Steelersdepot" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																	<li class="inst-soc">
						<a href="https://www.instagram.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-instagram fa-2"></i>
						</a>
					</li>
																	<li class="yt-soc">
						<a href="https://www.youtube.com/channel/UCFqbkq2BzNY3iQ_FPveqVhw" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-youtube-play fa-2"></i>
						</a>
					</li>
																	<li class="tum-soc">
						<a href="https://steelersdepot.tumblr.com/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-tumblr fa-2"></i>
						</a>
					</li>
													<li class="rss-soc">
						<a href="https://steelersdepot.com/feed/rss/" target="_blank" data-wpel-link="internal">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/" data-wpel-link="internal">Home</a></li>
<li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/" data-wpel-link="internal">Steelers News</a></li>
<li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/" data-wpel-link="internal">Steelers Wire</a></li>
<li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/" data-wpel-link="internal">Podcast</a></li>
<li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li id="menu-item-567678" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-567678"><a href="https://steelersdepot.com/2022-nfl-scouting-combine-results-tracker/" data-wpel-link="internal">2022 NFL Scouting Combine Results Tracker</a></li>
	<li id="menu-item-562385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-562385"><a href="https://steelersdepot.com/?s=2022+NFL+Draft+Player+Profiles" data-wpel-link="internal">2022 NFL Draft Player Profiles</a></li>
	<li id="menu-item-564799" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-564799"><a href="https://steelersdepot.com/2022/03/2022-steelers-pro-day-tracker/" data-wpel-link="internal">2022 Pro Day Tracker</a></li>
	<li id="menu-item-539603" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-539603"><a href="https://steelersdepot.com/2021-nfl-pro-day-results-tracker-scouting-combine-invitees/" data-wpel-link="internal">2021 NFL Pro Day Results Tracker – Scouting Combine Invitees</a></li>
	<li id="menu-item-535831" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-535831"><a href="https://steelersdepot.com/?s=2021+NFL+Draft+Player+Profiles" data-wpel-link="internal">2021 NFL Draft Player Profiles</a></li>
</ul>
</li>
<li id="menu-item-515035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li id="menu-item-515038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/" data-wpel-link="internal">Contact Us</a></li>
<li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4" data-wpel-link="external" rel="external noopener noreferrer">Donate</a></li>
<li id="menu-item-496474" class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/" data-wpel-link="internal">Go Ad-Free</a>
<ul class="sub-menu">
	<li id="menu-item-555072" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-555072"><a href="https://steelersdepot.com/profile/" data-wpel-link="internal">Resubscribe</a></li>
</ul>
</li>
<li id="menu-item-493254" class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php" data-wpel-link="internal">Login</a></li>
<li id="menu-item-493255" class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout" data-wpel-link="internal">Logout</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->			<div id="head-main-wrap" class="left relative">
				<div id="head-main-top" class="left relative">
																														</div><!--head-main-top-->
				<div id="main-nav-wrap">
					<div class="nav-out">
						<div class="nav-in">
							<div id="main-nav-cont" class="left" itemscope itemtype="http://schema.org/Organization">
								<div class="nav-logo-out">
									<div class="nav-left-wrap left relative">
										<div class="fly-but-wrap left relative">
											<span></span>
											<span></span>
											<span></span>
											<span></span>
										</div><!--fly-but-wrap-->
																					<div class="nav-logo left">
																									<a itemprop="url" href="https://steelersdepot.com/" data-wpel-link="internal"><img itemprop="logo" src="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png" alt="Steelers Depot" data-rjs="2" /></a>
																																					<h2 class="mvp-logo-title">Steelers Depot</h2>
																							</div><!--nav-logo-->
																			</div><!--nav-left-wrap-->
									<div class="nav-logo-in">
										<div class="nav-menu-out">
											<div class="nav-menu-in">
												<nav class="main-menu-wrap left">
													<div class="menu-header-container"><ul id="menu-header-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/" data-wpel-link="internal">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/" data-wpel-link="internal">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/" data-wpel-link="internal">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/" data-wpel-link="internal">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-567678"><a href="https://steelersdepot.com/2022-nfl-scouting-combine-results-tracker/" data-wpel-link="internal">2022 NFL Scouting Combine Results Tracker</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-562385"><a href="https://steelersdepot.com/?s=2022+NFL+Draft+Player+Profiles" data-wpel-link="internal">2022 NFL Draft Player Profiles</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-564799"><a href="https://steelersdepot.com/2022/03/2022-steelers-pro-day-tracker/" data-wpel-link="internal">2022 Pro Day Tracker</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-539603"><a href="https://steelersdepot.com/2021-nfl-pro-day-results-tracker-scouting-combine-invitees/" data-wpel-link="internal">2021 NFL Pro Day Results Tracker – Scouting Combine Invitees</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-535831"><a href="https://steelersdepot.com/?s=2021+NFL+Draft+Player+Profiles" data-wpel-link="internal">2021 NFL Draft Player Profiles</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/" data-wpel-link="internal">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4" data-wpel-link="external" rel="external noopener noreferrer">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/" data-wpel-link="internal">Go Ad-Free</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-555072"><a href="https://steelersdepot.com/profile/" data-wpel-link="internal">Resubscribe</a></li>
</ul>
</li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php" data-wpel-link="internal">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout" data-wpel-link="internal">Logout</a></li>
</ul></div>												</nav>
											</div><!--nav-menu-in-->
											<div class="nav-right-wrap relative">
												<div class="nav-search-wrap left relative">
													<span class="nav-search-but left"><i class="fa fa-search fa-2"></i></span>
													<div class="search-fly-wrap">
														<form method="get" id="searchform" action="https://steelersdepot.com/">
	<input type="text" name="s" id="s" value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>													</div><!--search-fly-wrap-->
												</div><!--nav-search-wrap-->
																									<a href="https://www.facebook.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
													<span class="nav-soc-but"><i class="fa fa-facebook fa-2"></i></span>
													</a>
																																					<a href="https://twitter.com/Steelersdepot" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
													<span class="nav-soc-but"><i class="fa fa-twitter fa-2"></i></span>
													</a>
																							</div><!--nav-right-wrap-->
										</div><!--nav-menu-out-->
									</div><!--nav-logo-in-->
								</div><!--nav-logo-out-->
							</div><!--main-nav-cont-->
						</div><!--nav-in-->
					</div><!--nav-out-->
				</div><!--main-nav-wrap-->
			</div><!--head-main-wrap-->
										<div id="body-main-wrap" class="left relative" itemscope itemtype="http://schema.org/NewsArticle">
					<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/"/>
																																			<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="body-main-cont" class="left relative">
																		<!-- <div style="margin-bottom:40px">
	<h5>Send Alex to Training Camp</h5>
	<iframe class='gfm-media-widget' image='0' coinfo='0' width='100%' height='100%' frameborder='0' id='steelers-depot-2018-training-camp'></iframe>
	<script src='//funds.gofundme.com/js/5.0/media-widget.js'></script>
	<style>
	.gfm-widget {
		width: 100%;
		max-width: initial;
	}
	</style>
	<script>
	jQuery(function($){
	});
	</script>
</div> --><div id="post-main-wrap" class="left relative">
	<div class="post-wrap-out1">
		<div class="post-wrap-in1">
			<div id="post-left-col" class="relative">
	<article id="post-area" class="post-585730 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-cameron-heyward tag-not-just-football">
			<header id="post-header">
							<a class="post-cat-link" href="https://steelersdepot.com/category/article/" data-wpel-link="internal"><span class="post-head-cat">Article</span></a>
						<h1 class="post-title entry-title left" itemprop="headline">Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217;</h1>
							<div id="post-info-wrap" class="left relative">
					<div class="post-info-out">
						<div class="post-info-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/e80755b50e7990cb085da88036354645?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e80755b50e7990cb085da88036354645?s=100&#038;d=mm&#038;r=g 2x' class='avatar arm_grid_avatar arm-avatar avatar-50 photo' height='50' width='50' loading='lazy'/>						</div><!--post-info-img-->
						<div class="post-info-in">
							<div class="post-info-right left relative">
								<div class="post-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
									<span class="post-info-text">By</span> <span class="author-name vcard fn author" itemprop="name"><a href="https://steelersdepot.com/author/joe-clark/" title="Posts by Joe Clark" rel="author" data-wpel-link="internal">Joe Clark</a></span> 																	</div><!--post-info-name-->
								<div class="post-info-date left relative">
									<span class="post-info-text">Posted on</span> <span class="post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-10-25">October 25, 2022 at 6:10 pm</time></span>
									<meta itemprop="dateModified" content="2022-10-25"/>
								</div><!--post-info-date-->
							</div><!--post-info-right-->
						</div><!--post-info-in-->
					</div><!--post-info-out-->
				</div><!--post-info-wrap-->
					</header><!--post-header-->
	

			<section class="social-sharing-top">
			<a href="#" onclick="window.open(&#039;http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/&amp;t=Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217;&#039;, &#039;facebookShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open(&#039;http://twitter.com/share?text=Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217; -&amp;url=https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/&#039;, &#039;twitterShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
			<a href="whatsapp://send?text=Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217; https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/" data-wpel-link="internal"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open(&#039;http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/&amp;media=https://steelersdepot.com/wp-content/uploads/2022/10/not-just-football.jpg&amp;description=Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217;&#039;, &#039;pinterestShare&#039;, &#039;width=750,height=350&#039;); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="/cdn-cgi/l/email-protection#7c430f091e16191f08413f1d11190e13125c3419050b1d0e185c3813190f125a5f444e4d4b47085c5a5f444e4d4a47341d0a195c3d12055c301d1f175c331a5c3a1d1508145a5f444e4d4b475c35125c383e0f505c3e09085c2f1d050f5c5a5f444e4d4a472b195c3b1308081d5c3f1d081f145c2814130f195c351208190e1f190c081513120f5a5f444e4d4b475a1d110c473e33382541355c1a130912185c0814150f5c1d0e08151f10195c151208190e190f0815121b5c1d12185c081413091b14085c131a5c0f141d0e15121b5c15085c0b1508145c051309525c3f14191f175c15085c130908465c1408080c0f4653530f08191910190e0f18190c1308521f1311534e4c4e4e534d4c531f1d11190e1312511419050b1d0e18511813190f120851141d0a19511d120551101d1f1751131a511a1d15081451151251181e0f511e0908510f1d050f510b19511b1308081d511f1d081f14510814130f1951151208190e1f190c081513120f53"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
																	<a href="#disqus_thread"><div class="social-comments comment-click-585730"><i class="fa fa-commenting fa-2"></i></div></a>
									</section><!--social-sharing-top-->
	


																					<div class="left" id="post-feat-img-wrapper">
							<div id="post-feat-img" class="relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
								<img width="771" height="434" src="https://steelersdepot.com/wp-content/uploads/2022/10/not-just-football.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://steelersdepot.com/wp-content/uploads/2022/10/not-just-football.jpg 771w, https://steelersdepot.com/wp-content/uploads/2022/10/not-just-football-300x169.jpg 300w, https://steelersdepot.com/wp-content/uploads/2022/10/not-just-football-768x432.jpg 768w" sizes="(max-width: 771px) 100vw, 771px" />																<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2022/10/not-just-football.jpg">
								<meta itemprop="width" content="771">
								<meta itemprop="height" content="434">
								<div class="post-feat-text">
																										</div><!--post-feat-text-->
							</div><!--post-feat-img-->
						</div>
																<div id="content-area" itemprop="articleBody" class="post-585730 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-cameron-heyward tag-not-just-football">
		<div class="post-cont-out">
			<div class="post-cont-in">
				<div id="content-main" class="left relative">

						
	
		<div class="post-specific-content">
<p>The Pittsburgh Steelers fell 16-10 on Sunday Night on the road against the Miami Dolphins to fall to 2-5 on the season with an impending matchup against the undefeated Philadelphia Eagles. The Steelers lost the turnover battle 3-0 against Miami, with their defense dropping four would-be interceptions throughout the game. On <a href="https://www.youtube.com/watch?v=nOuoYzx_IGU" data-wpel-link="external" rel="external noopener noreferrer">his Not Just Football Podcast</a>, Defensive lineman Cameron Heyward praised the defense and the coverage units, but said that they need to catch the interceptions.</p>
<p>“I don’t have any lack of faith in my DBs. I thought they played a heck of a game. You’re able to keep the top on a guy like Tyreek Hill, look at the way the linebackers played, I thought the linebackers did a really good job in coverage, Devin Bush had a really big breakup. Terrell Edmunds and Minkah [Fitzpatrick] played top-down, really good football. But we gotta catch those interceptions.”</p>
<p>After a shaky first quarter where Miami basically moved the ball at will and put up 13 points. Then, after making some adjustments, the defense buckled down and would only allow a Jason Sanders field goal late in the first half and held Miami to just 16 points in the game. In most games, that should be good enough to win, but late turnovers by Pittsburgh and a general lack of offense doomed them. It’s fair to say Pittsburgh has the worst offense in the NFL, so it would’ve truly taken a Herculean effort by the defense to get Pittsburgh the win on Sunday.</p>
<p>While the defense did well, the best way to cover up a bad offense is to force turnovers and give the offense a short field. Pittsburgh couldn’t capitalize on their opportunities to do so on Sunday, and unfortunately, that’s something that’s going to hurt them. As well as the defense played, they need to take advantage of at least one or two of those turnover opportunities. It helps the offense out by potentially giving them a shorter field and putting the opposing defense in a quick-change situation, and can also help change momentum. In a game like Sunday’s, a turnover or two really could’ve changed the game and tilted things ever so slightly in Pittsburgh’s favor.</p>
<p>Obviously, it didn’t happen, and now Pittsburgh is in the unenviable position of being 2-5, going up against the best team (at least record-wise) in the NFL coming off a bye before they head into their bye. While their schedule does get easier after their Week 9 bye, it’s going to be near-impossible to make the playoffs if they enter that stretch at 2-6. While the defense has played a lot better in recent weeks, the Steelers are getting almost no offensive output, and simply not playing winning football. It could be a really long rest of the season for the black and gold.</p>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async data-uid="5b5b391c79" src="https://steelersdepot.ck.page/5b5b391c79/index.js"></script></div>

	<div id="taboola-below-article">
	</div>

															<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
						<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
															<img src="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png"/>
								<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png">
													</div><!--mvp-org-logo-->
						<meta itemprop="name" content="Steelers Depot">
					</div><!--mvp-org-wrap-->
					<div class="posts-nav-link">
											</div><!--posts-nav-link-->
											<div class="post-tags">
							<span class="post-tags-header">Related Items:</span><span itemprop="keywords"><a href="https://steelersdepot.com/tag/cameron-heyward/" rel="tag" data-wpel-link="internal">Cameron Heyward</a>, <a href="https://steelersdepot.com/tag/not-just-football/" rel="tag" data-wpel-link="internal">Not Just Football</a></span>
						</div><!--post-tags-->
																<div class="social-sharing-bot">
							<a href="#" onclick="window.open(&#039;http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/&amp;t=Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217;&#039;, &#039;facebookShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span> <span style="color: #fff; font-family: 'Montserrat', sans-serif; font-size: 10px; font-weight: 400; line-height: 100%; padding: 8px 0; text-transform: uppercase;"></span></div></a>
							<a href="#" onclick="window.open(&#039;http://twitter.com/share?text=Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217; -&amp;url=https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/&#039;, &#039;twitterShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
							<a href="whatsapp://send?text=Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217; https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/" data-wpel-link="internal"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="#" onclick="window.open(&#039;http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/&amp;media=https://steelersdepot.com/wp-content/uploads/2022/10/not-just-football.jpg&amp;description=Cameron Heyward Doesn&#8217;t &#8216;Have Any Lack Of Faith&#8217; In DBs, But Says &#8216;We Gotta Catch Those Interceptions&#8217;&#039;, &#039;pinterestShare&#039;, &#039;width=750,height=350&#039;); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="/cdn-cgi/l/email-protection#1b24686e79717e786f26587a767e6974753b537e626c7a697f3b5f747e68753d3823292a2c206f3b3d3823292a2d20537a6d7e3b5a75623b577a78703b547d3b5d7a726f733d3823292a2c203b52753b5f5968373b596e6f3b487a62683b3d3823292a2d204c7e3b5c746f6f7a3b587a6f78733b4f7374687e3b52756f7e69787e6b6f727475683d3823292a2c203d7a766b2059545f4226523b7d746e757f3b6f7372683b7a696f7278777e3b72756f7e697e686f72757c3b7a757f3b6f73746e7c736f3b747d3b68737a6972757c3b726f3b6c726f733b62746e353b58737e78703b726f3b746e6f213b736f6f6b68213434686f7e7e777e69687f7e6b746f3578747634292b2929342a2b34787a767e69747536737e626c7a697f367f747e68756f36737a6d7e367a756236777a787036747d367d7a726f73367275367f796836796e6f36687a6268366c7e367c746f6f7a36787a6f7873366f7374687e3672756f7e69787e6b6f7274756834"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
						</div><!--social-sharing-bot-->
																            <div class="mvp-related-posts left relative">
		<h4 class="post-header"><span class="post-header">Recommended for you</span></h4>
			<ul>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2022/10/minkah-fitzpatrick-on-loss-good-teams-always-come-together-in-times-like-this/" rel="bookmark" title="Minkah Fitzpatrick On Loss: &#8216;Good Teams Always Come Together In Times Like This&#8217;" data-wpel-link="internal">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2022/10/Minkah-Fitzpatrick-3-300x180.jpg" class="reg-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2022/10/Minkah-Fitzpatrick-3-300x180.jpg 300w, https://steelersdepot.com/wp-content/uploads/2022/10/Minkah-Fitzpatrick-3-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2022/10/Minkah-Fitzpatrick-3-80x80.jpg" class="mob-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2022/10/Minkah-Fitzpatrick-3-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2022/10/Minkah-Fitzpatrick-3-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2022/10/minkah-fitzpatrick-on-loss-good-teams-always-come-together-in-times-like-this/" data-wpel-link="internal">Minkah Fitzpatrick On Loss: &#8216;Good Teams Always Come Together In Times Like This&#8217;</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2022/10/positional-grades-steelers-vs-dolphins-2/" rel="bookmark" title="Positional Grades: Steelers vs. Dolphins" data-wpel-link="internal">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2022/10/Kenny-Pickett-interception-300x180.jpg" class="reg-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2022/10/Kenny-Pickett-interception-300x180.jpg 300w, https://steelersdepot.com/wp-content/uploads/2022/10/Kenny-Pickett-interception-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2022/10/Kenny-Pickett-interception-80x80.jpg" class="mob-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2022/10/Kenny-Pickett-interception-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2022/10/Kenny-Pickett-interception-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2022/10/positional-grades-steelers-vs-dolphins-2/" data-wpel-link="internal">Positional Grades: Steelers vs. Dolphins</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2022/10/heyward-and-claypool-lament-lack-of-splash-plays-sometimes-we-just-want-to-go-score-now/" rel="bookmark" title="Heyward And Claypool Lament Lack Of Splash Plays: &#8216;Sometimes We Just Want To Go Score Now&#8217;" data-wpel-link="internal">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2022/10/Chase-Claypool-1-300x180.jpg" class="reg-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2022/10/Chase-Claypool-1-300x180.jpg 300w, https://steelersdepot.com/wp-content/uploads/2022/10/Chase-Claypool-1-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2022/10/Chase-Claypool-1-80x80.jpg" class="mob-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2022/10/Chase-Claypool-1-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2022/10/Chase-Claypool-1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2022/10/heyward-and-claypool-lament-lack-of-splash-plays-sometimes-we-just-want-to-go-score-now/" data-wpel-link="internal">Heyward And Claypool Lament Lack Of Splash Plays: &#8216;Sometimes We Just Want To Go Score Now&#8217;</a>
				</div><!--related-text-->
            			</li>
            		</ul></div>																					<div id="disqus_thread"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
    /**
     *  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT 
     *  THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR 
     *  PLATFORM OR CMS.
     *  
     *  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: 
     *  https://disqus.com/admin/universalcode/#configuration-variables
     */
    /*
    var disqus_config = function () {
        // Replace PAGE_URL with your page's canonical URL variable
        this.page.url = PAGE_URL;  
        
        // Replace PAGE_IDENTIFIER with your page's unique identifier variable
        this.page.identifier = PAGE_IDENTIFIER; 
    };
    */


	// DISQUS.reset({
	// 	reload: true,
	// 	config: function () {  
	// 		this.page.identifier = 'steelersdepot';
	// 		this.page.url = 'https://steelersdepot.com/2022/10/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions/';
	// 	}
	// });
 //    var changeThread = function(){
 //    };


    var disqus_loaded = false;
    
	if (typeof(disqus_loaded)=="undefined" || !disqus_loaded) {
		disqus_loaded=1;
		jQuery.ajax({
			type: 'GET',
			url: 'https://steelersdepot.disqus.com/embed.js',
			dataType: 'script',
			cache: true
		});
	} 

    // (function() {
    //     var d = document, s = d.createElement('script');
        
    //     s.src = 'https://steelersdepot.disqus.com/embed.js';
    //     // s.src = '/wp-content/themes/flex-mag-child/assets/js/disqus-post.js';
        
    //     s.setAttribute('data-timestamp', +new Date());
    //     (d.head || d.body).appendChild(s);
    // })();
</script>
<noscript>
    Please enable JavaScript to view the 
    <a href="https://disqus.com/?ref_noscript" rel="nofollow external noopener noreferrer" data-wpel-link="external">
        comments powered by Disqus.
    </a>
</noscript>									</div><!--content-main-->
			</div><!--post-cont-in-->
					</div><!--post-cont-out-->
	</div><!--content-area-->
</article>
				</div><!--post-left-col-->
			</div><!--post-wrap-in1-->
			
							<div id="post-right-col" class="relative">
																		<div id="sidebar-wrap" class="left relative theiaStickySidebar">
	<div id="custom_html-29" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a target="_blank" href="https://fanatics.ncw6.net/c/2325230/618771/9663" rel="noopener external noreferrer" data-wpel-link="external"><img src="https://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></div><!--sidebar-wrap-->															</div><!--post-right-col-->
					</div><!--post-wrap-out1-->
</div><!--post-main-wrap-->
											</div><!--body-main-cont-->
				</div><!--body-main-in-->
			</div><!--body-main-out-->
		</div><!--body-main-wrap-->
		<footer id="foot-wrap" class="left relative">
			<div id="foot-top-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-widget-wrap" class="left relative">
															<div class="foot-widget left relative">
																			<div class="foot-logo left realtive">
											<img src="https://steelersdepot.com/wp-content/themes/flex-mag/images/logos/logo-foot.png" alt="Steelers Depot" data-rjs="2" />
										</div><!--foot-logo-->
																		<div class="foot-info-text left relative">
										<p>Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem?</p><p>Temporibus autem quibusdam et aut officiis debitis aut rerum necessitatibus saepe eveniet.</p>									</div><!--footer-info-text-->
									<div class="foot-soc left relative">
										<ul class="foot-soc-list relative">
																							<li class="foot-soc-fb">
													<a href="https://www.facebook.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-facebook-square fa-2"></i></a>
												</li>
																																		<li class="foot-soc-twit">
													<a href="https://twitter.com/Steelersdepot" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-twitter-square fa-2"></i></a>
												</li>
																																													<li class="foot-soc-inst">
													<a href="https://www.instagram.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-instagram fa-2"></i></a>
												</li>
																																													<li class="foot-soc-yt">
													<a href="https://www.youtube.com/channel/UCFqbkq2BzNY3iQ_FPveqVhw" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-youtube-play fa-2"></i></a>
												</li>
																																													<li class="foot-soc-tumb">
													<a href="https://steelersdepot.tumblr.com/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-tumblr-square fa-2"></i></a>
												</li>
																																		<li class="foot-soc-rss">
													<a href="https://steelersdepot.com/feed/rss/" target="_blank" data-wpel-link="internal"><i class="fa fa-rss-square fa-2"></i></a>
												</li>
																					</ul>
									</div><!--foot-soc-->
								</div><!--foot-widget-->
																				</div><!--foot-widget-wrap-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-top-->
			<div id="foot-bot-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-bot" class="left relative">
							<div class="foot-menu relative">
								<div class="menu-header-container"><ul id="menu-header-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/" data-wpel-link="internal">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/" data-wpel-link="internal">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/" data-wpel-link="internal">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/" data-wpel-link="internal">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-567678"><a href="https://steelersdepot.com/2022-nfl-scouting-combine-results-tracker/" data-wpel-link="internal">2022 NFL Scouting Combine Results Tracker</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-562385"><a href="https://steelersdepot.com/?s=2022+NFL+Draft+Player+Profiles" data-wpel-link="internal">2022 NFL Draft Player Profiles</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-564799"><a href="https://steelersdepot.com/2022/03/2022-steelers-pro-day-tracker/" data-wpel-link="internal">2022 Pro Day Tracker</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-539603"><a href="https://steelersdepot.com/2021-nfl-pro-day-results-tracker-scouting-combine-invitees/" data-wpel-link="internal">2021 NFL Pro Day Results Tracker – Scouting Combine Invitees</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-535831"><a href="https://steelersdepot.com/?s=2021+NFL+Draft+Player+Profiles" data-wpel-link="internal">2021 NFL Draft Player Profiles</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/" data-wpel-link="internal">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4" data-wpel-link="external" rel="external noopener noreferrer">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/" data-wpel-link="internal">Go Ad-Free</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-555072"><a href="https://steelersdepot.com/profile/" data-wpel-link="internal">Resubscribe</a></li>
</ul>
</li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php" data-wpel-link="internal">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout" data-wpel-link="internal">Logout</a></li>
</ul></div>							</div><!--foot-menu-->
							<div class="foot-copy relative">
								<p>&copy; 2022 Steelers Depot</p>
							</div><!--foot-copy-->
						</div><!--foot-bot-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-bot-->
		</footer>
	</div><!--site-wrap-->
</div><!--site-->
<div class="fly-to-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
	<span class="to-top-text">To Top</span>
</div><!--fly-to-top-->
<div class="fly-fade">
</div><!--fly-fade-->
<script data-no-optimize='1' data-cfasync='false' id='cls-insertion-25a1f64'>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</script><script data-no-optimize="1" data-cfasync="false">(function () {var clsElements = document.querySelectorAll("script[id^='cls-']"); window.adthriveCLS && clsElements && clsElements.length === 0 ? window.adthriveCLS.injectedFromPlugin = false : ""; })();</script>			<script data-cfasync="false" type="text/javascript">
			function arm_open_modal_box_in_nav_menu(menu_id, form_id) {
                           
				jQuery(".arm_nav_menu_link_" + form_id).find("." + form_id).trigger("click");
				return false;
			}
			</script>
					<div data-theiaStickySidebar-sidebarSelector='"#tab-col2"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":0,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#tab-col3"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#post-right-col"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		
<script type="text/javascript">
jQuery(document).ready(function($) {

	// Back to Top Button
    	var duration = 500;
    	$('.back-to-top').click(function(event) {
          event.preventDefault();
          $('html, body').animate({scrollTop: 0}, duration);
          return false;
	});

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

	  	$(".comment-click-585730").on("click", function(){
  	  $(".com-click-id-585730").show();
	  $(".disqus-thread-585730").show();
  	  $(".com-but-585730").hide();
  	});
	

$(window).load(function() {
  // The slider being synced must be initialized first
  $('.post-gallery-bot').flexslider({
    animation: "slide",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    itemWidth: 80,
    itemMargin: 10,
    asNavFor: '.post-gallery-top'
  });

  $('.post-gallery-top').flexslider({
    animation: "fade",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    	  prevText: "&lt;",
          nextText: "&gt;",
    sync: ".post-gallery-bot"
  });
});

});

</script>

<style id="wccp_pro_style2" type="text/css" data-asas-style="">

	
	*[contenteditable] , [contenteditable] *,*[contenteditable="true"] , [contenteditable="true"] * { /* for contenteditable tags*/ , /* for tags inside contenteditable tags*/
	  -webkit-user-select: auto !important;
	  cursor: text !important;
	  user-select: text !important;
	  pointer-events: auto !important;
	}
	
	/*
	*[contenteditable]::selection, [contenteditable] *::selection, [contenteditable="true"]::selection, [contenteditable="true"] *::selection { background: Highlight !important; color: HighlightText !important;}
	*[contenteditable]::-moz-selection, [contenteditable="true"] *::-moz-selection { background: Highlight !important; color: HighlightText !important;}
	input::selection,textarea::selection, code::selection, code > *::selection { background: Highlight !important; color: HighlightText !important;}
	input::-moz-selection,textarea::-moz-selection, code::-moz-selection, code > *::-moz-selection { background: Highlight !important; color: HighlightText !important;}
	*/
	a{ cursor: pointer ; pointer-events: auto !important;}

	</style><style>TEXT,TEXTAREA,input[type="text"] {cursor: text !important; user-select: text !important;}</style>	<div oncontextmenu="return false;" id='wccp_pro_mask'></div>
	<div id="wpcp-error-message" class="msgmsg-box-wpcp hideme"><span>error: </span><b>Alert:</b> Content is protected !!</div>
	<script id="wccp_pro_alert_message" type="text/javascript">
	var timeout_result;
	function show_wccp_pro_message(smessage="", style="")
	{
		wccp_pro_log_to_console_if_allowed("function", "show_wccp_pro_message" + smessage);
				
		timeout = 3000;
		
		if(style == "") style = "warning-wpcp";
		
		if (smessage !== "" && timeout!=0)
		{
			var smessage_text = smessage;
			jquery_fadeTo();
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp showme " + style;
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, timeout);
		}
		else
		{
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, timeout);
		}
	}
	function hide_message()
	{
		jquery_fadeOut();
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	function jquery_fadeTo()
	{
		try {
			jQuery("#wccp_pro_mask").fadeTo("slow", 0.3);
		}
		catch(err) {
			//alert(err.message);
			}
	}
	function jquery_fadeOut()
	{
		try {
			jQuery("#wccp_pro_mask").fadeOut( "slow" );
		}
		catch(err) {}
	}
	</script>
	<style type="text/css">
	#wccp_pro_mask
	{
		position: absolute;
		bottom: 0;
		left: 0;
		position: fixed;
		right: 0;
		top: 0;
		background-color: #000;
		pointer-events: none;
		display: none;
		z-index: 10000;
		animation: 0.5s ease 0s normal none 1 running ngdialog-fadein;
		background: rgba(0, 0, 0, 0.4) none repeat scroll 0 0;
	}
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
		pointer-events: none;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555555;
		font-family: Tahoma;
		font-size: ;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
	}
	.msgmsg-box-wpcp b {
		font-weight:bold;
		text-transform:uppercase;
	}
		.warning-wpcp {
		background:#ffecec url('https://steelersdepot.com/wp-content/plugins/wccp-pro/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f2bfbf;
		-webkit-box-shadow: 0px 0px 34px 2px #f2bfbf;
		-moz-box-shadow: 0px 0px 34px 2px #f2bfbf;
		box-shadow: 0px 0px 34px 2px #f2bfbf;
	}
	.success-wpcp {
		background: #fafafa url('https://steelersdepot.com/wp-content/plugins/wccp-pro/images/success.png') no-repeat 10px 50%;
		border: 1px solid #00b38f;
		box-shadow: 0px 0px 34px 2px #adc;
	}
    </style>
<script type='text/javascript' data-cfasync="false" src='https://c0.wp.com/c/6.0.3/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' id='convertkit-broadcasts-js-extra'>
/* <![CDATA[ */
var convertkit_broadcasts = {"ajax_url":"https:\/\/steelersdepot.com\/wp-admin\/admin-ajax.php","action":"convertkit_broadcasts_render","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/convertkit/resources/frontend/js/broadcasts.js?ver=1.9.8.5' id='convertkit-broadcasts-js'></script>
<script type='text/javascript' id='convertkit-js-js-extra'>
/* <![CDATA[ */
var convertkit = {"ajaxurl":"https:\/\/steelersdepot.com\/wp-admin\/admin-ajax.php","debug":"","nonce":"a6a7d71e80","subscriber_id":"0","tag":"","post_id":"585730"};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/convertkit/resources/frontend/js/convertkit.js?ver=1.9.8.5' id='convertkit-js-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"steelersdepot"};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"585730 https:\/\/steelersdepot.com\/?p=585730","disqusShortname":"steelersdepot","disqusTitle":"Cameron Heyward Doesn\u2019t \u2018Have Any Lack Of Faith\u2019 In DBs, But Says \u2018We Gotta Catch Those Interceptions\u2019","disqusUrl":"https:\/\/steelersdepot.com\/2022\/10\/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions\/","postId":"585730"};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=1666735803' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.6.3' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.6.3' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag/js/autoloadpost.js?ver=6.0.3' id='mvp-autoloadpost-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag/js/retina.js?ver=6.0.3' id='retina-js'></script>
<script type='text/javascript' id='web-vitals-analytics-js-extra'>
/* <![CDATA[ */
var webVitalsAnalyticsData = {"0":{"gtag_id":"UA-11437002-3","measurementVersion":"dimension1","eventMeta":"dimension2","eventDebug":"dimension3","web_vitals_tracking_ratio":"0.5"},"chance":"0.5"};
/* ]]> */
</script>
<script type='text/javascript' type="module" defer data-src='https://steelersdepot.com/wp-content/plugins/site-performance-tracker/js/dist/module/web-vitals-analytics.8f75cb271429178c9035de39e1f2f8d8.js' id='web-vitals-analytics-js'></script>
<script type='text/javascript' id='web-vitals-analytics-js-after'>
( function () {
	if ( 'requestIdleCallback' in window ) {
		var randNumber = Math.random();
		if ( randNumber <= parseFloat( window.webVitalsAnalyticsData.chance ) ) {
			window.addEventListener( 'load', function() {
				setTimeout( function() {
					requestIdleCallback( function() {
						webVitalsAnalyticsScript = document.querySelector( 'script[data-src*="web-vitals-analytics."]' );
						webVitalsAnalyticsScript.src = webVitalsAnalyticsScript.dataset.src;
						delete webVitalsAnalyticsScript.dataset.src;
					} );
				}, 5000 );
			});
		}
	}
} )();
</script>
<script type='text/javascript' id='wccp_pro_admin_bar_ajax-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajaxurl":"https:\/\/steelersdepot.com\/wp-admin\/admin-ajax.php","link":"https:\/\/steelersdepot.com\/2022\/10\/cameron-heyward-doesnt-have-any-lack-of-faith-in-dbs-but-says-we-gotta-catch-those-interceptions\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/wccp-pro/js/admin_bar_ajax.js?ver=6.0.3' id='wccp_pro_admin_bar_ajax-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag-child/assets/js/main.min.js?ver=6.0.3' id='main-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag-child/assets/js/scripts.js?ver=6.0.3' id='mvp-child-flexmag-js'></script>
<script type='text/javascript' src='https://js.stripe.com/v3/?ver=879' id='arm_stripe_v3-js'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script src='https://stats.wp.com/e-202243.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.4',blog:'199681879',post:'585730',tz:'-4',srv:'steelersdepot.com'} ]);
	_stq.push([ 'clickTrackerInit', '199681879', '585730' ]);
</script>
<script>!function(){"use strict";!function(e){if(-1===e.cookie.indexOf("__adblocker")){e.cookie="__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/";var t=new XMLHttpRequest;t.open("GET","https://ads.adthrive.com/abd/abd.js",!0),t.onreadystatechange=function(){if(XMLHttpRequest.DONE===t.readyState)if(200===t.status){var a=e.createElement("script");a.innerHTML=t.responseText,e.getElementsByTagName("head")[0].appendChild(a)}else{var n=new Date;n.setTime(n.getTime()+3e5),e.cookie="__adblocker=true; expires="+n.toUTCString()+"; path=/"}},t.send()}}(document)}();
</script><script>!function(){"use strict";var e;e=document,function(){var t,n;function r(){var t=e.createElement("script");t.src="https://cafemedia-com.videoplayerhub.com/galleryplayer.js",e.head.appendChild(t)}function a(){var t=e.cookie.match("(^|[^;]+)\\s*__adblocker\\s*=\\s*([^;]+)");return t&&t.pop()}function c(){clearInterval(n)}return{init:function(){var e;"true"===(t=a())?r():(e=0,n=setInterval((function(){100!==e&&"false"!==t||c(),"true"===t&&(r(),c()),t=a(),e++}),50))}}}().init()}();
</script>
	<style>
.modal {
	margin-top:200px;
}
.modal-backdrop {
	background: rgba(0,0,0,0.6);
}
.modal-body a {
	text-decoration: underline;
}
</style>
<div class="modal" id="ad-free-modal" tabindex="-1" role="dialog">
	<div class="modal-dialog" role="document">
		<div class="modal-content">
			<div class="modal-header">
				<h5 class="modal-title">Adblocker is on</h5>
				<button type="button" class="close" data-dismiss="modal" aria-label="Close">
					<span aria-hidden="true">&times;</span>
				</button>
			</div>
			<div class="modal-body">
				<p>We noticed your adblocker is on.  We use ads to fund this site and continue to bring you premium Steelers content.</p>
				<p>If you like what you see on this site, we now have an <a href="/go-ad-free" data-wpel-link="internal">ad-free option</a> available for a donation of $25 per year, and you can enjoy the site entirely ad-free!</p>
				<p>Additionally, if you'd like to donate above and beyond the ad-free option, you can <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&amp;hosted_button_id=XZ97MFHPQZYX4" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">donate via PayPal</a> as well.</p>
				<p>Finally, if you wish to not see this dialog box, please turn off your adblocker, and enjoy content normally</p>
				<p>Thank you for visiting Steelers Depot!</p>
			</div>
			<div class="modal-footer">
				<a href="/go-ad-free" class="btn btn-warning" style="color:white" data-wpel-link="internal">Go Ad-Free</a>
				<button type="button" class="btn btn-dark" data-dismiss="modal">Close</button>
			</div>
		</div>
	</div>
</div></body>
</html>