
<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />



<link rel="shortcut icon" href="https://steelersdepot.com/wp-content/uploads/2020/10/favicon-16x16-1.png" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://steelersdepot.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://steelersdepot.com/feed/atom/" />
<link rel="pingback" href="https://steelersdepot.com/xmlrpc.php" />

<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2021/07/StockMattCorral1-1000x600.jpg" />
<meta name="twitter:image" content="https://steelersdepot.com/wp-content/uploads/2021/07/StockMattCorral1-1000x600.jpg" />

<meta property="og:type" content="article" />
<meta property="og:description" content="No matter where you turn nationally for your mock draft fixings, the Pittsburgh Steelers continue to have the same position mocked to them time after time. That position? Quarterback, obviously. Following the retirement of Ben Roethlisberger, the Steelers are in need of a new franchise quarterback, though the 2022 draft class might not be the [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/">
<meta name="twitter:title" content="Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback">
<meta name="twitter:description" content="No matter where you turn nationally for your mock draft fixings, the Pittsburgh Steelers continue to have the same position mocked to them time after time. That position? Quarterback, obviously. Following the retirement of Ben Roethlisberger, the Steelers are in need of a new franchise quarterback, though the 2022 draft class might not be the [&hellip;]">


<meta name='robots' content='max-image-preview:large' />
<style>
	.adthrive-ad {
		margin-top: 10px;
		margin-bottom: 10px;
		text-align: center;
		overflow-x: visible;
		clear: both;
		line-height: 0;
	}
	.adthrive-sidebar.side-widget {
padding: 10px 0px;
}

#AdThrive_Sidebar_9_desktop {
margin-bottom: 100px;
}

body.adthrive-device-desktop #adthrive-collapse-container {
width: 60%;
max-width: 500px;
}

#adthrive-collapse-position.adthrive-collapse-float {
right: unset;
left: 5px;
width: 256px;
}

#adthrive-collapse-position.adthrive-collapse-mobile {
top: 80px;
}

.adthrive-sidebar.adthrive-stuck {
margin-top:80px;
}

.adthrive-content, .adthrive-header {
margin-left:auto;
margin-right:auto;
}</style>
<script>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</script>

<script>
(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-1.1.4';
	w.adthrive.host = 'ads.adthrive.com';
	w.adthrive.integration = 'plugin';

	var commitParam = (w.adthriveCLS && w.adthriveCLS.bucket !== 'prod' && w.adthriveCLS.branch) ? '&commit=' + w.adthriveCLS.branch : '';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/5e387029c4178d20fcc52aa6/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href) + commitParam + '&cb=' + (Math.floor(Math.random() * 100) + 1);
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);
</script>

	<!-- This site is optimized with the Yoast SEO Premium plugin v15.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback - Steelers Depot</title>
	<meta name="description" content="No matter where you turn nationally for your mock draft fixings, the Pittsburgh Steelers continue to have the same position mocked to them time after" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback - Steelers Depot" />
	<meta property="og:description" content="No matter where you turn nationally for your mock draft fixings, the Pittsburgh Steelers continue to have the same position mocked to them time after" />
	<meta property="og:url" content="https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/" />
	<meta property="og:site_name" content="Steelers Depot" />
	<meta property="article:publisher" content="https://www.facebook.com/steelersdepot" />
	<meta property="article:published_time" content="2022-03-05T17:00:41+00:00" />
	<meta property="article:modified_time" content="2022-03-05T16:45:29+00:00" />
	<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2021/07/StockMattCorral1.jpg" />
	<meta property="og:image:width" content="1024" />
	<meta property="og:image:height" content="683" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@Steelersdepot" />
	<meta name="twitter:site" content="@Steelersdepot" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://steelersdepot.com/#organization","name":"Steelers Depot","url":"https://steelersdepot.com/","sameAs":["https://www.facebook.com/steelersdepot","https://twitter.com/Steelersdepot"],"logo":{"@type":"ImageObject","@id":"https://steelersdepot.com/#logo","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2015/07/depot-logo.png","width":384,"height":100,"caption":"Steelers Depot"},"image":{"@id":"https://steelersdepot.com/#logo"}},{"@type":"WebSite","@id":"https://steelersdepot.com/#website","url":"https://steelersdepot.com/","name":"Steelers Depot","description":"Pittsburgh Steelers blog featuring news, discussion &amp; merchandise!","publisher":{"@id":"https://steelersdepot.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://steelersdepot.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/#primaryimage","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2021/07/StockMattCorral1.jpg","width":1024,"height":683,"caption":"FAYETTEVILLE, AR - OCTOBER 17: Mississippi Rebels quarterback Matt Corral (2) passes the ball in the game between the Ole Miss Rebels and the Arkansas Razorbacks on October 17, 2020 at Donald W. Reynolds Razorback Stadium in Fayetteville, AR. (Photo by John Bunch/Icon Sportswire via Getty Images)"},{"@type":"WebPage","@id":"https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/#webpage","url":"https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/","name":"Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback - Steelers Depot","isPartOf":{"@id":"https://steelersdepot.com/#website"},"primaryImageOfPage":{"@id":"https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/#primaryimage"},"datePublished":"2022-03-05T17:00:41+00:00","dateModified":"2022-03-05T16:45:29+00:00","description":"No matter where you turn nationally for your mock draft fixings, the Pittsburgh Steelers continue to have the same position mocked to them time after","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/"]}]},{"@type":"Article","@id":"https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/#article","isPartOf":{"@id":"https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/#webpage"},"author":{"@id":"https://steelersdepot.com/#/schema/person/45fccc3df559d569a907c30a223d71ec"},"headline":"Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback","datePublished":"2022-03-05T17:00:41+00:00","dateModified":"2022-03-05T16:45:29+00:00","mainEntityOfPage":{"@id":"https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/#webpage"},"commentCount":0,"publisher":{"@id":"https://steelersdepot.com/#organization"},"image":{"@id":"https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/#primaryimage"},"keywords":"2022 NFL Draft,Kevin Colbert,Matt Canada,Matt Corral,Mike Tomlin,Ole Miss,Pittsburgh Steelers","articleSection":"Article,NFL Draft,Steelers News","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/#respond"]}]},{"@type":"Person","@id":"https://steelersdepot.com/#/schema/person/45fccc3df559d569a907c30a223d71ec","name":"Josh Carney","image":{"@type":"ImageObject","@id":"https://steelersdepot.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/4f9b578d5e43a1cb73a41c3af7907076?s=96&d=mm&r=g","caption":"Josh Carney"}}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="https://steelersdepot.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback Comments Feed" href="https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.9.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.9.1/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.9.1/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='mvp-reset-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/reset.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-style-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/style.css?ver=5.9.1' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/css/iecss.css?ver=5.9.1' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mvp-style-entertainment-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/style-entertainment.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/media-queries.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://steelersdepot.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='child-main-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/main.min.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/css/bootstrap.min.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/10.7/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' data-cfasync="false" src='https://c0.wp.com/c/5.9.1/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' data-cfasync="false" src='https://c0.wp.com/c/5.9.1/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://steelersdepot.com/wp-json/" /><link rel="alternate" type="application/json" href="https://steelersdepot.com/wp-json/wp/v2/posts/563736" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://steelersdepot.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://steelersdepot.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/pdvQnt-2mEw' />
<link rel="alternate" type="application/json+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2022%2F03%2Flatest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2022%2F03%2Flatest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback%2F&#038;format=xml" />
<script type="text/javascript" data-cfasync="false">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</script>		<style type="text/css">
		.feedzy-rss-link-icon:after {
			content: url( "https://steelersdepot.com/wp-content/plugins/feedzy-rss-feeds/img/external-link.png" );
			margin-left: 3px;
		}
	</style>
		<script type="text/javascript">//<![CDATA[
  function external_links_in_new_windows_loop() {
    if (!document.links) {
      document.links = document.getElementsByTagName('a');
    }
    var change_link = false;
    var force = '';
    var ignore = '';

    for (var t=0; t<document.links.length; t++) {
      var all_links = document.links[t];
      change_link = false;
      
      if(document.links[t].hasAttribute('onClick') == false) {
        // forced if the address starts with http (or also https), but does not link to the current domain
        if(all_links.href.search(/^http/) != -1 && all_links.href.search('steelersdepot.com') == -1 && all_links.href.search(/^#/) == -1) {
          // console.log('Changed ' + all_links.href);
          change_link = true;
        }
          
        if(force != '' && all_links.href.search(force) != -1) {
          // forced
          // console.log('force ' + all_links.href);
          change_link = true;
        }
        
        if(ignore != '' && all_links.href.search(ignore) != -1) {
          // console.log('ignore ' + all_links.href);
          // ignored
          change_link = false;
        }

        if(change_link == true) {
          // console.log('Changed ' + all_links.href);
          document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
          document.links[t].removeAttribute('target');
        }
      }
    }
  }
  
  // Load
  function external_links_in_new_windows_load(func)
  {  
    var oldonload = window.onload;
    if (typeof window.onload != 'function'){
      window.onload = func;
    } else {
      window.onload = function(){
        oldonload();
        func();
      }
    }
  }

  external_links_in_new_windows_load(external_links_in_new_windows_loop);
  //]]></script>

<style type='text/css'>img#wpstats{display:none}</style>
	
<style type='text/css'>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</style>
	
<style type="text/css">


.post-cont-out,
.post-cont-in {
	margin-right: 0;
	}




.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -315px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 315px;
	}
.home-left-col {
	float: left;
	}
.home-mid-col {
	float: right;
	margin-left: 15px;
	margin-right: 0;
	}

@media screen and (max-width: 1399px) and (min-width: 1250px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1249px) and (min-width: 1100px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1099px) {
.home-wrap-out2,
.home-wrap-in2 {
	float: left;
	margin-left: 0;
	margin-right: 0;
	}
.home-mid-col {
	float: left;
	}
}
@media screen and (max-width: 479px) {
.home-mid-col {
	margin-left: 0;
	}
}





</style>

<script id="wccp_pro_disable_selection" type="text/javascript">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</script>
	<script type="text/javascript">
	jQuery(document).bind("keyup keydown", function(e){
		e = e || window.event; // also there is no e.target property in IE. instead IE uses window.event.srcElement
		console.log (e.keyCode);
		dealWithPrintScrKey(e);
});
	
	//window.addEventListener("keyup", dealWithPrintScrKey, false);
	document.onkeyup = dealWithPrintScrKey;
	function dealWithPrintScrKey(e)
	{
		e = e || window.event; // also there is no e.target property in IE. instead IE uses window.event.srcElement
		
		// gets called when any of the keyboard events are overheard
		var prtsc = e.keyCode||e.charCode;

		if (prtsc == 44)
		{
			e.cancelBubble = true;
			e.preventDefault();
			e.stopImmediatePropagation();
			show_wccp_pro_message('You are not allowed to print or save this page!!');
			copyToClipboard(document.getElementsByTagName('span')[0]);
		}
	}
	</script>
<link rel="stylesheet" href="https://steelersdepot.com/wp-content/plugins/wccp-pro/css/print-protection.css?ver=3" media="print">
<script id="wccp_pro_disable_hot_keys" type="text/javascript">
//<![CDATA[
////////////////For contenteditable tags
function wccp_pro_iscontenteditable(e)
{
	var e = e || window.event; // also there is no e.target property in IE. instead IE uses window.event.srcElement
  	
	var target = e.target || e.srcElement;

	var elemtype = e.target.nodeName;
	
	elemtype = elemtype.toUpperCase();
	
	var iscontenteditable = "false";
		
	if(typeof target.getAttribute!="undefined" ) iscontenteditable = target.getAttribute("contenteditable"); // Return true or false as string
	
	var iscontenteditable2 = false;
	
	if(typeof target.isContentEditable!="undefined" ) iscontenteditable2 = target.isContentEditable; // Return true or false as boolean

	if(target.parentElement !=null) iscontenteditable2 = target.parentElement.isContentEditable;
	
	if (iscontenteditable == "true" || iscontenteditable2 == true)
	{
		if(typeof target.style!="undefined" ) target.style.cursor = "text";
		
		return true;
	}
}
//////////////////Hot keys function
function disable_hot_keys(e)
{
	var key_number;
	
		if(window.event)
			  key_number = window.event.keyCode;     //IE
		else
			key_number = e.which;     //firefox (97)

	/////////////////////////////////////////////Case F12
			if (key_number == 123)//F12 chrome developer key disable
		{
			show_wccp_pro_message('You are not allowed to print or save this page!!');
			return false;
		}
		var elemtype = e.target.tagName;
	
	elemtype = elemtype.toUpperCase();
	
	if (elemtype == "TEXT" || elemtype == "TEXTAREA" || elemtype == "INPUT" || elemtype == "PASSWORD" || elemtype == "SELECT")
	{
		elemtype = 'TEXT';
	}
	
	if(wccp_pro_iscontenteditable(e)) elemtype = 'TEXT';
	
	if (e.ctrlKey || e.metaKey)
	{
		var key = key_number;
		
		console.log(key);

		if (elemtype!= 'TEXT' && (key == 97 || key == 99 || key == 120 || key == 26 || key == 43))
		{
			 show_wccp_pro_message('<b>Alert:</b> You are not allowed to copy content or view source');
			 return false;
		}
		if (elemtype!= 'TEXT')
		{
			/////////////////////////////////////////////Case Ctrl + A 65
						
			if (key == 65)
			{
				show_wccp_pro_message('You are not allowed to print or save this page!!');
				return false;
			}			
			/////////////////////////////////////////////Case Ctrl + C 67
						
			if (key == 67)
			{
				show_wccp_pro_message('You are not allowed to print or save this page!!');
				return false;
			}			
			/////////////////////////////////////////////Case Ctrl + X 88
						
			if (key == 88)
			{
				show_wccp_pro_message('You are not allowed to print or save this page!!');
				return false;
			}			
			/////////////////////////////////////////////Case Ctrl + V 86
						
			if (key == 86)
			{
				show_wccp_pro_message('You are not allowed to print or save this page!!');
				return false;
			}			
			/////////////////////////////////////////////Case Ctrl + U 85
						
			if (key == 85)
			{
				show_wccp_pro_message('You are not allowed to print or save this page!!');
				return false;
			}		}
		
		//For any emement type, text elemtype is not excluded here
		/////////////////////////////////////////////Case Ctrl + P 80 (prntscr = 44)
				if (key == 80 || key == 44)
		{
			show_wccp_pro_message('You are not allowed to print or save this page!!');
			return false;
		}		
		/////////////////////////////////////////////Case (CTRL + Shift + I) to show developer tools
					if (key == 73)//F12 chrome developer key disable
			{
				show_wccp_pro_message('You are not allowed to print or save this page!!');
				return false;
			}
				
		/////////////////////////////////////////////Case Ctrl + S 83
				
		if (key == 83)
		{
			show_wccp_pro_message('You are not allowed to print or save this page!!');
			return false;
		}    }
return true;
}

jQuery(document).bind("keyup keydown", disable_hot_keys);
</script>
<script id="wccp_pro_disable_Right_Click" type="text/javascript">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</script>
	
	<script>
	document.ondragstart = disable_drag_images;
		jQuery(document).ready(function(){
			jQuery('img').each(function() {
				jQuery(this).attr('draggable', false);
			});
		});
	</script>
	<style>
		img{
			-moz-user-select: none;
			-webkit-user-select: none;
			-ms-user-select: none;
			-khtml-user-select: none;
			user-select: none;
			-webkit-user-drag: none;
			user-drag: none;
			-webkit-touch-callout: none;
		}
	</style>
	<style>
	.cover-container {
	   border: 1px solid #DDDDDD;
	   width: 100%;
	   height: 100%;
	   position: relative;
	}
	.glass-cover {
	   float: left;
	   position: relative;
	   left: 0px;
	   top: 0px;
	   z-index: 1000;
	   background-color: #92AD40;
	   padding: 5px;
	   color: #FFFFFF;
	   font-weight: bold;
	}
	.unselectable
	{
	-moz-user-select:none;
	-webkit-user-select:none;
	-khtml-user-select: none;
	user-select: none;
	cursor: default;
	}
	html
	{
	-webkit-touch-callout: none;
	-webkit-user-select: none;
	-khtml-user-select: none;
	-moz-user-select: none;
	-ms-user-select: none;
	user-select: none;
	-webkit-tap-highlight-color: rgba(0,0,0,0);
	}
	img
	{
	-webkit-touch-callout:none;
	-webkit-user-select:none;
	-khtml-user-select: none;
	-moz-user-select: none;
	}
	</style>
	<script id="wccp_pro_css_disable_selection" type="text/javascript">
	function wccp_pro_msieversion() 
		{
			var ua = window.navigator.userAgent;
			var msie = ua.indexOf("MSIE");
			var msie2 = ua.indexOf("Edge");
			var msie3 = ua.indexOf("Trident");

		if (msie > -1 || msie2 > -1 || msie3 > -1) // If Internet Explorer, return version number
		{
			return "IE";
		}
		else  // If another browser, return 0
		{
			return "otherbrowser";
		}
	}
    
	var e = document.getElementsByTagName('H1')[0];
	if(e && wccp_pro_msieversion() == "IE")
	{
		e.setAttribute('unselectable',"on");
	}
	</script>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #eeeeee; }
</style>
	<script id='cls-disable-ads-886f5bb'>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</script>		<style type="text/css" id="wp-custom-css">
			/* Slide Menu Color Link Fix */
nav.fly-nav-menu ul li a {
	color: #FFF !important;
}

/* Slide Menu Sub-Menu Icon Fix */
nav.fly-nav-menu ul li.menu-item-has-children:after {
	top: 0;
	font-size: 28px;
}

nav.fly-nav-menu ul li.menu-item-has-children.tog-minus:after {
	top: -14px;
	}

/* Fly to Top Fix */
.fly-to-top {
	bottom: 100px;
}		</style>
		<script id='cls-header-insertion-886f5bb'>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</script>
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<script>
	     (adsbygoogle = window.adsbygoogle || []).push({
	          google_ad_client: "ca-pub-7138622909378284",
	          enable_page_level_ads: true
	     });
	</script>
	
		<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({article:'auto'});
		!function (e, f, u, i) {
			if (!document.getElementById(i)){
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}
		}(document.createElement('script'),
		document.getElementsByTagName('script')[0],
		'//cdn.taboola.com/libtrc/steelersdepot/loader.js',
		'tb_loader_script');
		if(window.performance && typeof window.performance.mark == 'function')
		{window.performance.mark('tbl_ic');}
	</script>
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-11437002-3"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-11437002-3');


</script>
<script type="text/javascript">
	  window.disqus_config = function () {
	    this.disable_ads = true;
	}
</script>
</head>


<body class="post-template-default single single-post postid-563736 single-format-standard custom-background logged-out unselectable at-ads-allowed">
	<div id="site" class="left relative">
		<div id="site-wrap" class="left relative">
						<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
									<li class="fb-soc">
						<a href="https://www.facebook.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-facebook-square fa-2"></i>
						</a>
					</li>
													<li class="twit-soc">
						<a href="https://twitter.com/Steelersdepot" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																	<li class="inst-soc">
						<a href="https://www.instagram.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-instagram fa-2"></i>
						</a>
					</li>
																	<li class="yt-soc">
						<a href="https://www.youtube.com/channel/UCFqbkq2BzNY3iQ_FPveqVhw" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-youtube-play fa-2"></i>
						</a>
					</li>
																	<li class="tum-soc">
						<a href="https://steelersdepot.tumblr.com/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
						<i class="fa fa-tumblr fa-2"></i>
						</a>
					</li>
													<li class="rss-soc">
						<a href="https://steelersdepot.com/feed/rss/" target="_blank" data-wpel-link="internal">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/" data-wpel-link="internal">Home</a></li>
<li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/" data-wpel-link="internal">Steelers News</a></li>
<li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/" data-wpel-link="internal">Steelers Wire</a></li>
<li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/" data-wpel-link="internal">Podcast</a></li>
<li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li id="menu-item-562385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-562385"><a href="https://steelersdepot.com/?s=2022+NFL+Draft+Player+Profiles" data-wpel-link="internal">2022 NFL Draft Player Profiles</a></li>
	<li id="menu-item-539603" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-539603"><a href="https://steelersdepot.com/2021-nfl-pro-day-results-tracker-scouting-combine-invitees/" data-wpel-link="internal">2021 NFL Pro Day Results Tracker – Scouting Combine Invitees</a></li>
	<li id="menu-item-535831" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-535831"><a href="https://steelersdepot.com/?s=2021+NFL+Draft+Player+Profiles" data-wpel-link="internal">2021 NFL Draft Player Profiles</a></li>
</ul>
</li>
<li id="menu-item-515035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li id="menu-item-515038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/" data-wpel-link="internal">Contact Us</a></li>
<li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4" data-wpel-link="external" rel="external noopener noreferrer">Donate</a></li>
<li id="menu-item-496474" class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/" data-wpel-link="internal">Go Ad-Free</a>
<ul class="sub-menu">
	<li id="menu-item-555072" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-555072"><a href="https://steelersdepot.com/profile/" data-wpel-link="internal">Resubscribe</a></li>
</ul>
</li>
<li id="menu-item-493254" class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php" data-wpel-link="internal">Login</a></li>
<li id="menu-item-493255" class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout" data-wpel-link="internal">Logout</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->			<div id="head-main-wrap" class="left relative">
				<div id="head-main-top" class="left relative">
																														</div><!--head-main-top-->
				<div id="main-nav-wrap">
					<div class="nav-out">
						<div class="nav-in">
							<div id="main-nav-cont" class="left" itemscope itemtype="http://schema.org/Organization">
								<div class="nav-logo-out">
									<div class="nav-left-wrap left relative">
										<div class="fly-but-wrap left relative">
											<span></span>
											<span></span>
											<span></span>
											<span></span>
										</div><!--fly-but-wrap-->
																					<div class="nav-logo left">
																									<a itemprop="url" href="https://steelersdepot.com/" data-wpel-link="internal"><img itemprop="logo" src="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png" alt="Steelers Depot" data-rjs="2" /></a>
																																					<h2 class="mvp-logo-title">Steelers Depot</h2>
																							</div><!--nav-logo-->
																			</div><!--nav-left-wrap-->
									<div class="nav-logo-in">
										<div class="nav-menu-out">
											<div class="nav-menu-in">
												<nav class="main-menu-wrap left">
													<div class="menu-header-container"><ul id="menu-header-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/" data-wpel-link="internal">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/" data-wpel-link="internal">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/" data-wpel-link="internal">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/" data-wpel-link="internal">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-562385"><a href="https://steelersdepot.com/?s=2022+NFL+Draft+Player+Profiles" data-wpel-link="internal">2022 NFL Draft Player Profiles</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-539603"><a href="https://steelersdepot.com/2021-nfl-pro-day-results-tracker-scouting-combine-invitees/" data-wpel-link="internal">2021 NFL Pro Day Results Tracker – Scouting Combine Invitees</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-535831"><a href="https://steelersdepot.com/?s=2021+NFL+Draft+Player+Profiles" data-wpel-link="internal">2021 NFL Draft Player Profiles</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/" data-wpel-link="internal">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4" data-wpel-link="external" rel="external noopener noreferrer">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/" data-wpel-link="internal">Go Ad-Free</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-555072"><a href="https://steelersdepot.com/profile/" data-wpel-link="internal">Resubscribe</a></li>
</ul>
</li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php" data-wpel-link="internal">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout" data-wpel-link="internal">Logout</a></li>
</ul></div>												</nav>
											</div><!--nav-menu-in-->
											<div class="nav-right-wrap relative">
												<div class="nav-search-wrap left relative">
													<span class="nav-search-but left"><i class="fa fa-search fa-2"></i></span>
													<div class="search-fly-wrap">
														<form method="get" id="searchform" action="https://steelersdepot.com/">
	<input type="text" name="s" id="s" value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>													</div><!--search-fly-wrap-->
												</div><!--nav-search-wrap-->
																									<a href="https://www.facebook.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
													<span class="nav-soc-but"><i class="fa fa-facebook fa-2"></i></span>
													</a>
																																					<a href="https://twitter.com/Steelersdepot" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
													<span class="nav-soc-but"><i class="fa fa-twitter fa-2"></i></span>
													</a>
																							</div><!--nav-right-wrap-->
										</div><!--nav-menu-out-->
									</div><!--nav-logo-in-->
								</div><!--nav-logo-out-->
							</div><!--main-nav-cont-->
						</div><!--nav-in-->
					</div><!--nav-out-->
				</div><!--main-nav-wrap-->
			</div><!--head-main-wrap-->
										<div id="body-main-wrap" class="left relative" itemscope itemtype="http://schema.org/NewsArticle">
					<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/"/>
																																			<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="body-main-cont" class="left relative">
																		<!-- <div style="margin-bottom:40px">
	<h5>Send Alex to Training Camp</h5>
	<iframe class='gfm-media-widget' image='0' coinfo='0' width='100%' height='100%' frameborder='0' id='steelers-depot-2018-training-camp'></iframe>
	<script src='//funds.gofundme.com/js/5.0/media-widget.js'></script>
	<style>
	.gfm-widget {
		width: 100%;
		max-width: initial;
	}
	</style>
	<script>
	jQuery(function($){
	});
	</script>
</div> --><div id="post-main-wrap" class="left relative">
	<div class="post-wrap-out1">
		<div class="post-wrap-in1">
			<div id="post-left-col" class="relative">
	<article id="post-area" class="post-563736 post type-post status-publish format-standard has-post-thumbnail hentry category-article category-nfl-draft category-news tag-2022-nfl-draft tag-kevin-colbert tag-matt-canada tag-matt-corral tag-mike-tomlin tag-ole-miss tag-pittsburgh-steelers">
			<header id="post-header">
							<a class="post-cat-link" href="https://steelersdepot.com/category/article/" data-wpel-link="internal"><span class="post-head-cat">Article</span></a>
						<h1 class="post-title entry-title left" itemprop="headline">Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback</h1>
							<div id="post-info-wrap" class="left relative">
					<div class="post-info-out">
						<div class="post-info-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/4f9b578d5e43a1cb73a41c3af7907076?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/4f9b578d5e43a1cb73a41c3af7907076?s=100&#038;d=mm&#038;r=g 2x' class='avatar arm_grid_avatar arm-avatar avatar-50 photo' height='50' width='50' loading='lazy'/>						</div><!--post-info-img-->
						<div class="post-info-in">
							<div class="post-info-right left relative">
								<div class="post-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
									<span class="post-info-text">By</span> <span class="author-name vcard fn author" itemprop="name"><a href="https://steelersdepot.com/author/jcarney_sports/" title="Posts by Josh Carney" rel="author" data-wpel-link="internal">Josh Carney</a></span> 																	</div><!--post-info-name-->
								<div class="post-info-date left relative">
									<span class="post-info-text">Posted on</span> <span class="post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-03-05">March 5, 2022 at 12:00 pm</time></span>
									<meta itemprop="dateModified" content="2022-03-05"/>
								</div><!--post-info-date-->
							</div><!--post-info-right-->
						</div><!--post-info-in-->
					</div><!--post-info-out-->
				</div><!--post-info-wrap-->
					</header><!--post-header-->
	

			<section class="social-sharing-top">
			<a href="#" onclick="window.open(&#039;http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/&amp;t=Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback&#039;, &#039;facebookShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open(&#039;http://twitter.com/share?text=Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback -&amp;url=https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/&#039;, &#039;twitterShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
			<a href="whatsapp://send?text=Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/" data-wpel-link="internal"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open(&#039;http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/&amp;media=https://steelersdepot.com/wp-content/uploads/2021/07/StockMattCorral1-1000x600.jpg&amp;description=Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback&#039;, &#039;pinterestShare&#039;, &#039;width=750,height=350&#039;); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="/cdn-cgi/l/email-protection#18276b6d7a727d7b6c2554796c7d6b6c385b5a4b384b68776a6c6b3855777b73385c6a797e6c384b7d7d6b384b6c7d7d747d6a6b385479767c38417d6c385976776c707d6a38496d796a6c7d6a7a797b733e797568235a575c412551387e776d767c386c70716b38796a6c717b747d3871766c7d6a7d6b6c71767f3879767c386c70776d7f706c38777e386b70796a71767f38716c386f716c703861776d36385b707d7b7338716c38776d6c2238706c6c686b2237376b6c7d7d747d6a6b7c7d68776c367b7775372a282a2a37282b3774796c7d6b6c357b7a6b356b68776a6c6b3575777b73357c6a797e6c356b7d7d6b356b6c7d7d747d6a6b357479767c35617d6c357976776c707d6a35696d796a6c7d6a7a797b7337"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
																	<a href="#disqus_thread"><div class="social-comments comment-click-563736"><i class="fa fa-commenting fa-2"></i></div></a>
									</section><!--social-sharing-top-->
	


																					<div class="left" id="post-feat-img-wrapper">
							<div id="post-feat-img" class="relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
								<img width="1024" height="683" src="https://steelersdepot.com/wp-content/uploads/2021/07/StockMattCorral1.jpg" class="attachment- size- wp-post-image" alt="Matt Corral" srcset="https://steelersdepot.com/wp-content/uploads/2021/07/StockMattCorral1.jpg 1024w, https://steelersdepot.com/wp-content/uploads/2021/07/StockMattCorral1-300x200.jpg 300w, https://steelersdepot.com/wp-content/uploads/2021/07/StockMattCorral1-768x512.jpg 768w" sizes="(max-width: 1024px) 100vw, 1024px" />																<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2021/07/StockMattCorral1.jpg">
								<meta itemprop="width" content="1024">
								<meta itemprop="height" content="683">
								<div class="post-feat-text">
																										</div><!--post-feat-text-->
							</div><!--post-feat-img-->
						</div>
																<div id="content-area" itemprop="articleBody" class="post-563736 post type-post status-publish format-standard has-post-thumbnail hentry category-article category-nfl-draft category-news tag-2022-nfl-draft tag-kevin-colbert tag-matt-canada tag-matt-corral tag-mike-tomlin tag-ole-miss tag-pittsburgh-steelers">
		<div class="post-cont-out">
			<div class="post-cont-in">
				<div id="content-main" class="left relative">

						
	
		<div class="post-specific-content">
<p>No matter where you turn nationally for your mock draft fixings, the Pittsburgh Steelers continue to have the same position mocked to them time after time.</p>
<p>That position?</p>
<p>Quarterback, obviously.</p>
<p>Following the retirement of Ben Roethlisberger, the Steelers are in need of a new franchise quarterback, though the 2022 draft class might not be the one to provide that.</p>
<p>However, the Steelers continue to have quarterbacks mocked to them, and in the <a href="https://www.cbssports.com/nfl/draft/news/2022-nfl-mock-draft-five-qbs-go-in-first-round-as-combine-performances-boost-stock-of-top-prospects/" data-wpel-link="external" rel="external noopener noreferrer">latest mock draft from CBS Sports&#8217; Ryan Stackpole</a>, the Steelers land yet another QB, this time Ole Miss&#8217; Matt Corral, <a href="https://steelersdepot.com/2022/03/ole-miss-qb-matt-corral-says-hes-met-with-steelers-great-group-of-guys/" data-wpel-link="internal">a QB that formally met with the Steelers during the 2022 NFL Scouting Combine and spoke glowingly about potentially playing in the Steel City in the NFL. </a></p>
<p><em>&#8220;The Steelers avoid having to trade up to get Corral, who must improve his field awareness and decision making but will have the luxury of a quality supporting cast of skill players in Pittsburgh,&#8221; Stackpole writes. </em></p>
<p>The best thing that could possibly happen in the first round of the 2022 NFL Draft is that one of the top QBs that the Steelers like falls to No. 20 overall, allowing the Steelers to not only address position of need, but avoid trading away future draft capital, allowing them to continue to build around the quarterback of the future through the draft.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">One thing I love about Matt Corral? Toughness. <br /> <a href="https://t.co/NNTed0ARrP" data-wpel-link="external" rel="external noopener noreferrer">pic.twitter.com/NNTed0ARrP</a></p>
<p>&mdash; Saturday Gameday (@SaturdayGameday) <a href="https://twitter.com/SaturdayGameday/status/1499200272870133770?ref_src=twsrc%5Etfw" data-wpel-link="external" rel="external noopener noreferrer">March 3, 2022</a></p></blockquote>
<p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Of course, it never truly works out that way in the end, but in that perfect scenario the Steelers land an ideal fit in Matt Canada&#8217;s offense in Corral, who ran an RPO-heavy system at Ole Miss under Lane Kiffin the last two seasons. That said, Corral has struggled at times on tape when forced to move past his first read when it&#8217;s not there.</p>
<p>He put up great numbers in the SEC, throws one of the better balls in the class and is an impressive athlete with great mobility and competitiveness overall. He certainly feels like a fit.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">After taking a deeper dive on the QB class, I&#39;m a lot higher on Matt Corral. Great athleticism and arm talent. <a href="https://twitter.com/hashtag/BroncosCountry?src=hash&amp;ref_src=twsrc%5Etfw" data-wpel-link="external" rel="external noopener noreferrer">#BroncosCountry</a></p>
<p>His tape vs. Arkansas was impressive: <a href="https://t.co/DzwxVBpeVm" data-wpel-link="external" rel="external noopener noreferrer">pic.twitter.com/DzwxVBpeVm</a></p>
<p>&mdash; Jakob Ashlin (@JakobAshlin) <a href="https://twitter.com/JakobAshlin/status/1499043717491081229?ref_src=twsrc%5Etfw" data-wpel-link="external" rel="external noopener noreferrer">March 2, 2022</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Here&#8217;s what Jonathan Heitritter had to say about Corral in our scouting report on the Rebels&#8217; star QB.</p>
<p><em>&#8220;Corral would best be served going to a spread/West Coast offense that utilizes RPOs and quick hitters where he can make quick reads and get the ball out quickly while still having the ability to attack defenses down the field. Offensive systems like San Francisco and New Orleans can maximize his strengths as a passer with their respective schemes. Matt Canada’s offense in Pittsburgh could also be a logical fit given the pre-snap motions and RPOs they want to run, but the lack of projection could be an issue for a player of Corral’s stature. All said, Corral has the arm talent, mobility, and football character as a leader to make him a potential long-term solution at QB and a likely high draft selection.&#8221;</em></p>
<blockquote class="wp-embedded-content" data-secret="FRjhOFdWg3"><p><a href="https://steelersdepot.com/2022/02/2022-nfl-draft-player-profiles-ole-miss-qb-matt-corral/" data-wpel-link="internal">2022 NFL Draft Player Profiles: Ole Miss QB Matt Corral</a></p></blockquote>
<p><iframe class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" title="&#8220;2022 NFL Draft Player Profiles: Ole Miss QB Matt Corral&#8221; &#8212; Steelers Depot" src="https://steelersdepot.com/2022/02/2022-nfl-draft-player-profiles-ole-miss-qb-matt-corral/embed/#?secret=z3VM5QBXrv#?secret=FRjhOFdWg3" data-secret="FRjhOFdWg3" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe></p>
<script async data-uid="5b5b391c79" src="https://steelersdepot.ck.page/5b5b391c79/index.js"></script></div>

	<div id="taboola-below-article">
	</div>

															<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
						<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
															<img src="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png"/>
								<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png">
													</div><!--mvp-org-logo-->
						<meta itemprop="name" content="Steelers Depot">
					</div><!--mvp-org-wrap-->
					<div class="posts-nav-link">
											</div><!--posts-nav-link-->
											<div class="post-tags">
							<span class="post-tags-header">Related Items:</span><span itemprop="keywords"><a href="https://steelersdepot.com/tag/2022-nfl-draft/" rel="tag" data-wpel-link="internal">2022 NFL Draft</a>, <a href="https://steelersdepot.com/tag/kevin-colbert/" rel="tag" data-wpel-link="internal">Kevin Colbert</a>, <a href="https://steelersdepot.com/tag/matt-canada/" rel="tag" data-wpel-link="internal">Matt Canada</a>, <a href="https://steelersdepot.com/tag/matt-corral/" rel="tag" data-wpel-link="internal">Matt Corral</a>, <a href="https://steelersdepot.com/tag/mike-tomlin/" rel="tag" data-wpel-link="internal">Mike Tomlin</a>, <a href="https://steelersdepot.com/tag/ole-miss/" rel="tag" data-wpel-link="internal">Ole Miss</a>, <a href="https://steelersdepot.com/tag/pittsburgh-steelers/" rel="tag" data-wpel-link="internal">Pittsburgh Steelers</a></span>
						</div><!--post-tags-->
																<div class="social-sharing-bot">
							<a href="#" onclick="window.open(&#039;http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/&amp;t=Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback&#039;, &#039;facebookShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span> <span style="color: #fff; font-family: 'Montserrat', sans-serif; font-size: 10px; font-weight: 400; line-height: 100%; padding: 8px 0; text-transform: uppercase;"></span></div></a>
							<a href="#" onclick="window.open(&#039;http://twitter.com/share?text=Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback -&amp;url=https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/&#039;, &#039;twitterShare&#039;, &#039;width=626,height=436&#039;); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
							<a href="whatsapp://send?text=Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/" data-wpel-link="internal"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="#" onclick="window.open(&#039;http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/&amp;media=https://steelersdepot.com/wp-content/uploads/2021/07/StockMattCorral1-1000x600.jpg&amp;description=Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback&#039;, &#039;pinterestShare&#039;, &#039;width=750,height=350&#039;); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="/cdn-cgi/l/email-protection#79460a0c1b131c1a0d4435180d1c0a0d593a3b2a592a09160b0d0a5934161a12593d0b181f0d592a1c1c0a592a0d1c1c151c0b0a593518171d59201c0d593817160d111c0b59280c180b0d1c0b1b181a125f181409423b363d204430591f160c171d590d11100a59180b0d101a151c5910170d1c0b1c0a0d10171e5918171d590d11160c1e110d59161f590a11180b10171e59100d590e100d115900160c57593a111c1a1259100d59160c0d4359110d0d090a4356560a0d1c1c151c0b0a1d1c09160d571a1614564b494b4b56494a5615180d1c0a0d541a1b0a540a09160b0d0a5414161a12541d0b181f0d540a1c1c0a540a0d1c1c151c0b0a541518171d54001c0d541817160d111c0b54080c180b0d1c0b1b181a1256"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
						</div><!--social-sharing-bot-->
																            <div class="mvp-related-posts left relative">
		<h4 class="post-header"><span class="post-header">Recommended for you</span></h4>
			<ul>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2022/03/steelers-kendrick-green-reflects-on-trying-rookie-season-a-lot-of-learning-lessons-and-growing-pains/" rel="bookmark" title="Steelers&#8217; Kendrick Green Reflects On Trying Rookie Season: &#8216;A Lot Of Learning Lessons And Growing Pains&#8217;" data-wpel-link="internal">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2021/09/Ben-Roethlisberger-Kendrick-Green-Zach-Banner-300x180.jpg" class="reg-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2021/09/Ben-Roethlisberger-Kendrick-Green-Zach-Banner-300x180.jpg 300w, https://steelersdepot.com/wp-content/uploads/2021/09/Ben-Roethlisberger-Kendrick-Green-Zach-Banner-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2021/09/Ben-Roethlisberger-Kendrick-Green-Zach-Banner-80x80.jpg" class="mob-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2021/09/Ben-Roethlisberger-Kendrick-Green-Zach-Banner-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2021/09/Ben-Roethlisberger-Kendrick-Green-Zach-Banner-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2022/03/steelers-kendrick-green-reflects-on-trying-rookie-season-a-lot-of-learning-lessons-and-growing-pains/" data-wpel-link="internal">Steelers&#8217; Kendrick Green Reflects On Trying Rookie Season: &#8216;A Lot Of Learning Lessons And Growing Pains&#8217;</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2022/03/2022-nfl-draft-player-profiles-kentucky-ol-darian-kinnard/" rel="bookmark" title="2022 NFL Draft Player Profiles: Kentucky OL Darian Kinnard" data-wpel-link="internal">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2022/03/StockKinnard1-300x180.jpg" class="reg-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2022/03/StockKinnard1-300x180.jpg 300w, https://steelersdepot.com/wp-content/uploads/2022/03/StockKinnard1-1000x600.jpg 1000w, https://steelersdepot.com/wp-content/uploads/2022/03/StockKinnard1-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2022/03/StockKinnard1-80x80.jpg" class="mob-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2022/03/StockKinnard1-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2022/03/StockKinnard1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2022/03/2022-nfl-draft-player-profiles-kentucky-ol-darian-kinnard/" data-wpel-link="internal">2022 NFL Draft Player Profiles: Kentucky OL Darian Kinnard</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2022/03/2022-steelers-combine-interview-master-list-updating/" rel="bookmark" title="2022 Steelers Combine Interview Master List (Updating)" data-wpel-link="internal">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2020/02/nfl-scouting-combine-300x180.jpg" class="reg-img wp-post-image" alt="NFL Scouting Combine logo" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2020/02/nfl-scouting-combine-300x180.jpg 300w, https://steelersdepot.com/wp-content/uploads/2020/02/nfl-scouting-combine-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2020/02/nfl-scouting-combine-80x80.jpg" class="mob-img wp-post-image" alt="NFL Scouting Combine logo" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2020/02/nfl-scouting-combine-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2020/02/nfl-scouting-combine-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2022/03/2022-steelers-combine-interview-master-list-updating/" data-wpel-link="internal">2022 Steelers Combine Interview Master List (Updating)</a>
				</div><!--related-text-->
            			</li>
            		</ul></div>																					<div id="disqus_thread"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
    /**
     *  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT 
     *  THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR 
     *  PLATFORM OR CMS.
     *  
     *  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: 
     *  https://disqus.com/admin/universalcode/#configuration-variables
     */
    /*
    var disqus_config = function () {
        // Replace PAGE_URL with your page's canonical URL variable
        this.page.url = PAGE_URL;  
        
        // Replace PAGE_IDENTIFIER with your page's unique identifier variable
        this.page.identifier = PAGE_IDENTIFIER; 
    };
    */


	// DISQUS.reset({
	// 	reload: true,
	// 	config: function () {  
	// 		this.page.identifier = 'steelersdepot';
	// 		this.page.url = 'https://steelersdepot.com/2022/03/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback/';
	// 	}
	// });
 //    var changeThread = function(){
 //    };


    var disqus_loaded = false;
    
	if (typeof(disqus_loaded)=="undefined" || !disqus_loaded) {
		disqus_loaded=1;
		jQuery.ajax({
			type: 'GET',
			url: 'https://steelersdepot.disqus.com/embed.js',
			dataType: 'script',
			cache: true
		});
	} 

    // (function() {
    //     var d = document, s = d.createElement('script');
        
    //     s.src = 'https://steelersdepot.disqus.com/embed.js';
    //     // s.src = '/wp-content/themes/flex-mag-child/assets/js/disqus-post.js';
        
    //     s.setAttribute('data-timestamp', +new Date());
    //     (d.head || d.body).appendChild(s);
    // })();
</script>
<noscript>
    Please enable JavaScript to view the 
    <a href="https://disqus.com/?ref_noscript" rel="nofollow external noopener noreferrer" data-wpel-link="external">
        comments powered by Disqus.
    </a>
</noscript>									</div><!--content-main-->
			</div><!--post-cont-in-->
					</div><!--post-cont-out-->
	</div><!--content-area-->
</article>
				</div><!--post-left-col-->
			</div><!--post-wrap-in1-->
			
							<div id="post-right-col" class="relative">
																		<div id="sidebar-wrap" class="left relative theiaStickySidebar">
	<div id="custom_html-29" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a target="_blank" href="https://fanatics.ncw6.net/c/2325230/618771/9663" rel="noopener external noreferrer" data-wpel-link="external"><img src="https://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></div><!--sidebar-wrap-->															</div><!--post-right-col-->
					</div><!--post-wrap-out1-->
</div><!--post-main-wrap-->
											</div><!--body-main-cont-->
				</div><!--body-main-in-->
			</div><!--body-main-out-->
		</div><!--body-main-wrap-->
		<footer id="foot-wrap" class="left relative">
			<div id="foot-top-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-widget-wrap" class="left relative">
															<div class="foot-widget left relative">
																			<div class="foot-logo left realtive">
											<img src="https://steelersdepot.com/wp-content/themes/flex-mag/images/logos/logo-foot.png" alt="Steelers Depot" data-rjs="2" />
										</div><!--foot-logo-->
																		<div class="foot-info-text left relative">
										<p>Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem?</p><p>Temporibus autem quibusdam et aut officiis debitis aut rerum necessitatibus saepe eveniet.</p>									</div><!--footer-info-text-->
									<div class="foot-soc left relative">
										<ul class="foot-soc-list relative">
																							<li class="foot-soc-fb">
													<a href="https://www.facebook.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-facebook-square fa-2"></i></a>
												</li>
																																		<li class="foot-soc-twit">
													<a href="https://twitter.com/Steelersdepot" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-twitter-square fa-2"></i></a>
												</li>
																																													<li class="foot-soc-inst">
													<a href="https://www.instagram.com/steelersdepot/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-instagram fa-2"></i></a>
												</li>
																																													<li class="foot-soc-yt">
													<a href="https://www.youtube.com/channel/UCFqbkq2BzNY3iQ_FPveqVhw" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-youtube-play fa-2"></i></a>
												</li>
																																													<li class="foot-soc-tumb">
													<a href="https://steelersdepot.tumblr.com/" target="_blank" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-tumblr-square fa-2"></i></a>
												</li>
																																		<li class="foot-soc-rss">
													<a href="https://steelersdepot.com/feed/rss/" target="_blank" data-wpel-link="internal"><i class="fa fa-rss-square fa-2"></i></a>
												</li>
																					</ul>
									</div><!--foot-soc-->
								</div><!--foot-widget-->
																				</div><!--foot-widget-wrap-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-top-->
			<div id="foot-bot-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-bot" class="left relative">
							<div class="foot-menu relative">
								<div class="menu-header-container"><ul id="menu-header-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/" data-wpel-link="internal">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/" data-wpel-link="internal">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/" data-wpel-link="internal">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/" data-wpel-link="internal">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-562385"><a href="https://steelersdepot.com/?s=2022+NFL+Draft+Player+Profiles" data-wpel-link="internal">2022 NFL Draft Player Profiles</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-539603"><a href="https://steelersdepot.com/2021-nfl-pro-day-results-tracker-scouting-combine-invitees/" data-wpel-link="internal">2021 NFL Pro Day Results Tracker – Scouting Combine Invitees</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-535831"><a href="https://steelersdepot.com/?s=2021+NFL+Draft+Player+Profiles" data-wpel-link="internal">2021 NFL Draft Player Profiles</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/" data-wpel-link="internal">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4" data-wpel-link="external" rel="external noopener noreferrer">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/" data-wpel-link="internal">Go Ad-Free</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-555072"><a href="https://steelersdepot.com/profile/" data-wpel-link="internal">Resubscribe</a></li>
</ul>
</li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php" data-wpel-link="internal">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout" data-wpel-link="internal">Logout</a></li>
</ul></div>							</div><!--foot-menu-->
							<div class="foot-copy relative">
								<p>&copy; 2022 Steelers Depot</p>
							</div><!--foot-copy-->
						</div><!--foot-bot-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-bot-->
		</footer>
	</div><!--site-wrap-->
</div><!--site-->
<div class="fly-to-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
	<span class="to-top-text">To Top</span>
</div><!--fly-to-top-->
<div class="fly-fade">
</div><!--fly-fade-->
<script id='cls-insertion-886f5bb'>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</script><script>(function () {var clsElements = document.querySelectorAll("script[id^='cls-']"); window.adthriveCLS && clsElements && clsElements.length === 0 ? window.adthriveCLS.injectedFromPlugin = false : ""; })();</script>			<script data-cfasync="false" type="text/javascript">
			function arm_open_modal_box_in_nav_menu(menu_id, form_id) {
                           
				jQuery(".arm_nav_menu_link_" + form_id).find("." + form_id).trigger("click");
				return false;
			}
			</script>
					<div data-theiaStickySidebar-sidebarSelector='"#tab-col2"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":0,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#tab-col3"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#post-right-col"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		
<script type="text/javascript">
jQuery(document).ready(function($) {

	// Back to Top Button
    	var duration = 500;
    	$('.back-to-top').click(function(event) {
          event.preventDefault();
          $('html, body').animate({scrollTop: 0}, duration);
          return false;
	});

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

	  	$(".comment-click-563736").on("click", function(){
  	  $(".com-click-id-563736").show();
	  $(".disqus-thread-563736").show();
  	  $(".com-but-563736").hide();
  	});
	

$(window).load(function() {
  // The slider being synced must be initialized first
  $('.post-gallery-bot').flexslider({
    animation: "slide",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    itemWidth: 80,
    itemMargin: 10,
    asNavFor: '.post-gallery-top'
  });

  $('.post-gallery-top').flexslider({
    animation: "fade",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    	  prevText: "&lt;",
          nextText: "&gt;",
    sync: ".post-gallery-bot"
  });
});

});

</script>

<style type="text/css" data-asas-style="">body, div, p, span{ cursor: inherit ; user-select: none !important; 
	-webkit-touch-callout: none; -webkit-user-select: none; -khtml-user-select: none; -moz-user-select: none;
		-ms-user-select: none;
	}
	*[contenteditable="true"] {
  -webkit-user-select: auto !important;
  user-select: all !important;
  pointer-events: auto !important;
}
	a{ cursor: pointer ; user-select: none !important; pointer-events: auto !important;}
	h1, h2, h3, h4, h5, h6{ cursor: default ; user-select: none !important; 
	-webkit-touch-callout: none; -webkit-user-select: none; -khtml-user-select: none; -moz-user-select: none;
		-ms-user-select: none;
	}
	</style><style>TEXT,TEXTAREA,input[type=text],input[type=password],input[type=number] {cursor: text !important; user-select: text !important;}</style>	<div oncontextmenu="return false;" id='wccp_pro_mask'></div>
	<div id="wpcp-error-message" class="msgmsg-box-wpcp hideme"><span>error: </span><b>Alert:</b> Content is protected !!</div>
	<script>
	var timeout_result;
	function show_wccp_pro_message(smessage)
	{
				
		timeout = 3000;
		
		if (smessage !== "" && timeout!=0)
		{
			var smessage_text = smessage;
			jquery_fadeTo();
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, timeout);
		}
		else
		{
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, timeout);
		}
	}
	function hide_message()
	{
		jquery_fadeOut();
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	function jquery_fadeTo()
	{
		try {
			jQuery("#wccp_pro_mask").fadeTo("slow", 0.3);
		}
		catch(err) {
			//alert(err.message);
			}
	}
	function jquery_fadeOut()
	{
		try {
			jQuery("#wccp_pro_mask").fadeOut( "slow" );
		}
		catch(err) {}
	}
	</script>
	<style type="text/css">
	#wccp_pro_mask
	{
		position: absolute;
		bottom: 0;
		left: 0;
		position: fixed;
		right: 0;
		top: 0;
		background-color: #000;
		pointer-events: none;
		display: none;
		z-index: 10000;
		animation: 0.5s ease 0s normal none 1 running ngdialog-fadein;
		background: rgba(0, 0, 0, 0.4) none repeat scroll 0 0;
	}
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
		pointer-events: none;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px #f2bfbf;
		-moz-box-shadow: 0px 0px 34px 2px #f2bfbf;
		box-shadow: 0px 0px 34px 2px #f2bfbf;
	}
	.msgmsg-box-wpcp b {
		font-weight:bold;
		text-transform:uppercase;
	}
		.warning-wpcp {
		background:#ffecec url('https://steelersdepot.com/wp-content/plugins/wccp-pro/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f2bfbf;
	}
    </style>
<script id="wccp_pro_class_exclusion" type="text/javascript">
function copyToClipboard(elem) {
	  // create hidden text element, if it doesn't already exist
    var targetId = "_wccp_pro_hiddenCopyText_";
    {
        // must use a temporary form element for the selection and copy
        target = document.getElementById(targetId);
        if (!target) {
            var target = document.createElement("textarea");
            target.style.position = "absolute";
            target.style.left = "-9999px";
            target.style.top = "0";
            target.id = targetId;
            document.body.appendChild(target);
        }
        target.textContent = elem.textContent;
    }
    // select the content
    var currentFocus = document.activeElement;
    target.focus();
    target.setSelectionRange(0, target.value.length);
    
    // copy the selection
    var succeed;
    try {
    	  succeed = document.execCommand("copy");
    } catch(e) {
        succeed = false;
    }

    // restore original focus
    if (currentFocus && typeof currentFocus.focus === "function") {
        currentFocus.focus();
    }
    
    
	// clear temporary content
	target.textContent = "";
	document.getElementsByTagName('span')[0].innerHTML = " ";
    return succeed;
}

</script>

<script id="wccp_pro_class_exclusion" type="text/javascript">
function apply_class_exclusion(e)
{
	var my_return = 'No';
	
	var e = e || window.event; // also there is no e.target property in IE. instead IE uses window.event.srcElement
  	
	var target = e.target || e.srcElement || 'nothing';
	
	if(target.parentElement != null) console.log (target.parentElement.className);
	
	var excluded_classes = '' + '';
	
	var class_to_exclude = "";
	
	if(target.parentElement != null)
	{
		class_to_exclude = target.className + ' ' + target.parentElement.className || '';
	}else{
		class_to_exclude = target.className;
	}
	
	var class_to_exclude_array = class_to_exclude.split(" ");
	
	console.log (class_to_exclude_array);
	
	class_to_exclude_array.forEach(function(item)
	{
		if(item != '' && excluded_classes.indexOf(item)>=0)
		{
			target.style.cursor = "text";
			
			console.log ('Yes');
			
			my_return = 'Yes';
		}
	});

	try {
		class_to_exclude = target.parentElement.getAttribute('class') || target.parentElement.className || '';
		}
	catch(err) 
		{
		class_to_exclude = '';
		}
	
	if(class_to_exclude != '' && excluded_classes.indexOf(class_to_exclude)>=0)
	{
		target.style.cursor = "text";
		my_return = 'Yes';
	}

	return my_return;
}
</script>
<script type='text/javascript' data-cfasync="false" src='https://c0.wp.com/c/5.9.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' data-cfasync="false" src='https://c0.wp.com/c/5.9.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' id='convertkit-js-js-extra'>
/* <![CDATA[ */
var convertkit = {"ajaxurl":"https:\/\/steelersdepot.com\/wp-admin\/admin-ajax.php","debug":"","nonce":"9e519edd37","subscriber_id":"0","tag":"","post_id":"563736"};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/convertkit/resources/frontend/js/convertkit.js?ver=1.9.6.8' id='convertkit-js-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"steelersdepot"};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"563736 https:\/\/steelersdepot.com\/?p=563736","disqusShortname":"steelersdepot","disqusTitle":"Latest CBS Sports Mock Draft Sees Steelers Land Yet Another Quarterback","disqusUrl":"https:\/\/steelersdepot.com\/2022\/03\/latest-cbs-sports-mock-draft-sees-steelers-land-yet-another-quarterback\/","postId":"563736"};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=1646499740' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.6.3' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.6.3' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag/js/autoloadpost.js?ver=5.9.1' id='mvp-autoloadpost-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag/js/retina.js?ver=5.9.1' id='retina-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag-child/assets/js/main.min.js?ver=5.9.1' id='main-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag-child/assets/js/scripts.js?ver=5.9.1' id='mvp-child-flexmag-js'></script>
<script type='text/javascript' src='https://js.stripe.com/v3/?ver=746' id='arm_stripe_v3-js'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script src='https://stats.wp.com/e-202209.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.7',blog:'199681879',post:'563736',tz:'-5',srv:'steelersdepot.com'} ]);
	_stq.push([ 'clickTrackerInit', '199681879', '563736' ]);
</script>
<script>!function(){"use strict";!function(e){if(-1===e.cookie.indexOf("__adblocker")){e.cookie="__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/";var t=new XMLHttpRequest;t.open("GET","https://www.npttech.com/advertising.js",!0),t.onreadystatechange=function(){if(XMLHttpRequest.DONE===t.readyState)if(200===t.status){var n=e.createElement("script");n.innerHTML=t.responseText,e.getElementsByTagName("head")[0].appendChild(n)}else{var a=new Date;a.setTime(a.getTime()+3e5),e.cookie="__adblocker=true; expires="+a.toUTCString()+"; path=/"}},t.send()}}(document)}();
</script><script>!function(){"use strict";var e;e=document,function(){var t,n;function r(){var t=e.createElement("script");t.src="https://cafemedia-com.videoplayerhub.com/galleryplayer.js",e.head.appendChild(t)}function a(){var t=e.cookie.match("(^|[^;]+)\\s*__adblocker\\s*=\\s*([^;]+)");return t&&t.pop()}function c(){clearInterval(n)}return{init:function(){var e;"true"===(t=a())?r():(e=0,n=setInterval((function(){100!==e&&"false"!==t||c(),"true"===t&&(r(),c()),t=a(),e++}),50))}}}().init()}();
</script>
	<style>
.modal {
	margin-top:200px;
}
.modal-backdrop {
	background: rgba(0,0,0,0.6);
}
.modal-body a {
	text-decoration: underline;
}
</style>
<div class="modal" id="ad-free-modal" tabindex="-1" role="dialog">
	<div class="modal-dialog" role="document">
		<div class="modal-content">
			<div class="modal-header">
				<h5 class="modal-title">Adblocker is on</h5>
				<button type="button" class="close" data-dismiss="modal" aria-label="Close">
					<span aria-hidden="true">&times;</span>
				</button>
			</div>
			<div class="modal-body">
				<p>We noticed your adblocker is on.  We use ads to fund this site and continue to bring you premium Steelers content.</p>
				<p>If you like what you see on this site, we now have an <a href="/go-ad-free" data-wpel-link="internal">ad-free option</a> available for a donation of $25 per year, and you can enjoy the site entirely ad-free!</p>
				<p>Additionally, if you'd like to donate above and beyond the ad-free option, you can <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&amp;hosted_button_id=XZ97MFHPQZYX4" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">donate via PayPal</a> as well.</p>
				<p>Finally, if you wish to not see this dialog box, please turn off your adblocker, and enjoy content normally</p>
				<p>Thank you for visiting Steelers Depot!</p>
			</div>
			<div class="modal-footer">
				<a href="/go-ad-free" class="btn btn-warning" style="color:white" data-wpel-link="internal">Go Ad-Free</a>
				<button type="button" class="btn btn-dark" data-dismiss="modal">Close</button>
			</div>
		</div>
	</div>
</div></body>
</html>