
<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />



<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://steelersdepot.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://steelersdepot.com/feed/atom/" />
<link rel="pingback" href="https://steelersdepot.com/xmlrpc.php" />

<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth.jpg" />
<meta name="twitter:image" content="https://steelersdepot.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth.jpg" />

<meta property="og:type" content="article" />
<meta property="og:description" content="Listmania has taken over the offseason in the NFL more than ever this year since, ordinarily, reporters would at least have OTAs to cover, to some degree. While we are still getting interviews in some form or fashion here or there, they’re not like what they used to be. And pardon me if you’ll let [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/">
<meta name="twitter:title" content="Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger">
<meta name="twitter:description" content="Listmania has taken over the offseason in the NFL more than ever this year since, ordinarily, reporters would at least have OTAs to cover, to some degree. While we are still getting interviews in some form or fashion here or there, they’re not like what they used to be. And pardon me if you’ll let [&hellip;]">


<script>
window.adthrive = window.adthrive || {};
window.adthrive.cmd = window.adthrive.cmd || [];
window.adthrive.host = 'ads.adthrive.com';
window.adthrive.plugin = 'adthrive-ads-1.0.37';
window.adthrive.threshold = Math.floor(Math.random() * 100 + 1);

(function() {
	var script = document.createElement('script');
	script.async = true;
	script.type = 'text/javascript';
	script.src = 'https://ads.adthrive.com/sites/5e387029c4178d20fcc52aa6/ads.min.js?threshold=' + window.adthrive.threshold;
	var node = document.getElementsByTagName('script')[0];
	node.parentNode.insertBefore(script, node);
})();
</script>

	<!-- This site is optimized with the Yoast SEO Premium plugin v14.0.4 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger - Steelers Depot</title>
	<meta name="description" content="Listmania has taken over the offseason in the NFL more than ever this year since, ordinarily, reporters would at least have OTAs to cover, to some degree." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger - Steelers Depot" />
	<meta property="og:description" content="Listmania has taken over the offseason in the NFL more than ever this year since, ordinarily, reporters would at least have OTAs to cover, to some degree." />
	<meta property="og:url" content="https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/" />
	<meta property="og:site_name" content="Steelers Depot" />
	<meta property="article:publisher" content="https://www.facebook.com/steelersdepot" />
	<meta property="article:published_time" content="2020-06-02T15:00:00+00:00" />
	<meta property="article:modified_time" content="2020-06-02T11:20:20+00:00" />
	<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth.jpg" />
	<meta property="og:image:width" content="777" />
	<meta property="og:image:height" content="437" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@mmarczi" />
	<meta name="twitter:site" content="@Steelersdepot" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://steelersdepot.com/#organization","name":"Steelers Depot","url":"https://steelersdepot.com/","sameAs":["https://www.facebook.com/steelersdepot","https://twitter.com/Steelersdepot"],"logo":{"@type":"ImageObject","@id":"https://steelersdepot.com/#logo","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2015/07/depot-logo.png","width":384,"height":100,"caption":"Steelers Depot"},"image":{"@id":"https://steelersdepot.com/#logo"}},{"@type":"WebSite","@id":"https://steelersdepot.com/#website","url":"https://steelersdepot.com/","name":"Steelers Depot","description":"Pittsburgh Steelers blog featuring news, discussion &amp; merchandise!","publisher":{"@id":"https://steelersdepot.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://steelersdepot.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/#primaryimage","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth.jpg","width":"777","height":"437"},{"@type":"WebPage","@id":"https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/#webpage","url":"https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/","name":"Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger - Steelers Depot","isPartOf":{"@id":"https://steelersdepot.com/#website"},"primaryImageOfPage":{"@id":"https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/#primaryimage"},"datePublished":"2020-06-02T15:00:00+00:00","dateModified":"2020-06-02T11:20:20+00:00","description":"Listmania has taken over the offseason in the NFL more than ever this year since, ordinarily, reporters would at least have OTAs to cover, to some degree.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/"]}]},{"@type":"Article","@id":"https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/#article","isPartOf":{"@id":"https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/#webpage"},"author":{"@id":"https://steelersdepot.com/#/schema/person/1246034710ae30de8500effe3c401793"},"headline":"Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger","datePublished":"2020-06-02T15:00:00+00:00","dateModified":"2020-06-02T11:20:20+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/#webpage"},"publisher":{"@id":"https://steelersdepot.com/#organization"},"image":{"@id":"https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/#primaryimage"},"keywords":"Steelers","articleSection":"Article","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/#respond"]}]},{"@type":["Person"],"@id":"https://steelersdepot.com/#/schema/person/1246034710ae30de8500effe3c401793","name":"Matthew Marczi","image":{"@type":"ImageObject","@id":"https://steelersdepot.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/7fa7ee85674b58205a210a9bb2891f7d?s=96&d=mm&r=g","caption":"Matthew Marczi"},"description":"Passionate Steelers fan with a bit of writing ability. Connoisseur of loud music. Follow me on Twitter @mmarczi.","sameAs":["https://twitter.com/mmarczi"]}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="https://steelersdepot.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger Comments Feed" href="https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mvp-reset-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/css/reset.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-style-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/style.css?ver=5.4.1' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/css/iecss.css?ver=5.4.1' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mvp-style-entertainment-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/css/style-entertainment.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/css/media-queries.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='child-main-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/assets/css/_main.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/css/bootstrap.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.4.2' type='text/css' media='all' />
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://steelersdepot.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://steelersdepot.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://steelersdepot.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/pPyaZ-2cjW' />
<link rel="alternate" type="application/json+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2020%2F06%2Fshannon-sharpe-takes-1975-steelers-as-best-team-since-merger%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2020%2F06%2Fshannon-sharpe-takes-1975-steelers-as-best-team-since-merger%2F&#038;format=xml" />
<script type="text/javascript" data-cfasync="false">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</script>
<!-- BEGIN Clicky Analytics v1.6.1 Tracking - https://deconf.com/clicky-analytics-dashboard-wordpress/ -->
<script type="text/javascript">
  var clicky_custom = clicky_custom || {};
  clicky_custom.outbound_pattern = ['/go/','/out/'];
</script>

<script type="text/javascript">var clicky_site_ids = clicky_site_ids || [];clicky_site_ids.push(101252837);</script><script async src="//static.getclicky.com/js"></script>

<!-- END Clicky Analytics v1.6.1 Tracking - https://deconf.com/clicky-analytics-dashboard-wordpress/ -->
<style type='text/css'>img#wpstats{display:none}</style>
<style type='text/css'>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</style>
	
<style type="text/css">


.post-cont-out,
.post-cont-in {
	margin-right: 0;
	}




.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -315px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 315px;
	}
.home-left-col {
	float: left;
	}
.home-mid-col {
	float: right;
	margin-left: 15px;
	margin-right: 0;
	}

@media screen and (max-width: 1399px) and (min-width: 1250px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1249px) and (min-width: 1100px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1099px) {
.home-wrap-out2,
.home-wrap-in2 {
	float: left;
	margin-left: 0;
	margin-right: 0;
	}
.home-mid-col {
	float: left;
	}
}
@media screen and (max-width: 479px) {
.home-mid-col {
	margin-left: 0;
	}
}





</style>

<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #eeeeee; }
</style>
	

</head>


<body class="post-template-default single single-post postid-524020 single-format-standard custom-background logged-out at-ads-allowed">
		
	<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','/wp-content/themes/flex-mag-child/assets/js/google-analytics.js','ga');

	ga('create', 'UA-11437002-3', 'auto');
	ga('send', 'pageview');
	</script>
	<div id="site" class="left relative">
		<div id="site-wrap" class="left relative">
						<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
									<li class="fb-soc">
						<a href="https://www.facebook.com/steelersdepot/" target="_blank">
						<i class="fa fa-facebook-square fa-2"></i>
						</a>
					</li>
													<li class="twit-soc">
						<a href="https://twitter.com/Steelersdepot" target="_blank">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																																					<li class="rss-soc">
						<a href="https://steelersdepot.com/feed/rss/" target="_blank">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li id="menu-item-520576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/">2020 NFL Scouting Combine Results Tracker</a></li>
	<li id="menu-item-520575" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li id="menu-item-520730" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li id="menu-item-515035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-515038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/">Contact Us</a></li>
<li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li id="menu-item-496474" class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li id="menu-item-493254" class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li id="menu-item-493255" class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->			<div id="head-main-wrap" class="left relative">
				<div id="head-main-top" class="left relative">
																														</div><!--head-main-top-->
				<div id="main-nav-wrap">
					<div class="nav-out">
						<div class="nav-in">
							<div id="main-nav-cont" class="left" itemscope itemtype="http://schema.org/Organization">
								<div class="nav-logo-out">
									<div class="nav-left-wrap left relative">
										<div class="fly-but-wrap left relative">
											<span></span>
											<span></span>
											<span></span>
											<span></span>
										</div><!--fly-but-wrap-->
																					<div class="nav-logo left">
																									<a itemprop="url" href="https://steelersdepot.com/"><img itemprop="logo" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png" alt="Steelers Depot" data-rjs="2" /></a>
																																					<h2 class="mvp-logo-title">Steelers Depot</h2>
																							</div><!--nav-logo-->
																			</div><!--nav-left-wrap-->
									<div class="nav-logo-in">
										<div class="nav-menu-out">
											<div class="nav-menu-in">
												<nav class="main-menu-wrap left">
													<div class="menu-header-container"><ul id="menu-header-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/">2020 NFL Scouting Combine Results Tracker</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>												</nav>
											</div><!--nav-menu-in-->
											<div class="nav-right-wrap relative">
												<div class="nav-search-wrap left relative">
													<span class="nav-search-but left"><i class="fa fa-search fa-2"></i></span>
													<div class="search-fly-wrap">
														<form method="get" id="searchform" action="https://steelersdepot.com/">
	<input type="text" name="s" id="s" value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>													</div><!--search-fly-wrap-->
												</div><!--nav-search-wrap-->
																									<a href="https://www.facebook.com/steelersdepot/" target="_blank">
													<span class="nav-soc-but"><i class="fa fa-facebook fa-2"></i></span>
													</a>
																																					<a href="https://twitter.com/Steelersdepot" target="_blank">
													<span class="nav-soc-but"><i class="fa fa-twitter fa-2"></i></span>
													</a>
																							</div><!--nav-right-wrap-->
										</div><!--nav-menu-out-->
									</div><!--nav-logo-in-->
								</div><!--nav-logo-out-->
							</div><!--main-nav-cont-->
						</div><!--nav-in-->
					</div><!--nav-out-->
				</div><!--main-nav-wrap-->
			</div><!--head-main-wrap-->
										<div id="body-main-wrap" class="left relative" itemscope itemtype="http://schema.org/NewsArticle">
					<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/"/>
																																			<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="body-main-cont" class="left relative">
																			<div id="leader-wrap" class="left relative">
								<!-- large column top -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7138622909378284"
     data-ad-slot="9571372570"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>							</div><!--leader-wrap-->
												<!-- <div style="margin-bottom:40px">
	<h5>Send Alex to Training Camp</h5>
	<iframe class='gfm-media-widget' image='0' coinfo='0' width='100%' height='100%' frameborder='0' id='steelers-depot-2018-training-camp'></iframe>
	<script src='//funds.gofundme.com/js/5.0/media-widget.js'></script>
	<style>
	.gfm-widget {
		width: 100%;
		max-width: initial;
	}
	</style>
	<script>
	jQuery(function($){
	});
	</script>
</div> --><div id="post-main-wrap" class="left relative">
	<div class="post-wrap-out1">
		<div class="post-wrap-in1">
			<div id="post-left-col" class="relative">
	<article id="post-area" class="post-524020 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-steelers">
			<header id="post-header">
							<a class="post-cat-link" href="https://steelersdepot.com/category/article/"><span class="post-head-cat">Article</span></a>
						<h1 class="post-title entry-title left" itemprop="headline">Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger</h1>
							<div id="post-info-wrap" class="left relative">
					<div class="post-info-out">
						<div class="post-info-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/7fa7ee85674b58205a210a9bb2891f7d?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7fa7ee85674b58205a210a9bb2891f7d?s=100&#038;d=mm&#038;r=g 2x' class='avatar arm_grid_avatar arm-avatar avatar-50 photo' height='50' width='50' />						</div><!--post-info-img-->
						<div class="post-info-in">
							<div class="post-info-right left relative">
								<div class="post-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
									<span class="post-info-text">By</span> <span class="author-name vcard fn author" itemprop="name"><a href="https://steelersdepot.com/author/matthew-marczi/" title="Posts by Matthew Marczi" rel="author">Matthew Marczi</a></span> <span class="author-twitter"><a href="https://twitter.com/mmarczi" class="twitter-but" target="_blank"><i class="fa fa-twitter fa-2"></i></a></span>																	</div><!--post-info-name-->
								<div class="post-info-date left relative">
									<span class="post-info-text">Posted on</span> <span class="post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-06-02">June 2, 2020 at 11:00 am</time></span>
									<meta itemprop="dateModified" content="2020-06-02"/>
								</div><!--post-info-date-->
							</div><!--post-info-right-->
						</div><!--post-info-in-->
					</div><!--post-info-out-->
				</div><!--post-info-wrap-->
					</header><!--post-header-->
	

			<section class="social-sharing-top">
			<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/&amp;t=Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open('http://twitter.com/share?text=Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger -&amp;url=https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
			<a href="whatsapp://send?text=Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/&amp;media=https://steelersdepot.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth.jpg&amp;description=Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="/cdn-cgi/l/email-protection#cdf2beb8afa7a8aeb9f09ea5aca3a3a2a3ed9ea5acbfbda8ed99aca6a8beedfcf4faf8ed9eb9a8a8a1a8bfbeed8cbeed8fa8beb9ed99a8aca0ed9ea4a3aea8ed80a8bfaaa8bfebaca0bdf68f828994f084edaba2b8a3a9edb9a5a4beedacbfb9a4aea1a8eda4a3b9a8bfa8beb9a4a3aaedaca3a9edb9a5a2b8aaa5b9eda2abedbea5acbfa4a3aaeda4b9edbaa4b9a5edb4a2b8e3ed8ea5a8aea6eda4b9eda2b8b9f7eda5b9b9bdbef7e2e2beb9a8a8a1a8bfbea9a8bda2b9e3aea2a0e2fffdfffde2fdfbe2bea5aca3a3a2a3e0bea5acbfbda8e0b9aca6a8bee0fcf4faf8e0beb9a8a8a1a8bfbee0acbee0afa8beb9e0b9a8aca0e0bea4a3aea8e0a0a8bfaaa8bfe2"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
																	<a href="#disqus_thread"><div class="social-comments comment-click-524020"><i class="fa fa-commenting fa-2"></i></div></a>
									</section><!--social-sharing-top-->
	


																					<div class="left" id="post-feat-img-wrapper">
							<div id="post-feat-img" class="relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
								<img width="777" height="437" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth.jpg 777w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth-300x169.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth-768x432.jpg 768w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth-180x101.jpg 180w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth-260x146.jpg 260w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth-373x210.jpg 373w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth-120x67.jpg 120w" sizes="(max-width: 777px) 100vw, 777px" />																<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth.jpg">
								<meta itemprop="width" content="777">
								<meta itemprop="height" content="437">
								<div class="post-feat-text">
																										</div><!--post-feat-text-->
							</div><!--post-feat-img-->
						</div>
																<div id="content-area" itemprop="articleBody" class="post-524020 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-steelers">
		<div class="post-cont-out">
			<div class="post-cont-in">
				<div id="content-main" class="left relative">

						
	
		<div class="post-specific-content">
<p>Listmania has taken over the offseason in the NFL more than ever this year since, ordinarily, reporters would at least have OTAs to cover, to some degree. While we are still getting interviews in some form or fashion here or there, they’re not like what they used to be.</p>
<p>And pardon me if you’ll let me digress for a moment here, but let’s think about this for a second. We’re facing the possibility that we may not have locker room interviews, at least in the very immediate future, the way they used to. Nobody is going to allow a scrum of dozens of reporters to line of in front of the guy who scored the game-winning touchdown this fall. So the media’s job is going to be different. I’m not sure if locker room interviews will ever be quite the same.</p>
<p>But anyway, what I was getting at is that we have yet another list on our hands. The Athletic put together a list of the most dominant seasons since 1970. The Pittsburgh Steelers and their six Super Bowls didn’t even crack the top five—though they came close, with the 1975 season ranked at six.</p>
<p>They took the ‘best’ season from each team and punched in a formula accounting for regular- and postseason winning percentage as well as points per game ratio, the former two each weighted at 35 percent and the latter two at 10 percent.</p>
<p>You can debate the efficiency of the metrics—and well, that’s the whole point. That’s what many have been doing. Including Shannon Sharpe, who argued that the Steelers’ team should rank on the top of the list.</p>
<p>“I went with the ’75 Steelers. They had 10 Hall of Famers”, he said on Undisputed, talking with Skip Bayless. “I don’t think we’ll ever see that again. They outscored their opponents by 15 points a game. The defense on average gave up 11.6 points a game. That’s unbelievable”.</p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">&#8220;To me, the greatest team is the &#8217;75 Steelers. They had 10 HOFers and I don&#8217;t think we&#8217;ll ever see that again. They outscored their opponents by 15 a game &amp; their defense let up an average of 11.6 points a game. They kept the Cowboys from winning a couple SBs.&#8221;</p>
<p>— <a href="https://twitter.com/ShannonSharpe?ref_src=twsrc%5Etfw">@ShannonSharpe</a> <a href="https://t.co/kww0TrLsGa">pic.twitter.com/kww0TrLsGa</a></p>
<p>— UNDISPUTED (@undisputed) <a href="https://twitter.com/undisputed/status/1266385122829324288?ref_src=twsrc%5Etfw">May 29, 2020</a></p></blockquote>
<p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>He took particular joy in reminding the Cowboys fan Bayless that the Steelers got a couple of Super Bowl titles off of Dallas. “They used to beat the brakes off of your Cowboys, so you should give them even more credit than they, because they kept the Cowboys from winning a couple of Super Bowls”, he said.</p>
<p>Pittsburgh, of course, defeated the Cowboys twice in the Super Bowl during the 1970s, including in that 1975 season, and again in 1978, though they did win in 1971 and 1977.</p>
<p>1975 was a damn good year, though. They averaged 26.6 points per game, which is their highest total in franchise history. Even when they set a franchise record in 2015 with 423 points scored, they still averaged 26.4 points. They only played 14 games in 1975. And they literally outscored their opponents by 15 points per game. Which is ridiculous.</p>
</div>

	<div id="taboola-below-article">
	</div>

															<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
						<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
															<img src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png"/>
								<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png">
													</div><!--mvp-org-logo-->
						<meta itemprop="name" content="Steelers Depot">
					</div><!--mvp-org-wrap-->
					<div class="posts-nav-link">
											</div><!--posts-nav-link-->
											<div class="post-tags">
							<span class="post-tags-header">Related Items:</span><span itemprop="keywords"><a href="https://steelersdepot.com/tag/steelers/" rel="tag">Steelers</a></span>
						</div><!--post-tags-->
																<div class="social-sharing-bot">
							<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/&amp;t=Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span> <span style="color: #fff; font-family: 'Montserrat', sans-serif; font-size: 10px; font-weight: 400; line-height: 100%; padding: 8px 0; text-transform: uppercase;"></span></div></a>
							<a href="#" onclick="window.open('http://twitter.com/share?text=Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger -&amp;url=https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
							<a href="whatsapp://send?text=Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/&amp;media=https://steelersdepot.com/wp-content/uploads/2017/06/Lynn-Swann-John-Stallworth.jpg&amp;description=Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="/cdn-cgi/l/email-protection#0a35797f68606f697e3759626b646465642a59626b787a6f2a5e6b616f792a3b333d3f2a597e6f6f666f78792a4b792a486f797e2a5e6f6b672a596364696f2a476f786d6f782c6b677a3148454e5337432a6c657f646e2a7e6263792a6b787e6369666f2a63647e6f786f797e63646d2a6b646e2a7e62657f6d627e2a656c2a79626b7863646d2a637e2a7d637e622a73657f242a49626f69612a637e2a657f7e302a627e7e7a79302525797e6f6f666f78796e6f7a657e2469656725383a383a253a3c2579626b646465642779626b787a6f277e6b616f79273b333d3f27797e6f6f666f7879276b7927686f797e277e6f6b6727796364696f27676f786d6f7825"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
						</div><!--social-sharing-bot-->
																            <div class="mvp-related-posts left relative">
		<h4 class="post-header"><span class="post-header">Recommended for you</span></h4>
			<ul>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2020/06/desean-jackson-wants-players-miced-up-on-sundays-if-games-are-played-without-fans/" rel="bookmark" title="DeSean Jackson Wants Players Mic&#8217;ed Up On Sundays If Games Are Played Without Fans">
						<img width="300" height="169" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field.jpg" class="reg-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field.jpg 777w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-300x169.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-768x432.jpg 768w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-180x101.jpg 180w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-260x146.jpg 260w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-373x210.jpg 373w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-120x67.jpg 120w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="45" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field.jpg" class="mob-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field.jpg 777w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-300x169.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-768x432.jpg 768w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-180x101.jpg 180w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-260x146.jpg 260w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-373x210.jpg 373w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/Dan-Rooney-Heinz-Field-120x67.jpg 120w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2020/06/desean-jackson-wants-players-miced-up-on-sundays-if-games-are-played-without-fans/">DeSean Jackson Wants Players Mic&#8217;ed Up On Sundays If Games Are Played Without Fans</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2020/06/2020-offseason-questions-biggest-thing-defense-can-improve-upon/" rel="bookmark" title="2020 Offseason Questions: Biggest Thing Defense Can Improve Upon?">
						<img width="300" height="180" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/12/Joe-Haden-upset-300x180.jpg" class="reg-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/12/Joe-Haden-upset-300x180.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/12/Joe-Haden-upset-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/12/Joe-Haden-upset-80x80.jpg" class="mob-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/12/Joe-Haden-upset-80x80.jpg 80w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/12/Joe-Haden-upset-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2020/06/2020-offseason-questions-biggest-thing-defense-can-improve-upon/">2020 Offseason Questions: Biggest Thing Defense Can Improve Upon?</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2020/06/steelers-return-4th-most-defensive-snaps-from-2019-in-nfl/" rel="bookmark" title="Steelers Return 4th-Most Defensive Snaps From 2019 In NFL">
						<img width="300" height="180" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/12/defense-celebrate-300x180.jpg" class="reg-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/12/defense-celebrate-300x180.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/12/defense-celebrate-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/12/defense-celebrate-80x80.jpg" class="mob-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/12/defense-celebrate-80x80.jpg 80w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/12/defense-celebrate-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2020/06/steelers-return-4th-most-defensive-snaps-from-2019-in-nfl/">Steelers Return 4th-Most Defensive Snaps From 2019 In NFL</a>
				</div><!--related-text-->
            			</li>
            		</ul></div>																					<div id="disqus_thread"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
    /**
     *  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT 
     *  THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR 
     *  PLATFORM OR CMS.
     *  
     *  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: 
     *  https://disqus.com/admin/universalcode/#configuration-variables
     */
    /*
    var disqus_config = function () {
        // Replace PAGE_URL with your page's canonical URL variable
        this.page.url = PAGE_URL;  
        
        // Replace PAGE_IDENTIFIER with your page's unique identifier variable
        this.page.identifier = PAGE_IDENTIFIER; 
    };
    */


	// DISQUS.reset({
	// 	reload: true,
	// 	config: function () {  
	// 		this.page.identifier = 'steelersdepot';
	// 		this.page.url = 'https://steelersdepot.com/2020/06/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger/';
	// 	}
	// });
 //    var changeThread = function(){
 //    };


    var disqus_loaded = false;
    
	if (typeof(disqus_loaded)=="undefined" || !disqus_loaded) {
		disqus_loaded=1;
		jQuery.ajax({
			type: 'GET',
			url: 'https://steelersdepot.disqus.com/embed.js',
			dataType: 'script',
			cache: true
		});
	} 

    // (function() {
    //     var d = document, s = d.createElement('script');
        
    //     s.src = 'https://steelersdepot.disqus.com/embed.js';
    //     // s.src = 'https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/assets/js/disqus-post.js';
        
    //     s.setAttribute('data-timestamp', +new Date());
    //     (d.head || d.body).appendChild(s);
    // })();
</script>
<noscript>
    Please enable JavaScript to view the 
    <a href="https://disqus.com/?ref_noscript" rel="nofollow">
        comments powered by Disqus.
    </a>
</noscript>									</div><!--content-main-->
			</div><!--post-cont-in-->
					</div><!--post-cont-out-->
	</div><!--content-area-->
</article>
				</div><!--post-left-col-->
			</div><!--post-wrap-in1-->
			
							<div id="post-right-col" class="relative">
																		<div id="sidebar-wrap" class="left relative theiaStickySidebar">
	<div id="custom_html-29" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a target="_blank" href="https://shareasale.com/r.cfm?b=31196&u=275818&m=7124&urllink=www%2Efanatics%2Ecom%2Fnfl%2Fpittsburgh%2Dsteelers%2Fo%2D2449%2Bt%2D03379361%2Bz%2D94360%2D2312615936&afftrack=" rel="noopener noreferrer"><img src="https://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></div><!--sidebar-wrap-->															</div><!--post-right-col-->
					</div><!--post-wrap-out1-->
</div><!--post-main-wrap-->
											</div><!--body-main-cont-->
				</div><!--body-main-in-->
			</div><!--body-main-out-->
		</div><!--body-main-wrap-->

		<footer id="foot-wrap" class="left relative">
			<div id="foot-top-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-widget-wrap" class="left relative">
															<div class="foot-widget left relative">
																			<div class="foot-logo left realtive">
											<img src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/images/logos/logo-foot.png" alt="Steelers Depot" data-rjs="2" />
										</div><!--foot-logo-->
																		<div class="foot-info-text left relative">
										<p>Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem?</p><p>Temporibus autem quibusdam et aut officiis debitis aut rerum necessitatibus saepe eveniet.</p>									</div><!--footer-info-text-->
									<div class="foot-soc left relative">
										<ul class="foot-soc-list relative">
																							<li class="foot-soc-fb">
													<a href="https://www.facebook.com/steelersdepot/" target="_blank"><i class="fa fa-facebook-square fa-2"></i></a>
												</li>
																																		<li class="foot-soc-twit">
													<a href="https://twitter.com/Steelersdepot" target="_blank"><i class="fa fa-twitter-square fa-2"></i></a>
												</li>
																																																																																																				<li class="foot-soc-rss">
													<a href="https://steelersdepot.com/feed/rss/" target="_blank"><i class="fa fa-rss-square fa-2"></i></a>
												</li>
																					</ul>
									</div><!--foot-soc-->
								</div><!--foot-widget-->
																				</div><!--foot-widget-wrap-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-top-->
			<div id="foot-bot-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-bot" class="left relative">
							<div class="foot-menu relative">
								<div class="menu-header-container"><ul id="menu-header-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/">2020 NFL Scouting Combine Results Tracker</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>							</div><!--foot-menu-->
							<div class="foot-copy relative">
								<p>&copy; 2020 Steelers Depot</p>
							</div><!--foot-copy-->
						</div><!--foot-bot-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-bot-->
		</footer>
	</div><!--site-wrap-->
</div><!--site-->
<div class="fly-to-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
	<span class="to-top-text">To Top</span>
</div><!--fly-to-top-->
<div class="fly-fade">
</div><!--fly-fade-->
			<script data-cfasync="false" type="text/javascript">
			function arm_open_modal_box_in_nav_menu(menu_id, form_id) {
                           
				jQuery(".arm_nav_menu_link_" + form_id).find("." + form_id).trigger("click");
				return false;
			}
			</script>
			
<!-- BEGIN Clicky Analytics v1.6.1 Tracking - https://deconf.com/clicky-analytics-dashboard-wordpress/ -->
<noscript><p><img alt="Clicky" width="1" height="1" src="//in.getclicky.com/100669114ns.gif" /></p></noscript>
<!-- END Clicky Analytics v1.6.1 Tracking - https://deconf.com/clicky-analytics-dashboard-wordpress/ -->
		<div data-theiaStickySidebar-sidebarSelector='"#tab-col2"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":0,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#tab-col3"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#post-right-col"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		<script>
(function (w, d) {
	var s = d.createElement('script');
	s.src = "https://dstik9906m659.cloudfront.net/eVIfRVUUblIfRlskRCEyUu.js";
	s.defer = true;
	d.body.appendChild(s);
})(window, document);
</script>

<script type="text/javascript">
jQuery(document).ready(function($) {

	// Back to Top Button
    	var duration = 500;
    	$('.back-to-top').click(function(event) {
          event.preventDefault();
          $('html, body').animate({scrollTop: 0}, duration);
          return false;
	});

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

	  	$(".comment-click-524020").on("click", function(){
  	  $(".com-click-id-524020").show();
	  $(".disqus-thread-524020").show();
  	  $(".com-but-524020").hide();
  	});
	

$(window).load(function() {
  // The slider being synced must be initialized first
  $('.post-gallery-bot').flexslider({
    animation: "slide",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    itemWidth: 80,
    itemMargin: 10,
    asNavFor: '.post-gallery-top'
  });

  $('.post-gallery-top').flexslider({
    animation: "fade",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    	  prevText: "&lt;",
          nextText: "&gt;",
    sync: ".post-gallery-bot"
  });
});

});

</script>

<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=5.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"steelersdepot"};
/* ]]> */
</script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"524020 https:\/\/steelersdepot.com\/?p=524020","disqusShortname":"steelersdepot","disqusTitle":"Shannon Sharpe Takes 1975 Steelers As Best Team Since Merger","disqusUrl":"https:\/\/steelersdepot.com\/2020\/06\/shannon-sharpe-takes-1975-steelers-as-best-team-since-merger\/","postId":"524020"};
/* ]]> */
</script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.6.3'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.6.3'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/js/scripts.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/js/autoloadpost.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/js/retina.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/assets/js/_main.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/assets/js/main.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script type='text/javascript' src='https://stats.wp.com/e-202023.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.4.2',blog:'12286105',post:'524020',tz:'-4',srv:'steelersdepot.com'} ]);
	_stq.push([ 'clickTrackerInit', '12286105', '524020' ]);
</script>

	<style>
.modal {
	margin-top:200px;
}
.modal-backdrop {
	background: rgba(0,0,0,0.6);
}
.modal-body a {
	text-decoration: underline;
}
</style>
<div class="modal" id="ad-free-modal" tabindex="-1" role="dialog">
	<div class="modal-dialog" role="document">
		<div class="modal-content">
			<div class="modal-header">
				<h5 class="modal-title">Adblocker is on</h5>
				<button type="button" class="close" data-dismiss="modal" aria-label="Close">
					<span aria-hidden="true">&times;</span>
				</button>
			</div>
			<div class="modal-body">
				<p>We noticed your adblocker is on.  We use ads to fund this site and continue to bring you premium Steelers content.</p>
				<p>If you like what you see on this site, we now have an <a href="/go-ad-free">ad-free option</a> available for a donation of $25 per year, and you can enjoy the site entirely ad-free!</p>
				<p>Additionally, if you'd like to donate above and beyond the ad-free option, you can <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=XZ97MFHPQZYX4" target="_blank">donate via PayPal</a> as well.</p>
				<p>Finally, if you wish to not see this dialog box, please turn off your adblocker, and enjoy content normally</p>
				<p>Thank you for visiting Steelers Depot!</p>
			</div>
			<div class="modal-footer">
				<a href="/go-ad-free" class="btn btn-warning" style="color:white">Go Ad-Free</a>
				<button type="button" class="btn btn-dark" data-dismiss="modal">Close</button>
			</div>
		</div>
	</div>
</div></body>
</html>