
<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />



<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://steelersdepot.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://steelersdepot.com/feed/atom/" />
<link rel="pingback" href="https://steelersdepot.com/xmlrpc.php" />

<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2020/10/chargers-saints.jpg" />
<meta name="twitter:image" content="https://steelersdepot.com/wp-content/uploads/2020/10/chargers-saints.jpg" />

<meta property="og:type" content="article" />
<meta property="og:description" content="Week 5 of the 2020 NFL regular season will come to a close Monday night with the New Orleans Saints hosting the Los Angels Chargers at the Mercedes-Benz Superdome. This game pits superstar quarterback Drew Brees against rookie quarterback Justin Herbert. The Saints enter this Monday night game with a record of 2-2 while the [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/">
<meta name="twitter:title" content="Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread">
<meta name="twitter:description" content="Week 5 of the 2020 NFL regular season will come to a close Monday night with the New Orleans Saints hosting the Los Angels Chargers at the Mercedes-Benz Superdome. This game pits superstar quarterback Drew Brees against rookie quarterback Justin Herbert. The Saints enter this Monday night game with a record of 2-2 while the [&hellip;]">



<script>
(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-1.0.40';
	w.adthrive.host = 'ads.adthrive.com';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/5e387029c4178d20fcc52aa6/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href);
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);
</script>

	<!-- This site is optimized with the Yoast SEO Premium plugin v15.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread - Steelers Depot</title>
	<meta name="description" content="Week 5 of the 2020 NFL regular season will come to a close Monday night with the New Orleans Saints hosting the Los Angels Chargers at the Mercedes-Benz" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread - Steelers Depot" />
	<meta property="og:description" content="Week 5 of the 2020 NFL regular season will come to a close Monday night with the New Orleans Saints hosting the Los Angels Chargers at the Mercedes-Benz" />
	<meta property="og:url" content="https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/" />
	<meta property="og:site_name" content="Steelers Depot" />
	<meta property="article:publisher" content="https://www.facebook.com/steelersdepot" />
	<meta property="article:published_time" content="2020-10-13T00:07:08+00:00" />
	<meta property="article:modified_time" content="2020-10-13T01:03:38+00:00" />
	<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2020/10/chargers-saints.jpg" />
	<meta property="og:image:width" content="776" />
	<meta property="og:image:height" content="436" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@Steelersdepot" />
	<meta name="twitter:site" content="@Steelersdepot" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://steelersdepot.com/#organization","name":"Steelers Depot","url":"https://steelersdepot.com/","sameAs":["https://www.facebook.com/steelersdepot","https://twitter.com/Steelersdepot"],"logo":{"@type":"ImageObject","@id":"https://steelersdepot.com/#logo","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2015/07/depot-logo.png","width":384,"height":100,"caption":"Steelers Depot"},"image":{"@id":"https://steelersdepot.com/#logo"}},{"@type":"WebSite","@id":"https://steelersdepot.com/#website","url":"https://steelersdepot.com/","name":"Steelers Depot","description":"Pittsburgh Steelers blog featuring news, discussion &amp; merchandise!","publisher":{"@id":"https://steelersdepot.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://steelersdepot.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/#primaryimage","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2020/10/chargers-saints.jpg","width":776,"height":436},{"@type":"WebPage","@id":"https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/#webpage","url":"https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/","name":"Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread - Steelers Depot","isPartOf":{"@id":"https://steelersdepot.com/#website"},"primaryImageOfPage":{"@id":"https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/#primaryimage"},"datePublished":"2020-10-13T00:07:08+00:00","dateModified":"2020-10-13T01:03:38+00:00","description":"Week 5 of the 2020 NFL regular season will come to a close Monday night with the New Orleans Saints hosting the Los Angels Chargers at the Mercedes-Benz","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/"]}]},{"@type":"Article","@id":"https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/#article","isPartOf":{"@id":"https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/#webpage"},"author":{"@id":"https://steelersdepot.com/#/schema/person/510b7205750a220b4f1f625f4cf0b47b"},"headline":"Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread","datePublished":"2020-10-13T00:07:08+00:00","dateModified":"2020-10-13T01:03:38+00:00","mainEntityOfPage":{"@id":"https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/#webpage"},"commentCount":0,"publisher":{"@id":"https://steelersdepot.com/#organization"},"image":{"@id":"https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/#primaryimage"},"keywords":"Los Angeles Chargers,New Orleans Saints,Week 5","articleSection":"Article","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/#respond"]}]},{"@type":"Person","@id":"https://steelersdepot.com/#/schema/person/510b7205750a220b4f1f625f4cf0b47b","name":"Dave Bryan","image":{"@type":"ImageObject","@id":"https://steelersdepot.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/108b00b5dd3364a8638248aea7b2da43?s=96&d=mm&r=g","caption":"Dave Bryan"}}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="https://steelersdepot.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread Comments Feed" href="https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://steelersdepot.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mvp-reset-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/reset.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-style-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/style.css?ver=5.5.1' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/css/iecss.css?ver=5.5.1' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mvp-style-entertainment-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/style-entertainment.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag/css/media-queries.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://steelersdepot.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='child-main-css'  href='https://steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/main.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/css/bootstrap.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://steelersdepot.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.9.1' type='text/css' media='all' />
<script type='text/javascript' data-cfasync="false" src='https://steelersdepot.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<link rel="https://api.w.org/" href="https://steelersdepot.com/wp-json/" /><link rel="alternate" type="application/json" href="https://steelersdepot.com/wp-json/wp/v2/posts/529351" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://steelersdepot.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://steelersdepot.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/pPyaZ-2dHV' />
<link rel="alternate" type="application/json+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2020%2F10%2Fchargers-vs-saints-week-5-monday-night-game-open-discussion-thread%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2020%2F10%2Fchargers-vs-saints-week-5-monday-night-game-open-discussion-thread%2F&#038;format=xml" />
<script type="text/javascript" data-cfasync="false">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</script><style type='text/css'>img#wpstats{display:none}</style>
<style type='text/css'>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</style>
	
<style type="text/css">


.post-cont-out,
.post-cont-in {
	margin-right: 0;
	}




.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -315px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 315px;
	}
.home-left-col {
	float: left;
	}
.home-mid-col {
	float: right;
	margin-left: 15px;
	margin-right: 0;
	}

@media screen and (max-width: 1399px) and (min-width: 1250px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1249px) and (min-width: 1100px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1099px) {
.home-wrap-out2,
.home-wrap-in2 {
	float: left;
	margin-left: 0;
	margin-right: 0;
	}
.home-mid-col {
	float: left;
	}
}
@media screen and (max-width: 479px) {
.home-mid-col {
	margin-left: 0;
	}
}





</style>

<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #eeeeee; }
</style>
	
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<script>
	     (adsbygoogle = window.adsbygoogle || []).push({
	          google_ad_client: "ca-pub-7138622909378284",
	          enable_page_level_ads: true
	     });
	</script>
	
		<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({article:'auto'});
		!function (e, f, u, i) {
			if (!document.getElementById(i)){
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}
		}(document.createElement('script'),
		document.getElementsByTagName('script')[0],
		'//cdn.taboola.com/libtrc/steelersdepot/loader.js',
		'tb_loader_script');
		if(window.performance && typeof window.performance.mark == 'function')
		{window.performance.mark('tbl_ic');}
	</script>
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-11437002-3"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-11437002-3');
</script>
</head>


<body class="post-template-default single single-post postid-529351 single-format-standard custom-background logged-out at-ads-allowed">
	<div id="site" class="left relative">
		<div id="site-wrap" class="left relative">
						<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
									<li class="fb-soc">
						<a href="https://www.facebook.com/steelersdepot/" target="_blank">
						<i class="fa fa-facebook-square fa-2"></i>
						</a>
					</li>
													<li class="twit-soc">
						<a href="https://twitter.com/Steelersdepot" target="_blank">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																	<li class="inst-soc">
						<a href="https://www.instagram.com/steelersdepot/" target="_blank">
						<i class="fa fa-instagram fa-2"></i>
						</a>
					</li>
																	<li class="yt-soc">
						<a href="https://www.youtube.com/channel/UCFqbkq2BzNY3iQ_FPveqVhw" target="_blank">
						<i class="fa fa-youtube-play fa-2"></i>
						</a>
					</li>
																	<li class="tum-soc">
						<a href="https://steelersdepot.tumblr.com/" target="_blank">
						<i class="fa fa-tumblr fa-2"></i>
						</a>
					</li>
													<li class="rss-soc">
						<a href="https://steelersdepot.com/feed/rss/" target="_blank">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li id="menu-item-520576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/">2020 NFL Scouting Combine Results Tracker</a></li>
	<li id="menu-item-520575" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li id="menu-item-520730" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li id="menu-item-515035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-515038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/">Contact Us</a></li>
<li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li id="menu-item-496474" class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li id="menu-item-493254" class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li id="menu-item-493255" class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->			<div id="head-main-wrap" class="left relative">
				<div id="head-main-top" class="left relative">
																														</div><!--head-main-top-->
				<div id="main-nav-wrap">
					<div class="nav-out">
						<div class="nav-in">
							<div id="main-nav-cont" class="left" itemscope itemtype="http://schema.org/Organization">
								<div class="nav-logo-out">
									<div class="nav-left-wrap left relative">
										<div class="fly-but-wrap left relative">
											<span></span>
											<span></span>
											<span></span>
											<span></span>
										</div><!--fly-but-wrap-->
																					<div class="nav-logo left">
																									<a itemprop="url" href="https://steelersdepot.com/"><img itemprop="logo" src="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png" alt="Steelers Depot" data-rjs="2" /></a>
																																					<h2 class="mvp-logo-title">Steelers Depot</h2>
																							</div><!--nav-logo-->
																			</div><!--nav-left-wrap-->
									<div class="nav-logo-in">
										<div class="nav-menu-out">
											<div class="nav-menu-in">
												<nav class="main-menu-wrap left">
													<div class="menu-header-container"><ul id="menu-header-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/">2020 NFL Scouting Combine Results Tracker</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>												</nav>
											</div><!--nav-menu-in-->
											<div class="nav-right-wrap relative">
												<div class="nav-search-wrap left relative">
													<span class="nav-search-but left"><i class="fa fa-search fa-2"></i></span>
													<div class="search-fly-wrap">
														<form method="get" id="searchform" action="https://steelersdepot.com/">
	<input type="text" name="s" id="s" value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>													</div><!--search-fly-wrap-->
												</div><!--nav-search-wrap-->
																									<a href="https://www.facebook.com/steelersdepot/" target="_blank">
													<span class="nav-soc-but"><i class="fa fa-facebook fa-2"></i></span>
													</a>
																																					<a href="https://twitter.com/Steelersdepot" target="_blank">
													<span class="nav-soc-but"><i class="fa fa-twitter fa-2"></i></span>
													</a>
																							</div><!--nav-right-wrap-->
										</div><!--nav-menu-out-->
									</div><!--nav-logo-in-->
								</div><!--nav-logo-out-->
							</div><!--main-nav-cont-->
						</div><!--nav-in-->
					</div><!--nav-out-->
				</div><!--main-nav-wrap-->
			</div><!--head-main-wrap-->
										<div id="body-main-wrap" class="left relative" itemscope itemtype="http://schema.org/NewsArticle">
					<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/"/>
																																			<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="body-main-cont" class="left relative">
																		<!-- <div style="margin-bottom:40px">
	<h5>Send Alex to Training Camp</h5>
	<iframe class='gfm-media-widget' image='0' coinfo='0' width='100%' height='100%' frameborder='0' id='steelers-depot-2018-training-camp'></iframe>
	<script src='//funds.gofundme.com/js/5.0/media-widget.js'></script>
	<style>
	.gfm-widget {
		width: 100%;
		max-width: initial;
	}
	</style>
	<script>
	jQuery(function($){
	});
	</script>
</div> --><div id="post-main-wrap" class="left relative">
	<div class="post-wrap-out1">
		<div class="post-wrap-in1">
			<div id="post-left-col" class="relative">
	<article id="post-area" class="post-529351 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-los-angeles-chargers tag-new-orleans-saints tag-week-5">
			<header id="post-header">
							<a class="post-cat-link" href="https://steelersdepot.com/category/article/"><span class="post-head-cat">Article</span></a>
						<h1 class="post-title entry-title left" itemprop="headline">Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread</h1>
							<div id="post-info-wrap" class="left relative">
					<div class="post-info-out">
						<div class="post-info-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/108b00b5dd3364a8638248aea7b2da43?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/108b00b5dd3364a8638248aea7b2da43?s=100&#038;d=mm&#038;r=g 2x' class='avatar arm_grid_avatar arm-avatar avatar-50 photo' height='50' width='50' loading='lazy'/>						</div><!--post-info-img-->
						<div class="post-info-in">
							<div class="post-info-right left relative">
								<div class="post-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
									<span class="post-info-text">By</span> <span class="author-name vcard fn author" itemprop="name"><a href="https://steelersdepot.com/author/davebryan/" title="Posts by Dave Bryan" rel="author">Dave Bryan</a></span> 																	</div><!--post-info-name-->
								<div class="post-info-date left relative">
									<span class="post-info-text">Posted on</span> <span class="post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-10-12">October 12, 2020 at 8:07 pm</time></span>
									<meta itemprop="dateModified" content="2020-10-12"/>
								</div><!--post-info-date-->
							</div><!--post-info-right-->
						</div><!--post-info-in-->
					</div><!--post-info-out-->
				</div><!--post-info-wrap-->
					</header><!--post-header-->
	

			<section class="social-sharing-top">
			<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/&amp;t=Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open('http://twitter.com/share?text=Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread -&amp;url=https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
			<a href="whatsapp://send?text=Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/&amp;media=https://steelersdepot.com/wp-content/uploads/2020/10/chargers-saints.jpg&amp;description=Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="/cdn-cgi/l/email-protection#c5fab6b0a7afa0a6b1f886ada4b7a2a0b7b6e593b6ebe596a4acabb1b6e592a0a0aee5f0e588aaaba1a4bce58baca2adb1e582a4a8a0e58ab5a0abe581acb6a6b0b6b6acaaabe591adb7a0a4a1e3a4a8b5fe878a819cf88ce5a3aab0aba1e5b1adacb6e5a4b7b1aca6a9a0e5acabb1a0b7a0b6b1acaba2e5a4aba1e5b1adaab0a2adb1e5aaa3e5b6ada4b7acaba2e5acb1e5b2acb1ade5bcaab0ebe586ada0a6aee5acb1e5aab0b1ffe5adb1b1b5b6ffeaeab6b1a0a0a9a0b7b6a1a0b5aab1eba6aaa8eaf7f5f7f5eaf4f5eaa6ada4b7a2a0b7b6e8b3b6e8b6a4acabb1b6e8b2a0a0aee8f0e8a8aaaba1a4bce8abaca2adb1e8a2a4a8a0e8aab5a0abe8a1acb6a6b0b6b6acaaabe8b1adb7a0a4a1ea"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
																	<a href="#disqus_thread"><div class="social-comments comment-click-529351"><i class="fa fa-commenting fa-2"></i></div></a>
									</section><!--social-sharing-top-->
	


																					<div class="left" id="post-feat-img-wrapper">
							<div id="post-feat-img" class="relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
								<img width="776" height="436" src="https://steelersdepot.com/wp-content/uploads/2020/10/chargers-saints.jpg" class="attachment- size- wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2020/10/chargers-saints.jpg 776w, https://steelersdepot.com/wp-content/uploads/2020/10/chargers-saints-300x169.jpg 300w, https://steelersdepot.com/wp-content/uploads/2020/10/chargers-saints-768x432.jpg 768w" sizes="(max-width: 776px) 100vw, 776px" />																<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2020/10/chargers-saints.jpg">
								<meta itemprop="width" content="776">
								<meta itemprop="height" content="436">
								<div class="post-feat-text">
																										</div><!--post-feat-text-->
							</div><!--post-feat-img-->
						</div>
																<div id="content-area" itemprop="articleBody" class="post-529351 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-los-angeles-chargers tag-new-orleans-saints tag-week-5">
		<div class="post-cont-out">
			<div class="post-cont-in">
				<div id="content-main" class="left relative">

						
	
		<div class="post-specific-content">
<p>Week 5 of the 2020 NFL regular season will come to a close Monday night with the <strong>New Orleans Saints</strong> hosting the <strong>Los Angels Chargers</strong> at the Mercedes-Benz Superdome.</p>
<p>This game pits superstar quarterback Drew Brees against rookie quarterback Justin Herbert. The Saints enter this Monday night game with a record of 2-2 while the Chargers are 1-3.</p>
<p>As usual, I invite all of yinz to chat about this game in the comment section below this post. I will try to add a few video highlights from the game throughout the night to this post as well.</p>
<p>Have a great Monday night and thank you for stopping by the site.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="de" dir="ltr">Herbert to Allen <a href="https://twitter.com/hashtag/LACvsNO?src=hash&amp;ref_src=twsrc%5Etfw">#LACvsNO</a> <a href="https://twitter.com/hashtag/Chargers?src=hash&amp;ref_src=twsrc%5Etfw">#Chargers</a> <a href="https://t.co/nrvE1ikhQO">pic.twitter.com/nrvE1ikhQO</a></p>
<p>&mdash; Steelers Depot 🏆👑 (@Steelersdepot) <a href="https://twitter.com/Steelersdepot/status/1315813199254495233?ref_src=twsrc%5Etfw">October 13, 2020</a></p></blockquote>
<p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Cam Jordan have mercy 😳 <a href="https://twitter.com/camjordan94?ref_src=twsrc%5Etfw">@camjordan94</a> <a href="https://twitter.com/Saints?ref_src=twsrc%5Etfw">@Saints</a> <a href="https://t.co/77clupWQg5">pic.twitter.com/77clupWQg5</a></p>
<p>&mdash; The Checkdown (@thecheckdown) <a href="https://twitter.com/thecheckdown/status/1315819211411714048?ref_src=twsrc%5Etfw">October 13, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Looks like the Saints got beat on the play the Giants had for a TD against the <a href="https://twitter.com/hashtag/Steelers?src=hash&amp;ref_src=twsrc%5Etfw">#Steelers</a> in Week 1 <a href="https://t.co/brOOse0vEQ">pic.twitter.com/brOOse0vEQ</a></p>
<p>&mdash; Steelers Depot 🏆👑 (@Steelersdepot) <a href="https://twitter.com/Steelersdepot/status/1315820302241132545?ref_src=twsrc%5Etfw">October 13, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Mike Williams is back and making TD grabs! <a href="https://twitter.com/hashtag/BoltUp?src=hash&amp;ref_src=twsrc%5Etfw">#BoltUp</a></p>
<p>📺: <a href="https://twitter.com/hashtag/LACvsNO?src=hash&amp;ref_src=twsrc%5Etfw">#LACvsNO</a> on ESPN<br />📱: NFL app // Yahoo Sports app: <a href="https://t.co/DQbEOUQ3Cv">https://t.co/DQbEOUQ3Cv</a> <a href="https://t.co/9VxCSAr8SR">pic.twitter.com/9VxCSAr8SR</a></p>
<p>&mdash; NFL (@NFL) <a href="https://twitter.com/NFL/status/1315820207487639552?ref_src=twsrc%5Etfw">October 13, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Chargers Inactives:</strong></p>
<p>QB Tyrod Taylor<br />
OL Bryan Bulaga<br />
OL Trai Turner<br />
WR Jason Moore Jr.<br />
WR Joe Reed<br />
S Jahleel Addae<br />
DE Joe Gaziano</p>
<p><strong>Saints Inactives:</strong></p>
<p>CB Janoris Jenkins<br />
CB Justin Hardee<br />
WR Deonte Harris<br />
WR Michael Thomas<br />
OL Ethan Greenidge<br />
TE Adam Trautman<br />
DL Malcolm Roach</p>
</div>

	<div id="taboola-below-article">
	</div>

															<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
						<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
															<img src="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png"/>
								<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-depot-logo1.png">
													</div><!--mvp-org-logo-->
						<meta itemprop="name" content="Steelers Depot">
					</div><!--mvp-org-wrap-->
					<div class="posts-nav-link">
											</div><!--posts-nav-link-->
											<div class="post-tags">
							<span class="post-tags-header">Related Items:</span><span itemprop="keywords"><a href="https://steelersdepot.com/tag/los-angeles-chargers/" rel="tag">Los Angeles Chargers</a>, <a href="https://steelersdepot.com/tag/new-orleans-saints/" rel="tag">New Orleans Saints</a>, <a href="https://steelersdepot.com/tag/week-5/" rel="tag">Week 5</a></span>
						</div><!--post-tags-->
																<div class="social-sharing-bot">
							<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/&amp;t=Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span> <span style="color: #fff; font-family: 'Montserrat', sans-serif; font-size: 10px; font-weight: 400; line-height: 100%; padding: 8px 0; text-transform: uppercase;"></span></div></a>
							<a href="#" onclick="window.open('http://twitter.com/share?text=Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread -&amp;url=https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
							<a href="whatsapp://send?text=Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/&amp;media=https://steelersdepot.com/wp-content/uploads/2020/10/chargers-saints.jpg&amp;description=Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="/cdn-cgi/l/email-protection#cdf2beb8afa7a8aeb9f08ea5acbfaaa8bfbeed9bbee3ed9eaca4a3b9beed9aa8a8a6edf8ed80a2a3a9acb4ed83a4aaa5b9ed8aaca0a8ed82bda8a3ed89a4beaeb8bebea4a2a3ed99a5bfa8aca9ebaca0bdf68f828994f084edaba2b8a3a9edb9a5a4beedacbfb9a4aea1a8eda4a3b9a8bfa8beb9a4a3aaedaca3a9edb9a5a2b8aaa5b9eda2abedbea5acbfa4a3aaeda4b9edbaa4b9a5edb4a2b8e3ed8ea5a8aea6eda4b9eda2b8b9f7eda5b9b9bdbef7e2e2beb9a8a8a1a8bfbea9a8bda2b9e3aea2a0e2fffdfffde2fcfde2aea5acbfaaa8bfbee0bbbee0beaca4a3b9bee0baa8a8a6e0f8e0a0a2a3a9acb4e0a3a4aaa5b9e0aaaca0a8e0a2bda8a3e0a9a4beaeb8bebea4a2a3e0b9a5bfa8aca9e2"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
						</div><!--social-sharing-bot-->
																            <div class="mvp-related-posts left relative">
		<h4 class="post-header"><span class="post-header">Recommended for you</span></h4>
			<ul>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2020/10/roethlisberger-gets-credit-from-eagles-hc-pederson-for-audible-on-steelers-late-td-pass/" rel="bookmark" title="Roethlisberger Gets Credit From Eagles HC Pederson For Audible On Steelers Late TD Pass">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2020/10/roethlisberger-eagles-td-huddle-audible-300x180.jpg" class="reg-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2020/10/roethlisberger-eagles-td-huddle-audible-300x180.jpg 300w, https://steelersdepot.com/wp-content/uploads/2020/10/roethlisberger-eagles-td-huddle-audible-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2020/10/roethlisberger-eagles-td-huddle-audible-80x80.jpg" class="mob-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2020/10/roethlisberger-eagles-td-huddle-audible-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2020/10/roethlisberger-eagles-td-huddle-audible-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2020/10/roethlisberger-gets-credit-from-eagles-hc-pederson-for-audible-on-steelers-late-td-pass/">Roethlisberger Gets Credit From Eagles HC Pederson For Audible On Steelers Late TD Pass</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2020/10/the-terrible-podcast-talking-steelers-eagles-recap-inactives-injury-report-motion-report-listener-emails-more/" rel="bookmark" title="The Terrible Podcast – Talking Steelers Eagles Recap, Inactives, Injury Report, Motion Report, Listener Emails &#038; More">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2018/11/large-terrible-300x180.jpg" class="reg-img wp-post-image" alt="Terrible Podcast Logo" loading="lazy" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2018/11/large-terrible-80x80.jpg" class="mob-img wp-post-image" alt="Terrible Podcast Logo" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2018/11/large-terrible-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2018/11/large-terrible-150x150.jpg 150w, https://steelersdepot.com/wp-content/uploads/2018/11/large-terrible-300x300.jpg 300w, https://steelersdepot.com/wp-content/uploads/2018/11/large-terrible.jpg 320w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2020/10/the-terrible-podcast-talking-steelers-eagles-recap-inactives-injury-report-motion-report-listener-emails-more/">The Terrible Podcast – Talking Steelers Eagles Recap, Inactives, Injury Report, Motion Report, Listener Emails &#038; More</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2020/10/steelers-vs-eagles-player-snap-counts-and-analysis-week-5/" rel="bookmark" title="Steelers Vs. Eagles: Player Snap Counts And Analysis – Week 5">
						<img width="300" height="180" src="https://steelersdepot.com/wp-content/uploads/2020/10/steelers-versus-eagles-week-5-2020-300x180.jpg" class="reg-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2020/10/steelers-versus-eagles-week-5-2020-300x180.jpg 300w, https://steelersdepot.com/wp-content/uploads/2020/10/steelers-versus-eagles-week-5-2020-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://steelersdepot.com/wp-content/uploads/2020/10/steelers-versus-eagles-week-5-2020-80x80.jpg" class="mob-img wp-post-image" alt="" loading="lazy" srcset="https://steelersdepot.com/wp-content/uploads/2020/10/steelers-versus-eagles-week-5-2020-80x80.jpg 80w, https://steelersdepot.com/wp-content/uploads/2020/10/steelers-versus-eagles-week-5-2020-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2020/10/steelers-vs-eagles-player-snap-counts-and-analysis-week-5/">Steelers Vs. Eagles: Player Snap Counts And Analysis – Week 5</a>
				</div><!--related-text-->
            			</li>
            		</ul></div>																					<div id="disqus_thread"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
    /**
     *  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT 
     *  THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR 
     *  PLATFORM OR CMS.
     *  
     *  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: 
     *  https://disqus.com/admin/universalcode/#configuration-variables
     */
    /*
    var disqus_config = function () {
        // Replace PAGE_URL with your page's canonical URL variable
        this.page.url = PAGE_URL;  
        
        // Replace PAGE_IDENTIFIER with your page's unique identifier variable
        this.page.identifier = PAGE_IDENTIFIER; 
    };
    */


	// DISQUS.reset({
	// 	reload: true,
	// 	config: function () {  
	// 		this.page.identifier = 'steelersdepot';
	// 		this.page.url = 'https://steelersdepot.com/2020/10/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread/';
	// 	}
	// });
 //    var changeThread = function(){
 //    };


    var disqus_loaded = false;
    
	if (typeof(disqus_loaded)=="undefined" || !disqus_loaded) {
		disqus_loaded=1;
		jQuery.ajax({
			type: 'GET',
			url: 'https://steelersdepot.disqus.com/embed.js',
			dataType: 'script',
			cache: true
		});
	} 

    // (function() {
    //     var d = document, s = d.createElement('script');
        
    //     s.src = 'https://steelersdepot.disqus.com/embed.js';
    //     // s.src = '/wp-content/themes/flex-mag-child/assets/js/disqus-post.js';
        
    //     s.setAttribute('data-timestamp', +new Date());
    //     (d.head || d.body).appendChild(s);
    // })();
</script>
<noscript>
    Please enable JavaScript to view the 
    <a href="https://disqus.com/?ref_noscript" rel="nofollow">
        comments powered by Disqus.
    </a>
</noscript>									</div><!--content-main-->
			</div><!--post-cont-in-->
					</div><!--post-cont-out-->
	</div><!--content-area-->
</article>
				</div><!--post-left-col-->
			</div><!--post-wrap-in1-->
			
							<div id="post-right-col" class="relative">
																		<div id="sidebar-wrap" class="left relative theiaStickySidebar">
	<div id="custom_html-29" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a target="_blank" href="https://fanatics.ncw6.net/c/2325230/618771/9663" rel="noopener noreferrer"><img src="https://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></div><!--sidebar-wrap-->															</div><!--post-right-col-->
					</div><!--post-wrap-out1-->
</div><!--post-main-wrap-->
											</div><!--body-main-cont-->
				</div><!--body-main-in-->
			</div><!--body-main-out-->
		</div><!--body-main-wrap-->
		<footer id="foot-wrap" class="left relative">
			<div id="foot-top-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-widget-wrap" class="left relative">
															<div class="foot-widget left relative">
																			<div class="foot-logo left realtive">
											<img src="https://steelersdepot.com/wp-content/themes/flex-mag/images/logos/logo-foot.png" alt="Steelers Depot" data-rjs="2" />
										</div><!--foot-logo-->
																		<div class="foot-info-text left relative">
										<p>Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem?</p><p>Temporibus autem quibusdam et aut officiis debitis aut rerum necessitatibus saepe eveniet.</p>									</div><!--footer-info-text-->
									<div class="foot-soc left relative">
										<ul class="foot-soc-list relative">
																							<li class="foot-soc-fb">
													<a href="https://www.facebook.com/steelersdepot/" target="_blank"><i class="fa fa-facebook-square fa-2"></i></a>
												</li>
																																		<li class="foot-soc-twit">
													<a href="https://twitter.com/Steelersdepot" target="_blank"><i class="fa fa-twitter-square fa-2"></i></a>
												</li>
																																													<li class="foot-soc-inst">
													<a href="https://www.instagram.com/steelersdepot/" target="_blank"><i class="fa fa-instagram fa-2"></i></a>
												</li>
																																													<li class="foot-soc-yt">
													<a href="https://www.youtube.com/channel/UCFqbkq2BzNY3iQ_FPveqVhw" target="_blank"><i class="fa fa-youtube-play fa-2"></i></a>
												</li>
																																													<li class="foot-soc-tumb">
													<a href="https://steelersdepot.tumblr.com/" target="_blank"><i class="fa fa-tumblr-square fa-2"></i></a>
												</li>
																																		<li class="foot-soc-rss">
													<a href="https://steelersdepot.com/feed/rss/" target="_blank"><i class="fa fa-rss-square fa-2"></i></a>
												</li>
																					</ul>
									</div><!--foot-soc-->
								</div><!--foot-widget-->
																				</div><!--foot-widget-wrap-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-top-->
			<div id="foot-bot-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-bot" class="left relative">
							<div class="foot-menu relative">
								<div class="menu-header-container"><ul id="menu-header-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/">2020 NFL Scouting Combine Results Tracker</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>							</div><!--foot-menu-->
							<div class="foot-copy relative">
								<p>&copy; 2020 Steelers Depot</p>
							</div><!--foot-copy-->
						</div><!--foot-bot-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-bot-->
		</footer>
	</div><!--site-wrap-->
</div><!--site-->
<div class="fly-to-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
	<span class="to-top-text">To Top</span>
</div><!--fly-to-top-->
<div class="fly-fade">
</div><!--fly-fade-->
			<script data-cfasync="false" type="text/javascript">
			function arm_open_modal_box_in_nav_menu(menu_id, form_id) {
                           
				jQuery(".arm_nav_menu_link_" + form_id).find("." + form_id).trigger("click");
				return false;
			}
			</script>
					<div data-theiaStickySidebar-sidebarSelector='"#tab-col2"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":0,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#tab-col3"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#post-right-col"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		
<script>
	if (!window.adthrive.config) {
		window.adblock_exp_val = 'off';
		if (Math.floor(Math.random() * 100) < 95) {
			window.adblock_exp_val = 'onpage';
			(function(a,d){function g(b){try{return d.createElement(b);}catch(k){}return d.createElementNS('http://www.w3.org/1999/xhtml',b);}try{var e='\x24\x63\x6D\x64',h='\x72\x65\x61\x64\x79',f='\x24\x65\x76\x72',c=a['\x70\x41\x50\x49']=function(b,a){c[e].push([b,a]);};c[e]=[];c[f]=[];c[h]=function(a){c[f].push(a);};}catch(b){}'\x50\x72\x6F\x78\x79'in a&&(0,a=g('script'),a.src='//kppcfedi.yyjvimo.com/f3ff4bcab40a7747d7aa3f28cc67d82d',(d.head||d.body).appendChild(a));}(window,document))		}
	}
</script>

<script type="text/javascript">
jQuery(document).ready(function($) {

	// Back to Top Button
    	var duration = 500;
    	$('.back-to-top').click(function(event) {
          event.preventDefault();
          $('html, body').animate({scrollTop: 0}, duration);
          return false;
	});

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

	  	$(".comment-click-529351").on("click", function(){
  	  $(".com-click-id-529351").show();
	  $(".disqus-thread-529351").show();
  	  $(".com-but-529351").hide();
  	});
	

$(window).load(function() {
  // The slider being synced must be initialized first
  $('.post-gallery-bot').flexslider({
    animation: "slide",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    itemWidth: 80,
    itemMargin: 10,
    asNavFor: '.post-gallery-top'
  });

  $('.post-gallery-top').flexslider({
    animation: "fade",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    	  prevText: "&lt;",
          nextText: "&gt;",
    sync: ".post-gallery-bot"
  });
});

});

</script>

<script type='text/javascript' data-cfasync="false" src='https://steelersdepot.com/wp-includes/js/comment-reply.min.js?ver=5.5.1' id='comment-reply-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"steelersdepot"};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"529351 https:\/\/steelersdepot.com\/?p=529351","disqusShortname":"steelersdepot","disqusTitle":"Chargers Vs. Saints Week 5 Monday Night Game Open Discussion Thread","disqusUrl":"https:\/\/steelersdepot.com\/2020\/10\/chargers-vs-saints-week-5-monday-night-game-open-discussion-thread\/","postId":"529351"};
/* ]]> */
</script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.6.3' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.6.3' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag/js/scripts.js?ver=5.5.1' id='mvp-flexmag-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag/js/autoloadpost.js?ver=5.5.1' id='mvp-autoloadpost-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag/js/retina.js?ver=5.5.1' id='retina-js'></script>
<script type='text/javascript' src='https://steelersdepot.com/wp-content/themes/flex-mag-child/assets/js/main.min.js?ver=5.5.1' id='main-js'></script>
<script type='text/javascript' data-cfasync="false" src='https://steelersdepot.com/wp-includes/js/wp-embed.min.js?ver=5.5.1' id='wp-embed-js'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script type='text/javascript' src='https://stats.wp.com/e-202042.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9.1',blog:'12286105',post:'529351',tz:'-4',srv:'steelersdepot.com'} ]);
	_stq.push([ 'clickTrackerInit', '12286105', '529351' ]);
</script>

	<style>
.modal {
	margin-top:200px;
}
.modal-backdrop {
	background: rgba(0,0,0,0.6);
}
.modal-body a {
	text-decoration: underline;
}
</style>
<div class="modal" id="ad-free-modal" tabindex="-1" role="dialog">
	<div class="modal-dialog" role="document">
		<div class="modal-content">
			<div class="modal-header">
				<h5 class="modal-title">Adblocker is on</h5>
				<button type="button" class="close" data-dismiss="modal" aria-label="Close">
					<span aria-hidden="true">&times;</span>
				</button>
			</div>
			<div class="modal-body">
				<p>We noticed your adblocker is on.  We use ads to fund this site and continue to bring you premium Steelers content.</p>
				<p>If you like what you see on this site, we now have an <a href="/go-ad-free">ad-free option</a> available for a donation of $25 per year, and you can enjoy the site entirely ad-free!</p>
				<p>Additionally, if you'd like to donate above and beyond the ad-free option, you can <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=XZ97MFHPQZYX4" target="_blank">donate via PayPal</a> as well.</p>
				<p>Finally, if you wish to not see this dialog box, please turn off your adblocker, and enjoy content normally</p>
				<p>Thank you for visiting Steelers Depot!</p>
			</div>
			<div class="modal-footer">
				<a href="/go-ad-free" class="btn btn-warning" style="color:white">Go Ad-Free</a>
				<button type="button" class="btn btn-dark" data-dismiss="modal">Close</button>
			</div>
		</div>
	</div>
</div></body>
</html>