
<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />



<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://steelersdepot.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://steelersdepot.com/feed/atom/" />
<link rel="pingback" href="https://steelersdepot.com/xmlrpc.php" />

<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu.jpg" />
<meta name="twitter:image" content="https://steelersdepot.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu.jpg" />

<meta property="og:type" content="article" />
<meta property="og:description" content="The Pittsburgh Steelers enter the 2020 season having not been to the playoffs since 2017, and having not won a playoff game since 2016. They went 8-8 last season. And yet there is a good deal of optimism behind the former perennial contenders in their bid to return to that status—not without reason. While so [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/">
<meta name="twitter:title" content="Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020">
<meta name="twitter:description" content="The Pittsburgh Steelers enter the 2020 season having not been to the playoffs since 2017, and having not won a playoff game since 2016. They went 8-8 last season. And yet there is a good deal of optimism behind the former perennial contenders in their bid to return to that status—not without reason. While so [&hellip;]">


<title>Solomon Wilcots: Steelers&#039; Defense Makes Them A Contender In 2020 - Steelers Depot</title>
<script>
window.adthrive = window.adthrive || {};
window.adthrive.cmd = window.adthrive.cmd || [];
window.adthrive.host = 'ads.adthrive.com';
window.adthrive.plugin = 'adthrive-ads-1.0.37';
window.adthrive.threshold = Math.floor(Math.random() * 100 + 1);

(function() {
	var script = document.createElement('script');
	script.async = true;
	script.type = 'text/javascript';
	script.src = 'https://ads.adthrive.com/sites/5e387029c4178d20fcc52aa6/ads.min.js?threshold=' + window.adthrive.threshold;
	var node = document.getElementsByTagName('script')[0];
	node.parentNode.insertBefore(script, node);
})();
</script>

<!-- This site is optimized with the Yoast SEO Premium plugin v13.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="The Pittsburgh Steelers enter the 2020 season having not been to the playoffs since 2017, and having not won a playoff game since 2016. They went 8-8 last"/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Solomon Wilcots: Steelers&#039; Defense Makes Them A Contender In 2020 - Steelers Depot" />
<meta property="og:description" content="The Pittsburgh Steelers enter the 2020 season having not been to the playoffs since 2017, and having not won a playoff game since 2016. They went 8-8 last" />
<meta property="og:url" content="https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/" />
<meta property="og:site_name" content="Steelers Depot" />
<meta property="article:publisher" content="https://www.facebook.com/steelersdepot" />
<meta property="article:tag" content="Steelers" />
<meta property="article:section" content="Article" />
<meta property="article:published_time" content="2020-04-09T10:20:39+00:00" />
<meta property="article:modified_time" content="2020-04-09T09:39:35+00:00" />
<meta property="og:updated_time" content="2020-04-09T09:39:35+00:00" />
<meta property="og:image" content="https://steelersdepot.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu.jpg" />
<meta property="og:image:secure_url" content="https://steelersdepot.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu.jpg" />
<meta property="og:image:width" content="777" />
<meta property="og:image:height" content="437" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The Pittsburgh Steelers enter the 2020 season having not been to the playoffs since 2017, and having not won a playoff game since 2016. They went 8-8 last" />
<meta name="twitter:title" content="Solomon Wilcots: Steelers&#039; Defense Makes Them A Contender In 2020 - Steelers Depot" />
<meta name="twitter:site" content="@Steelersdepot" />
<meta name="twitter:image" content="https://steelersdepot.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu.jpg" />
<meta name="twitter:creator" content="@mmarczi" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://steelersdepot.com/#organization","name":"Steelers Depot","url":"https://steelersdepot.com/","sameAs":["https://www.facebook.com/steelersdepot","https://twitter.com/Steelersdepot"],"logo":{"@type":"ImageObject","@id":"https://steelersdepot.com/#logo","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2015/07/depot-logo.png","width":384,"height":100,"caption":"Steelers Depot"},"image":{"@id":"https://steelersdepot.com/#logo"}},{"@type":"WebSite","@id":"https://steelersdepot.com/#website","url":"https://steelersdepot.com/","name":"Steelers Depot","inLanguage":"en-US","description":"Pittsburgh Steelers blog featuring news, discussion &amp; merchandise!","publisher":{"@id":"https://steelersdepot.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://steelersdepot.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/#primaryimage","inLanguage":"en-US","url":"https://steelersdepot.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu.jpg","width":"777","height":"437"},{"@type":"WebPage","@id":"https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/#webpage","url":"https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/","name":"Solomon Wilcots: Steelers&#039; Defense Makes Them A Contender In 2020 - Steelers Depot","isPartOf":{"@id":"https://steelersdepot.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/#primaryimage"},"datePublished":"2020-04-09T10:20:39+00:00","dateModified":"2020-04-09T09:39:35+00:00","description":"The Pittsburgh Steelers enter the 2020 season having not been to the playoffs since 2017, and having not won a playoff game since 2016. They went 8-8 last","potentialAction":[{"@type":"ReadAction","target":["https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/"]}]},{"@type":"Article","@id":"https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/#article","isPartOf":{"@id":"https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/#webpage"},"author":{"@id":"https://steelersdepot.com/#/schema/person/1246034710ae30de8500effe3c401793"},"headline":"Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020","datePublished":"2020-04-09T10:20:39+00:00","dateModified":"2020-04-09T09:39:35+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/#webpage"},"publisher":{"@id":"https://steelersdepot.com/#organization"},"image":{"@id":"https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/#primaryimage"},"keywords":"Steelers","articleSection":"Article","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/#respond"]}]},{"@type":["Person"],"@id":"https://steelersdepot.com/#/schema/person/1246034710ae30de8500effe3c401793","name":"Matthew Marczi","image":{"@type":"ImageObject","@id":"https://steelersdepot.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/7fa7ee85674b58205a210a9bb2891f7d?s=96&d=mm&r=g","caption":"Matthew Marczi"},"description":"Passionate Steelers fan with a bit of writing ability. Connoisseur of loud music. Follow me on Twitter @mmarczi.","sameAs":["https://twitter.com/mmarczi"]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="https://steelersdepot.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="https://steelersdepot.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020 Comments Feed" href="https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mvp-reset-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/css/reset.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-style-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/style.css?ver=5.3.2' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/css/iecss.css?ver=5.3.2' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mvp-style-entertainment-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/css/style-entertainment.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/css/media-queries.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='child-main-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/assets/css/_main.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/css/bootstrap.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://steelersdepot.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://steelersdepot.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://steelersdepot.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/pPyaZ-2bQx' />
<link rel="alternate" type="application/json+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2020%2F04%2Fsolomon-wilcots-steelers-defense-makes-them-a-contender-in-2020%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsteelersdepot.com%2F2020%2F04%2Fsolomon-wilcots-steelers-defense-makes-them-a-contender-in-2020%2F&#038;format=xml" />
<script type="text/javascript" data-cfasync="false">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</script><style type='text/css'>img#wpstats{display:none}</style>
<style type='text/css'>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</style>
	
<style type="text/css">


.post-cont-out,
.post-cont-in {
	margin-right: 0;
	}




.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -315px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 315px;
	}
.home-left-col {
	float: left;
	}
.home-mid-col {
	float: right;
	margin-left: 15px;
	margin-right: 0;
	}

@media screen and (max-width: 1399px) and (min-width: 1250px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1249px) and (min-width: 1100px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1099px) {
.home-wrap-out2,
.home-wrap-in2 {
	float: left;
	margin-left: 0;
	margin-right: 0;
	}
.home-mid-col {
	float: left;
	}
}
@media screen and (max-width: 479px) {
.home-mid-col {
	margin-left: 0;
	}
}





</style>

<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #eeeeee; }
</style>
	

</head>


<body class="post-template-default single single-post postid-522197 single-format-standard custom-background logged-out at-ads-allowed">
		
	<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','/wp-content/themes/flex-mag-child/assets/js/google-analytics.js','ga');

	ga('create', 'UA-11437002-3', 'auto');
	ga('send', 'pageview');
	</script>
	<div id="site" class="left relative">
		<div id="site-wrap" class="left relative">
						<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
									<li class="fb-soc">
						<a href="https://www.facebook.com/steelersdepot/" target="_blank">
						<i class="fa fa-facebook-square fa-2"></i>
						</a>
					</li>
													<li class="twit-soc">
						<a href="https://twitter.com/Steelersdepot" target="_blank">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																																					<li class="rss-soc">
						<a href="https://steelersdepot.com/feed/rss/" target="_blank">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li id="menu-item-520576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/">2020 NFL Scouting Combine Results Tracker</a></li>
	<li id="menu-item-520575" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li id="menu-item-520730" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li id="menu-item-515035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-515038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/">Contact Us</a></li>
<li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li id="menu-item-496474" class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li id="menu-item-493254" class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li id="menu-item-493255" class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->			<div id="head-main-wrap" class="left relative">
				<div id="head-main-top" class="left relative">
																														</div><!--head-main-top-->
				<div id="main-nav-wrap">
					<div class="nav-out">
						<div class="nav-in">
							<div id="main-nav-cont" class="left" itemscope itemtype="http://schema.org/Organization">
								<div class="nav-logo-out">
									<div class="nav-left-wrap left relative">
										<div class="fly-but-wrap left relative">
											<span></span>
											<span></span>
											<span></span>
											<span></span>
										</div><!--fly-but-wrap-->
																					<div class="nav-logo left">
																									<a itemprop="url" href="https://steelersdepot.com/"><img itemprop="logo" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png" alt="Steelers Depot" data-rjs="2" /></a>
																																					<h2 class="mvp-logo-title">Steelers Depot</h2>
																							</div><!--nav-logo-->
																			</div><!--nav-left-wrap-->
									<div class="nav-logo-in">
										<div class="nav-menu-out">
											<div class="nav-menu-in">
												<nav class="main-menu-wrap left">
													<div class="menu-header-container"><ul id="menu-header-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/">2020 NFL Scouting Combine Results Tracker</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>												</nav>
											</div><!--nav-menu-in-->
											<div class="nav-right-wrap relative">
												<div class="nav-search-wrap left relative">
													<span class="nav-search-but left"><i class="fa fa-search fa-2"></i></span>
													<div class="search-fly-wrap">
														<form method="get" id="searchform" action="https://steelersdepot.com/">
	<input type="text" name="s" id="s" value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>													</div><!--search-fly-wrap-->
												</div><!--nav-search-wrap-->
																									<a href="https://www.facebook.com/steelersdepot/" target="_blank">
													<span class="nav-soc-but"><i class="fa fa-facebook fa-2"></i></span>
													</a>
																																					<a href="https://twitter.com/Steelersdepot" target="_blank">
													<span class="nav-soc-but"><i class="fa fa-twitter fa-2"></i></span>
													</a>
																							</div><!--nav-right-wrap-->
										</div><!--nav-menu-out-->
									</div><!--nav-logo-in-->
								</div><!--nav-logo-out-->
							</div><!--main-nav-cont-->
						</div><!--nav-in-->
					</div><!--nav-out-->
				</div><!--main-nav-wrap-->
			</div><!--head-main-wrap-->
										<div id="body-main-wrap" class="left relative" itemscope itemtype="http://schema.org/NewsArticle">
					<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/"/>
																																			<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="body-main-cont" class="left relative">
																			<div id="leader-wrap" class="left relative">
								<!-- large column top -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7138622909378284"
     data-ad-slot="9571372570"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>							</div><!--leader-wrap-->
												<!-- <div style="margin-bottom:40px">
	<h5>Send Alex to Training Camp</h5>
	<iframe class='gfm-media-widget' image='0' coinfo='0' width='100%' height='100%' frameborder='0' id='steelers-depot-2018-training-camp'></iframe>
	<script src='//funds.gofundme.com/js/5.0/media-widget.js'></script>
	<style>
	.gfm-widget {
		width: 100%;
		max-width: initial;
	}
	</style>
	<script>
	jQuery(function($){
	});
	</script>
</div> --><div id="post-main-wrap" class="left relative">
	<div class="post-wrap-out1">
		<div class="post-wrap-in1">
			<div id="post-left-col" class="relative">
	<article id="post-area" class="post-522197 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-steelers">
			<header id="post-header">
							<a class="post-cat-link" href="https://steelersdepot.com/category/article/"><span class="post-head-cat">Article</span></a>
						<h1 class="post-title entry-title left" itemprop="headline">Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020</h1>
							<div id="post-info-wrap" class="left relative">
					<div class="post-info-out">
						<div class="post-info-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/7fa7ee85674b58205a210a9bb2891f7d?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7fa7ee85674b58205a210a9bb2891f7d?s=100&#038;d=mm&#038;r=g 2x' class='avatar arm_grid_avatar arm-avatar avatar-50 photo' height='50' width='50' />						</div><!--post-info-img-->
						<div class="post-info-in">
							<div class="post-info-right left relative">
								<div class="post-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
									<span class="post-info-text">By</span> <span class="author-name vcard fn author" itemprop="name"><a href="https://steelersdepot.com/author/matthew-marczi/" title="Posts by Matthew Marczi" rel="author">Matthew Marczi</a></span> <span class="author-twitter"><a href="https://twitter.com/mmarczi" class="twitter-but" target="_blank"><i class="fa fa-twitter fa-2"></i></a></span>																	</div><!--post-info-name-->
								<div class="post-info-date left relative">
									<span class="post-info-text">Posted on</span> <span class="post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-04-09">April 9, 2020 at 6:20 am</time></span>
									<meta itemprop="dateModified" content="2020-04-09"/>
								</div><!--post-info-date-->
							</div><!--post-info-right-->
						</div><!--post-info-in-->
					</div><!--post-info-out-->
				</div><!--post-info-wrap-->
					</header><!--post-header-->
	

			<section class="social-sharing-top">
			<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/&amp;t=Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open('http://twitter.com/share?text=Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020 -&amp;url=https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
			<a href="whatsapp://send?text=Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020 https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/&amp;media=https://steelersdepot.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu.jpg&amp;description=Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="/cdn-cgi/l/email-protection#0d327e786f67686e79305e6261626062632d5a64616e62797e372d5e79686861687f7e2b2e353f3c3a362d49686b68637e682d406c66687e2d596568602d4c2d4e626379686369687f2d44632d3f3d3f3d2b6c607d364f42495430442d6b627863692d7965647e2d6c7f79646e61682d646379687f687e7964636a2d6c63692d796562786a65792d626b2d7e656c7f64636a2d64792d7a6479652d746278232d4e65686e662d64792d627879372d6579797d7e3722227e79686861687f7e69687d6279236e6260223f3d3f3d223d39227e626162606263207a64616e62797e207e79686861687f7e2069686b68637e6820606c66687e2079656860206c206e626379686369687f206463203f3d3f3d22"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
																	<a href="#disqus_thread"><div class="social-comments comment-click-522197"><i class="fa fa-commenting fa-2"></i></div></a>
									</section><!--social-sharing-top-->
	


																					<div class="left" id="post-feat-img-wrapper">
							<div id="post-feat-img" class="relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
								<img width="777" height="437" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu.jpg 777w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu-300x169.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu-768x432.jpg 768w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu-180x101.jpg 180w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu-260x146.jpg 260w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu-373x210.jpg 373w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu-120x67.jpg 120w" sizes="(max-width: 777px) 100vw, 777px" />																<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu.jpg">
								<meta itemprop="width" content="777">
								<meta itemprop="height" content="437">
								<div class="post-feat-text">
																										</div><!--post-feat-text-->
							</div><!--post-feat-img-->
						</div>
																<div id="content-area" itemprop="articleBody" class="post-522197 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-steelers">
		<div class="post-cont-out">
			<div class="post-cont-in">
				<div id="content-main" class="left relative">

						
	
		<div class="post-specific-content">
<p>The <strong>Pittsburgh Steelers</strong> enter the 2020 season having not been to the playoffs since 2017, and having not won a playoff game since 2016. They went 8-8 last season. And yet there is a good deal of optimism behind the former perennial contenders in their bid to return to that status—not without reason.</p>
<p>While so much of what they are potentially able to do will rest upon the elbow of quarterback <strong>Ben Roethlisberger</strong> and what he can get out of the surgically-repaired arm, it is the defense that is now in the driver’s seat for Pittsburgh, and is good enough to compete with in 2020.</p>
<p>That is the argument <strong>Solomon Wilcots</strong> makes for <em>Pro Football Focus</em>, <a href="https://www.pff.com/news/nfl-pittsburgh-steelers-defense-could-be-the-driving-force-behind-an-afc-contender-in-2020">putting together an article</a> demonstrating how the Steelers transformed their defense into not only an elite pass-rushing unit, but also one of the top coverage teams as well. The Steelers have been generating pressure for a while now, but the improvement in coverage last season was enormous.</p>
<p>That’s thanks in no small part to the major investments the team made in the back end last season, signing cornerback <strong>Steven Nelson</strong> in free agency and then acquiring safety <strong>Minkah Fitzpatrick</strong> via trade. The latter was a first-team All-Pro, while a prior investment, <strong>Joe Haden</strong>, made his first Pro Bowl in Pittsburgh.</p>
<p>According to the site’s numbers, Wilcots writes that the Steelers’ secondary posted the third-best completion percentage against a year ago, with the fourth-highest forced-incompletion percentage at 14.4 percent. They allowed 7.2 yards per target, sixth-best, and 54 explosive plays, also sixth.</p>
<p>Remember, these numbers are specific to the secondary, not the defense as a whole. And the numbers after Fitzpatrick was acquired in Week Three on are even better.</p>
<p>Meanwhile, the pass rush led by <strong>T.J. Watt</strong>, <strong>Bud Dupree</strong>, and <strong>Cameron Heyward</strong> produced the most sacks, the highest pressure rate, and the best win rate. As a defense, the Steelers are credited with ‘winning’ on 64.5 percent of their snaps, generating some sort of pressure on 40.4 percent of their snaps—both numbers, again, tops in the NFL.</p>
<p>Wilcots believes that even if the Steelers fail to duplicate their turnover production from last season—a feat that is rather unlikely—the unit has enough star power and performance to retain its place among the top units in the league.</p>
<p>“With a healthy Ben Roethlisberger in 2020, the Steelers will no longer be the offensive juggernaut with a defense as its Achilles heel”, he concludes. “And even if the Steelers fail to replicate the high turnover rate from one year ago, its star power on defense is undeniable. So, with the lethal combination of top-ranked pressure and coverage, the Steelers&#8217; defense makes the team a contender in the AFC for 2020”.</p>
</div>

	<div id="taboola-below-article">
	</div>

															<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
						<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
															<img src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png"/>
								<meta itemprop="url" content="https://steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png">
													</div><!--mvp-org-logo-->
						<meta itemprop="name" content="Steelers Depot">
					</div><!--mvp-org-wrap-->
					<div class="posts-nav-link">
											</div><!--posts-nav-link-->
											<div class="post-tags">
							<span class="post-tags-header">Related Items:</span><span itemprop="keywords"><a href="https://steelersdepot.com/tag/steelers/" rel="tag">Steelers</a></span>
						</div><!--post-tags-->
																<div class="social-sharing-bot">
							<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/&amp;t=Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span> <span style="color: #fff; font-family: 'Montserrat', sans-serif; font-size: 10px; font-weight: 400; line-height: 100%; padding: 8px 0; text-transform: uppercase;"></span></div></a>
							<a href="#" onclick="window.open('http://twitter.com/share?text=Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020 -&amp;url=https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
							<a href="whatsapp://send?text=Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020 https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/&amp;media=https://steelersdepot.com/wp-content/uploads/2018/03/T.J.-Watt-celebrate-Mike-Hilton-Cameron-Heyward-Tyson-Alualu.jpg&amp;description=Solomon Wilcots: Steelers&#8217; Defense Makes Them A Contender In 2020', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="/cdn-cgi/l/email-protection#f5ca8680979f909681c8a69a999a989a9bd5a29c99969a8186cfd5a681909099908786d3d6cdc7c4c2ced5b19093909b8690d5b8949e9086d5a19d9098d5b4d5b69a9b81909b919087d5bc9bd5c7c5c7c5d3949885ceb7bab1acc8bcd5939a809b91d5819d9c86d59487819c969990d59c9b8190879086819c9b92d5949b91d5819d9a80929d81d59a93d5869d94879c9b92d59c81d5829c819dd58c9a80dbd5b69d90969ed59c81d59a8081cfd59d81818586cfdada86819090999087869190859a81db969a98dac7c5c7c5dac5c1da869a999a989a9bd8829c99969a8186d88681909099908786d8919093909b8690d898949e9086d8819d9098d894d8969a9b81909b919087d89c9bd8c7c5c7c5da"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
						</div><!--social-sharing-bot-->
																            <div class="mvp-related-posts left relative">
		<h4 class="post-header"><span class="post-header">Recommended for you</span></h4>
			<ul>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2020/04/2020-offseason-questions-disappointed-you-wont-be-watching-steelers-on-hard-knocks/" rel="bookmark" title="2020 Offseason Questions: Disappointed You Won&#8217;t Be Watching Steelers On Hard Knocks?">
						<img width="300" height="180" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/07/James-Conner-Ben-Roethlisberger-training-camp-300x180.jpg" class="reg-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/07/James-Conner-Ben-Roethlisberger-training-camp-300x180.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/07/James-Conner-Ben-Roethlisberger-training-camp-1000x600.jpg 1000w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/07/James-Conner-Ben-Roethlisberger-training-camp-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/07/James-Conner-Ben-Roethlisberger-training-camp-80x80.jpg" class="mob-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/07/James-Conner-Ben-Roethlisberger-training-camp-80x80.jpg 80w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2018/07/James-Conner-Ben-Roethlisberger-training-camp-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2020/04/2020-offseason-questions-disappointed-you-wont-be-watching-steelers-on-hard-knocks/">2020 Offseason Questions: Disappointed You Won&#8217;t Be Watching Steelers On Hard Knocks?</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2020/04/buy-or-sell-steelers-top-pick-must-be-able-to-contribute-on-day-one/" rel="bookmark" title="Buy Or Sell: Steelers&#8217; Top Pick Must Be Able To Contribute On Day One">
						<img width="300" height="180" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2020/01/steelers-2020-nfl-draft-300x180.jpg" class="reg-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2020/01/steelers-2020-nfl-draft-300x180.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2020/01/steelers-2020-nfl-draft-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2020/01/steelers-2020-nfl-draft-80x80.jpg" class="mob-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2020/01/steelers-2020-nfl-draft-80x80.jpg 80w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2020/01/steelers-2020-nfl-draft-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2020/04/buy-or-sell-steelers-top-pick-must-be-able-to-contribute-on-day-one/">Buy Or Sell: Steelers&#8217; Top Pick Must Be Able To Contribute On Day One</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://steelersdepot.com/2020/03/steelers-rank-10th-on-pffs-improvement-index/" rel="bookmark" title="Steelers Rank 10th On PFF&#8217;s Improvement Index">
						<img width="300" height="180" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/04/StockColbert10-300x180.jpg" class="reg-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/04/StockColbert10-300x180.jpg 300w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/04/StockColbert10-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/04/StockColbert10-80x80.jpg" class="mob-img wp-post-image" alt="" srcset="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/04/StockColbert10-80x80.jpg 80w, https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/uploads/2019/04/StockColbert10-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://steelersdepot.com/2020/03/steelers-rank-10th-on-pffs-improvement-index/">Steelers Rank 10th On PFF&#8217;s Improvement Index</a>
				</div><!--related-text-->
            			</li>
            		</ul></div>																					<div id="disqus_thread"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
    /**
     *  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT 
     *  THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR 
     *  PLATFORM OR CMS.
     *  
     *  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: 
     *  https://disqus.com/admin/universalcode/#configuration-variables
     */
    /*
    var disqus_config = function () {
        // Replace PAGE_URL with your page's canonical URL variable
        this.page.url = PAGE_URL;  
        
        // Replace PAGE_IDENTIFIER with your page's unique identifier variable
        this.page.identifier = PAGE_IDENTIFIER; 
    };
    */


	// DISQUS.reset({
	// 	reload: true,
	// 	config: function () {  
	// 		this.page.identifier = 'steelersdepot';
	// 		this.page.url = 'https://steelersdepot.com/2020/04/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020/';
	// 	}
	// });
 //    var changeThread = function(){
 //    };


    var disqus_loaded = false;
    
	if (typeof(disqus_loaded)=="undefined" || !disqus_loaded) {
		disqus_loaded=1;
		jQuery.ajax({
			type: 'GET',
			url: 'https://steelersdepot.disqus.com/embed.js',
			dataType: 'script',
			cache: true
		});
	} 

    // (function() {
    //     var d = document, s = d.createElement('script');
        
    //     s.src = 'https://steelersdepot.disqus.com/embed.js';
    //     // s.src = 'https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/assets/js/disqus-post.js';
        
    //     s.setAttribute('data-timestamp', +new Date());
    //     (d.head || d.body).appendChild(s);
    // })();
</script>
<noscript>
    Please enable JavaScript to view the 
    <a href="https://disqus.com/?ref_noscript" rel="nofollow">
        comments powered by Disqus.
    </a>
</noscript>									</div><!--content-main-->
			</div><!--post-cont-in-->
					</div><!--post-cont-out-->
	</div><!--content-area-->
</article>
				</div><!--post-left-col-->
			</div><!--post-wrap-in1-->
			
							<div id="post-right-col" class="relative">
																		<div id="sidebar-wrap" class="left relative theiaStickySidebar">
	<div id="custom_html-29" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a target="_blank" href="https://shareasale.com/r.cfm?b=537844&amp;u=275818&amp;m=7124&amp;urllink=&amp;afftrack=" rel="noopener noreferrer"><img src="https://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></div><!--sidebar-wrap-->															</div><!--post-right-col-->
					</div><!--post-wrap-out1-->
</div><!--post-main-wrap-->
											</div><!--body-main-cont-->
				</div><!--body-main-in-->
			</div><!--body-main-out-->
		</div><!--body-main-wrap-->

		<footer id="foot-wrap" class="left relative">
			<div id="foot-top-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-widget-wrap" class="left relative">
															<div class="foot-widget left relative">
																			<div class="foot-logo left realtive">
											<img src="https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/images/logos/logo-foot.png" alt="Steelers Depot" data-rjs="2" />
										</div><!--foot-logo-->
																		<div class="foot-info-text left relative">
										<p>Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem?</p><p>Temporibus autem quibusdam et aut officiis debitis aut rerum necessitatibus saepe eveniet.</p>									</div><!--footer-info-text-->
									<div class="foot-soc left relative">
										<ul class="foot-soc-list relative">
																							<li class="foot-soc-fb">
													<a href="https://www.facebook.com/steelersdepot/" target="_blank"><i class="fa fa-facebook-square fa-2"></i></a>
												</li>
																																		<li class="foot-soc-twit">
													<a href="https://twitter.com/Steelersdepot" target="_blank"><i class="fa fa-twitter-square fa-2"></i></a>
												</li>
																																																																																																				<li class="foot-soc-rss">
													<a href="https://steelersdepot.com/feed/rss/" target="_blank"><i class="fa fa-rss-square fa-2"></i></a>
												</li>
																					</ul>
									</div><!--foot-soc-->
								</div><!--foot-widget-->
																				</div><!--foot-widget-wrap-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-top-->
			<div id="foot-bot-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-bot" class="left relative">
							<div class="foot-menu relative">
								<div class="menu-header-container"><ul id="menu-header-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520576"><a href="https://steelersdepot.com/2020-nfl-scouting-combine-results-tracker/">2020 NFL Scouting Combine Results Tracker</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520575"><a href="https://steelersdepot.com/2020/02/2020-steelers-combine-interview-masterlist-updating/">2020 Steelers Combine Interview Masterlist (Updating)</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-520730"><a href="https://steelersdepot.com/2020/03/2020-steelers-pro-day-tracker/">2020 Steelers Pro Day Tracker</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-515035"><a href="https://steelersdepot.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-515038"><a href="https://steelersdepot.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-496474"><a href="https://steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>							</div><!--foot-menu-->
							<div class="foot-copy relative">
								<p>&copy; 2020 Steelers Depot</p>
							</div><!--foot-copy-->
						</div><!--foot-bot-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-bot-->
		</footer>
	</div><!--site-wrap-->
</div><!--site-->
<div class="fly-to-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
	<span class="to-top-text">To Top</span>
</div><!--fly-to-top-->
<div class="fly-fade">
</div><!--fly-fade-->
			<script data-cfasync="false" type="text/javascript">
			function arm_open_modal_box_in_nav_menu(menu_id, form_id) {
                           
				jQuery(".arm_nav_menu_link_" + form_id).find("." + form_id).trigger("click");
				return false;
			}
			</script>
					<div data-theiaStickySidebar-sidebarSelector='"#tab-col2"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":0,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#tab-col3"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#post-right-col"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		<script>
(function (w, d) {
	var s = d.createElement('script');
	s.src = "https://dstik9906m659.cloudfront.net/eVIfRVUUblIfRlskRCEyUu.js";
	s.defer = true;
	d.body.appendChild(s);
})(window, document);
</script>

<script type="text/javascript">
jQuery(document).ready(function($) {

	// Back to Top Button
    	var duration = 500;
    	$('.back-to-top').click(function(event) {
          event.preventDefault();
          $('html, body').animate({scrollTop: 0}, duration);
          return false;
	});

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

	  	$(".comment-click-522197").on("click", function(){
  	  $(".com-click-id-522197").show();
	  $(".disqus-thread-522197").show();
  	  $(".com-but-522197").hide();
  	});
	

$(window).load(function() {
  // The slider being synced must be initialized first
  $('.post-gallery-bot').flexslider({
    animation: "slide",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    itemWidth: 80,
    itemMargin: 10,
    asNavFor: '.post-gallery-top'
  });

  $('.post-gallery-top').flexslider({
    animation: "fade",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    	  prevText: "&lt;",
          nextText: "&gt;",
    sync: ".post-gallery-bot"
  });
});

});

</script>

<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"steelersdepot"};
/* ]]> */
</script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"522197 https:\/\/steelersdepot.com\/?p=522197","disqusShortname":"steelersdepot","disqusTitle":"Solomon Wilcots: Steelers\u2019 Defense Makes Them A Contender In 2020","disqusUrl":"https:\/\/steelersdepot.com\/2020\/04\/solomon-wilcots-steelers-defense-makes-them-a-contender-in-2020\/","postId":"522197"};
/* ]]> */
</script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.6.3'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.6.3'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/js/scripts.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/js/autoloadpost.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag/js/retina.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/assets/js/_main.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-content/themes/flex-mag-child/assets/js/main.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://42rmyb1muv894309qpoieim1-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script type='text/javascript' src='https://stats.wp.com/e-202015.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'12286105',post:'522197',tz:'-4',srv:'steelersdepot.com'} ]);
	_stq.push([ 'clickTrackerInit', '12286105', '522197' ]);
</script>

	<style>
.modal {
	margin-top:200px;
}
.modal-backdrop {
	background: rgba(0,0,0,0.6);
}
.modal-body a {
	text-decoration: underline;
}
</style>
<div class="modal" id="ad-free-modal" tabindex="-1" role="dialog">
	<div class="modal-dialog" role="document">
		<div class="modal-content">
			<div class="modal-header">
				<h5 class="modal-title">Adblocker is on</h5>
				<button type="button" class="close" data-dismiss="modal" aria-label="Close">
					<span aria-hidden="true">&times;</span>
				</button>
			</div>
			<div class="modal-body">
				<p>We noticed your adblocker is on.  We use ads to fund this site and continue to bring you premium Steelers content.</p>
				<p>If you like what you see on this site, we now have an <a href="/go-ad-free">ad-free option</a> available for a donation of $25 per year, and you can enjoy the site entirely ad-free!</p>
				<p>Additionally, if you'd like to donate above and beyond the ad-free option, you can <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=XZ97MFHPQZYX4" target="_blank">donate via PayPal</a> as well.</p>
				<p>Finally, if you wish to not see this dialog box, please turn off your adblocker, and enjoy content normally</p>
				<p>Thank you for visiting Steelers Depot!</p>
			</div>
			<div class="modal-footer">
				<a href="/go-ad-free" class="btn btn-warning" style="color:white">Go Ad-Free</a>
				<button type="button" class="btn btn-dark" data-dismiss="modal">Close</button>
			</div>
		</div>
	</div>
</div></body>
</html>